- Unbreak: remove two conflicting functions, which are never used anyway.

PR:		ports/76635
Submitted by:	Johan van Selst <johans@stack.nl> (maintainer)
This commit is contained in:
Pav Lucistnik 2005-01-26 15:25:17 +00:00
parent b6dbde6672
commit e2067c1ece
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=127423
2 changed files with 20 additions and 7 deletions

View File

@ -26,12 +26,6 @@ DOCSDIR= ${PREFIX}/share/doc/KnightCap
PORTDOCS= README
PLIST_FILES= bin/KnightCap
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/KnightCap ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@ -39,4 +33,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,19 @@
--- knightcap.h Mon Jan 24 22:20:22 2005
+++ knightcap.h Mon Jan 24 22:17:19 2005
@@ -632,16 +632,6 @@
return i1 > i2? i1 : i2;
}
-static inline float fmin(float i1, float i2)
-{
- return i1 > i2? i2 : i1;
-}
-
-static inline float fmax(float i1, float i2)
-{
- return i1 > i2? i1 : i2;
-}
-
static inline etype emin(etype i1, etype i2)
{
return i1 > i2? i2 : i1;