- Update to 0.8.2
This commit is contained in:
parent
ffa134e44c
commit
e1b66ed573
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=439674
@ -2,8 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xonotic
|
||||
PORTVERSION= 0.8.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.8.2
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://nl.dl.xonotic.org/ \
|
||||
http://mirror.bitmissile.com/xonotic/releases/
|
||||
@ -12,34 +11,37 @@ MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Fast-paced, chaotic, and intense multiplayer first person shooter
|
||||
|
||||
LIB_DEPENDS= libcurl.so:ftp/curl \
|
||||
libpng.so:graphics/png
|
||||
libpng.so:graphics/png \
|
||||
libd0_blind_id.so:security/d0_blind_id \
|
||||
libd0_rijndael.so:security/d0_blind_id \
|
||||
libode.so:devel/ode
|
||||
|
||||
USES= compiler:features jpeg shebangfix zip:infozip
|
||||
USES= compiler:features gmake jpeg localbase shebangfix zip:infozip
|
||||
SHEBANG_FILES= server/rcon.pl server/rcon2irc/rcon2irc.pl
|
||||
WRKSRC= ${WRKDIR}/Xonotic
|
||||
BUILD_WRKSRC= ${WRKSRC}/source/darkplaces
|
||||
MAKEFILE= BSDmakefile
|
||||
MAKEFILE= makefile
|
||||
MAKE_ARGS= DP_FS_BASEDIR="${DATADIR}" \
|
||||
DP_PRELOAD_DEPENDENCIES=yes \
|
||||
CFLAGS_LIBJPEG="-I${LOCALBASE}/include -DLINK_TO_LIBJPEG" \
|
||||
OPTIM_RELEASE="${CFLAGS} -fno-strict-aliasing -funroll-loops" \
|
||||
OPTIM_RELEASE="${CFLAGS}" \
|
||||
STRIP="${STRIP_CMD}"
|
||||
MAKE_JOBS_UNSAFE=yes
|
||||
ALL_TARGET= # empty
|
||||
|
||||
PORTDATA= *
|
||||
|
||||
OPTIONS_DEFINE= ENCRYPTION
|
||||
OPTIONS_DEFINE= OPTIMIZED_CFLAGS
|
||||
OPTIONS_MULTI= COMPONENTS
|
||||
OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
|
||||
OPTIONS_DEFAULT= CLIENT DEDICATED ENCRYPTION
|
||||
OPTIONS_DEFAULT= CLIENT DEDICATED
|
||||
|
||||
CLIENT_DESC= Build client
|
||||
CLIENT_LIB_DEPENDS= libmodplug.so:audio/libmodplug \
|
||||
libtheora.so:multimedia/libtheora \
|
||||
CLIENT_LIB_DEPENDS= libtheora.so:multimedia/libtheora \
|
||||
libvorbis.so:audio/libvorbis \
|
||||
libvorbisenc.so:audio/libvorbis \
|
||||
libvorbisfile.so:audio/libvorbis \
|
||||
libogg.so:audio/libogg
|
||||
CLIENT_USE= SDL=sdl XORG=x11
|
||||
CLIENT_USE= SDL=sdl2 XORG=x11
|
||||
CLIENT_ALL_TARGET= sdl-release
|
||||
CLIENT_PLIST_FILES= bin/${PORTNAME} share/pixmaps/${PORTNAME}.ico
|
||||
CLIENT_DESKTOP_ENTRIES= "Xonotic" \
|
||||
@ -53,22 +55,11 @@ DEDICATED_DESC= Build dedicated server
|
||||
DEDICATED_ALL_TARGET= sv-release
|
||||
DEDICATED_PLIST_FILES= bin/${PORTNAME}-dedicated
|
||||
|
||||
ENCRYPTION_DESC= Build encryption (required for stats submission)
|
||||
ENCRYPTION_LIB_DEPENDS= libd0_rijndael.so:security/d0_blind_id
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} == 42
|
||||
# internal compiler error with base gcc
|
||||
USE_GCC= yes
|
||||
.endif
|
||||
OPTIMIZED_CFLAGS_CFLAGS= -O3 -fno-strict-aliasing -fno-math-errno -ffinite-math-only -fno-rounding-math -fno-signaling-nans -fno-trapping-math
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},' \
|
||||
${BUILD_WRKSRC}/${MAKEFILE} ${BUILD_WRKSRC}/makefile.inc
|
||||
@${REINPLACE_CMD} -e '/LDFLAGS_BSDSV/s,$$,-L${LOCALBASE}/lib,' \
|
||||
${BUILD_WRKSRC}/makefile.inc
|
||||
@${ECHO_CMD} >> ${BUILD_WRKSRC}/prvm_offsets.h # silence 'no newline' warnings
|
||||
${BUILD_WRKSRC}/makefile ${BUILD_WRKSRC}/makefile.inc
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${STAGEDIR}${DATADIR}/data
|
||||
@ -88,4 +79,4 @@ do-install-DEDICATED-on:
|
||||
do-install-ENCRYPTION-on:
|
||||
${INSTALL_DATA} ${WRKSRC}/key_0.d0pk ${STAGEDIR}${DATADIR}/
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (xonotic-0.8.1.zip) = be8bcc41e2993a2f26d4d04c65a7eab810443bd98b11b45e482ffdbbf284c46f
|
||||
SIZE (xonotic-0.8.1.zip) = 984854761
|
||||
TIMESTAMP = 1491306088
|
||||
SHA256 (xonotic-0.8.2.zip) = a22f7230f486c5825b55cfdadd73399c9b0fae98c9e081dd8ac76eca08359ad5
|
||||
SIZE (xonotic-0.8.2.zip) = 991045679
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- source/darkplaces/BSDmakefile.orig 2015-08-25 12:10:24 UTC
|
||||
+++ source/darkplaces/BSDmakefile
|
||||
@@ -158,7 +158,7 @@ LIB_SOUND=$(LIB_SND_BSD)
|
||||
|
||||
CFLAGS_MAKEDEP=-MD
|
||||
.ifdef DP_FS_BASEDIR
|
||||
-CFLAGS_FS=-DDP_FS_BASEDIR='\"$(DP_FS_BASEDIR)\"'
|
||||
+CFLAGS_FS=-DDP_FS_BASEDIR='\\\"$(DP_FS_BASEDIR)\\\"'
|
||||
.else
|
||||
CFLAGS_FS=
|
||||
.endif
|
15
games/xonotic/files/patch-source_darkplaces_makefile
Normal file
15
games/xonotic/files/patch-source_darkplaces_makefile
Normal file
@ -0,0 +1,15 @@
|
||||
--- source/darkplaces/makefile.orig 2017-04-05 10:52:46 UTC
|
||||
+++ source/darkplaces/makefile
|
||||
@@ -234,9 +234,9 @@ endif
|
||||
|
||||
DP_LINK_ZLIB?=shared
|
||||
DP_LINK_JPEG?=shared
|
||||
- DP_LINK_ODE?=dlopen
|
||||
- DP_LINK_CRYPTO?=dlopen
|
||||
- DP_LINK_CRYPTO_RIJNDAEL?=dlopen
|
||||
+ DP_LINK_ODE?=shared
|
||||
+ DP_LINK_CRYPTO?=shared
|
||||
+ DP_LINK_CRYPTO_RIJNDAEL?=shared
|
||||
endif
|
||||
|
||||
# Win32 configuration
|
Loading…
Reference in New Issue
Block a user