Reset maintainership

- While I'm here:
  - Update MASTER_SITES
  - Clean up Makefile
  - Update manpage location (r523104)
  - Update WWW
  - Take maintainership

PR:		244449
Submitted by:	Neel Chauhan <neel@neelc.org> (maintainer)
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2020-02-27 21:26:31 +00:00
parent 217d81b2ee
commit e1334adab3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=527301
3 changed files with 7 additions and 31 deletions

View File

@ -3,22 +3,21 @@
PORTNAME= countdown
PORTVERSION= 20150606
CATEGORIES= deskutils
MASTER_SITES= http://acme.com/software/countdown/
MASTER_SITES= https://acme.com/software/countdown/
DISTNAME= ${PORTNAME}_06jun2015
MAINTAINER= neel@neelc.org
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Counts down a specified time interval, beeps, then exits
LICENSE= BSD2CLAUSE
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/countdown man/man1/countdown.1.gz
WRKSRC= ${WRKDIR}/countdown
MAKEFILE= /dev/null
ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/countdown \
share/man/man1/countdown.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/countdown ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/countdown.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/countdown.1
${INSTALL_MAN} ${WRKSRC}/countdown.1 ${STAGEDIR}${MAN1PREFIX}/share/man/man1/countdown.1
.include <bsd.port.mk>

View File

@ -1,23 +0,0 @@
--- Makefile.orig 2014-08-11 19:16:15 UTC
+++ Makefile
@@ -1,15 +1,14 @@
# Makefile for countdown
-BINDIR = /usr/local/bin
-MANDIR = /usr/local/man/man1
-CC = cc
-CFLAGS = -O -ansi -pedantic -U__STRICT_ANSI__ -Wall -Wpointer-arith -Wshadow -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wno-long-long
-LDFLAGS = -s
+BINDIR= /usr/local/bin
+MANDIR= /usr/local/man/man1
+CC?= cc
+CFLAGS+= -ansi -pedantic -U__STRICT_ANSI__ -Wall -Wpointer-arith -Wshadow -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wno-long-long
all: countdown
countdown: countdown.c
- $(CC) $(CFLAGS) countdown.c $(LDFLAGS) -o countdown
+ $(CC) $(CFLAGS) countdown.c -o countdown
install: all

View File

@ -1,3 +1,3 @@
This program counts down a specified time interval, then beeps and exits.
WWW: http://www.acme.com/software/countdown/
WWW: https://acme.com/software/countdown/