- update to 4.6.1
Submitted by: Jan van Stekelenburg - make portlint happier
This commit is contained in:
parent
0ffcdaf737
commit
e09f287a7f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=416273
@ -2,33 +2,32 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xen-guest-tools
|
||||
PORTVERSION= 4.2.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 4.6.1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://bits.xensource.com/oss-xen/release/${PORTVERSION}/
|
||||
DISTNAME= xen-${PORTVERSION}
|
||||
|
||||
MAINTAINER= dinoex@FreeBSD.org
|
||||
COMMENT= Xen tools within FreeBSD domU
|
||||
|
||||
MASTER_SITES= http://bits.xensource.com/oss-xen/release/${PORTVERSION}/
|
||||
DISTFILES= xen-${PORTVERSION}.tar.gz
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash \
|
||||
${LOCALBASE}/lib/libglib-2.0.so:devel/glib20 \
|
||||
${LOCALBASE}/lib/libargp.so:devel/argp-standalone \
|
||||
${LOCALBASE}/lib/libyajl.so:devel/yajl
|
||||
|
||||
ONLY_FOR_ARCHS= amd64 i386 ia64
|
||||
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than amd64, i386, or ia64"
|
||||
CONFLICTS= xen-tools-[0-9]*
|
||||
|
||||
USES= gmake python:2.7:configure perl5 gettext-runtime:build gettext-tools:build pkgconfig
|
||||
USE_PERL5= build
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= PYTHON=${PYTHON_CMD} PYTHON_PATH=${PYTHON_CMD}
|
||||
CONFIGURE_ENV+= APPEND_LIB="${LOCALBASE}/lib"
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -I${LOCALBASE}/lib
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CONFLICTS= xen-tools-[0-9]*
|
||||
|
||||
ONLY_FOR_ARCHS= amd64 i386 ia64
|
||||
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than amd64, i386, or ia64"
|
||||
|
||||
PLIST_FILES= lib/libxenstore.so.3.0 \
|
||||
bin/xen-detect \
|
||||
bin/xenstore \
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (xen-4.2.2.tar.gz) = c9bfe91a5e72f8545acebad9889d64368020359bfe18044c0e683133e55ae005
|
||||
SIZE (xen-4.2.2.tar.gz) = 15602746
|
||||
SHA256 (xen-4.6.1.tar.gz) = 44cc2fccba1e147ef4c8da0584ce0f24189c8743de0e3e9a9226da88ddb5f589
|
||||
SIZE (xen-4.6.1.tar.gz) = 19693042
|
||||
|
@ -1,15 +1,16 @@
|
||||
--- config/StdGNU.mk.orig 2013-04-23 18:42:55.000000000 +0200
|
||||
+++ config/StdGNU.mk 2015-01-30 09:12:53.000000000 +0100
|
||||
@@ -1,10 +1,10 @@
|
||||
@@ -1,11 +1,11 @@
|
||||
AS = $(CROSS_COMPILE)as
|
||||
LD = $(CROSS_COMPILE)ld
|
||||
ifeq ($(clang),y)
|
||||
-CC = $(CROSS_COMPILE)clang
|
||||
+CC ?= $(CROSS_COMPILE)clang
|
||||
CXX = $(CROSS_COMPILE)clang++
|
||||
LD_LTO = $(CROSS_COMPILE)llvm-ld
|
||||
else
|
||||
-CC = $(CROSS_COMPILE)gcc
|
||||
+CC ?= $(CROSS_COMPILE)gcc
|
||||
CXX = $(CROSS_COMPILE)g++
|
||||
LD_LTO = $(CROSS_COMPILE)ld
|
||||
endif
|
||||
CPP = $(CC) -E
|
||||
|
Loading…
Reference in New Issue
Block a user