Today's daily wget:

o don't detect libmd5 in libwww.
o pass Referer header in recursive retrieval.

Obtained from:	wget CVS
This commit is contained in:
FUJISHIMA Satsuki 2001-12-18 19:47:45 +00:00
parent b81be70491
commit dfdba66be6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51753
6 changed files with 102 additions and 4 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= wget
PORTVERSION= 1.8
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= ftp www
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.dl.ac.uk/ccp14/ftp-mirror/wget/pub/unix/util/wget/ \
@ -25,7 +25,7 @@ USE_OPENSSL= yes
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
.endif
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOCONF= yes
CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
LIBS=-L${LOCALBASE}/lib

View File

@ -0,0 +1,32 @@
Index: configure.in
===================================================================
RCS file: /pack/anoncvs/wget/configure.in,v
retrieving revision 1.30
retrieving revision 1.31
diff -u -r1.30 -r1.31
--- configure.in 2001/12/06 10:45:26 1.30
+++ configure.in 2001/12/11 06:20:22 1.31
@@ -340,18 +340,18 @@
dnl Find an md5 implementation.
dnl
-dnl On Solaris, we use libmd5. If we're compiled with OpenSSL, use
-dnl OpenSSL's md5 support. Otherwise, use our own md5.
-
if test x$wget_need_md5 = xyes
then
MD5_OBJ='gen-md5$o'
found_md5=no
- dnl First check for Solaris md5.
+ dnl Check for the system MD5 library on Solaris. We don't check for
+ dnl something simple like "MD5Update" because there are a number of
+ dnl MD5 implementations that use that name. md5_calc is, hopefully,
+ dnl specific to the Solaris MD5 library.
if test x$found_md5 = xno; then
- AC_CHECK_LIB(md5, MD5Update, [
+ AC_CHECK_LIB(md5, md5_calc, [
AC_DEFINE(HAVE_SOLARIS_MD5)
LIBS="-lmd5 $LIBS"
found_md5=yes

View File

@ -0,0 +1,17 @@
Index: src/recur.c
===================================================================
RCS file: /pack/anoncvs/wget/src/recur.c,v
retrieving revision 1.37
retrieving revision 1.38
diff -u -r1.37 -r1.38
--- src/recur.c 2001/12/13 19:18:31 1.37
+++ src/recur.c 2001/12/18 15:22:03 1.38
@@ -237,7 +237,7 @@
int oldrec = opt.recursive;
opt.recursive = 0;
- status = retrieve_url (url, &file, &redirected, NULL, &dt);
+ status = retrieve_url (url, &file, &redirected, referer, &dt);
opt.recursive = oldrec;
if (file && status == RETROK

View File

@ -7,7 +7,7 @@
PORTNAME= wget
PORTVERSION= 1.8
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= ftp www
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.dl.ac.uk/ccp14/ftp-mirror/wget/pub/unix/util/wget/ \
@ -25,7 +25,7 @@ USE_OPENSSL= yes
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
.endif
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOCONF= yes
CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
LIBS=-L${LOCALBASE}/lib

View File

@ -0,0 +1,32 @@
Index: configure.in
===================================================================
RCS file: /pack/anoncvs/wget/configure.in,v
retrieving revision 1.30
retrieving revision 1.31
diff -u -r1.30 -r1.31
--- configure.in 2001/12/06 10:45:26 1.30
+++ configure.in 2001/12/11 06:20:22 1.31
@@ -340,18 +340,18 @@
dnl Find an md5 implementation.
dnl
-dnl On Solaris, we use libmd5. If we're compiled with OpenSSL, use
-dnl OpenSSL's md5 support. Otherwise, use our own md5.
-
if test x$wget_need_md5 = xyes
then
MD5_OBJ='gen-md5$o'
found_md5=no
- dnl First check for Solaris md5.
+ dnl Check for the system MD5 library on Solaris. We don't check for
+ dnl something simple like "MD5Update" because there are a number of
+ dnl MD5 implementations that use that name. md5_calc is, hopefully,
+ dnl specific to the Solaris MD5 library.
if test x$found_md5 = xno; then
- AC_CHECK_LIB(md5, MD5Update, [
+ AC_CHECK_LIB(md5, md5_calc, [
AC_DEFINE(HAVE_SOLARIS_MD5)
LIBS="-lmd5 $LIBS"
found_md5=yes

View File

@ -0,0 +1,17 @@
Index: src/recur.c
===================================================================
RCS file: /pack/anoncvs/wget/src/recur.c,v
retrieving revision 1.37
retrieving revision 1.38
diff -u -r1.37 -r1.38
--- src/recur.c 2001/12/13 19:18:31 1.37
+++ src/recur.c 2001/12/18 15:22:03 1.38
@@ -237,7 +237,7 @@
int oldrec = opt.recursive;
opt.recursive = 0;
- status = retrieve_url (url, &file, &redirected, NULL, &dt);
+ status = retrieve_url (url, &file, &redirected, referer, &dt);
opt.recursive = oldrec;
if (file && status == RETROK