New port: wxgtk-contrib (wxWindows contributed libraries).
This commit is contained in:
parent
d5e02ca873
commit
dfcece5a4e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93013
@ -190,6 +190,7 @@
|
||||
SUBDIR += whistlerk
|
||||
SUBDIR += wmapp
|
||||
SUBDIR += wxgtk
|
||||
SUBDIR += wxgtk-contrib
|
||||
SUBDIR += wxgtk-devel
|
||||
SUBDIR += wxgtk-docs
|
||||
SUBDIR += xbae
|
||||
|
20
x11-toolkits/wxgtk-contrib/Makefile
Normal file
20
x11-toolkits/wxgtk-contrib/Makefile
Normal file
@ -0,0 +1,20 @@
|
||||
# New ports collection makefile for: wxgtk-contrib
|
||||
# Date created: November 4, 2003
|
||||
# Whom: fjoe@FreeBSD.ORG
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTREVISION= 0
|
||||
PKGNAMESUFFIX= -contrib
|
||||
|
||||
MAINTAINER= fjoe@FreeBSD.org
|
||||
COMMENT= The wxWindows GUI toolkit contributed libraries
|
||||
|
||||
BUILD_WRKSRC= ${WRKSRC}/contrib/src
|
||||
INSTALL_WRKSRC= ${BUILD_WRKSRC}
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../wxgtk-devel
|
||||
PLIST= ${PKGDIR}/pkg-plist.contrib
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
10
x11-toolkits/wxgtk-devel/files/patch-contrib-src-Makefile.in
Normal file
10
x11-toolkits/wxgtk-devel/files/patch-contrib-src-Makefile.in
Normal file
@ -0,0 +1,10 @@
|
||||
--- contrib/src/Makefile.in.orig Tue Nov 4 04:29:40 2003
|
||||
+++ contrib/src/Makefile.in Tue Nov 4 04:29:51 2003
|
||||
@@ -1,6 +1,6 @@
|
||||
# $Id: Makefile.in,v 1.13.2.1 2003/07/28 08:23:09 VS Exp $
|
||||
|
||||
-CONTRIB_SUBDIRS=canvas fl gizmos mmedia net ogl plot stc svg xrc animate #applet
|
||||
+CONTRIB_SUBDIRS=canvas fl gizmos net ogl plot stc svg xrc #animate applet mmedia
|
||||
|
||||
all:
|
||||
@for d in $(CONTRIB_SUBDIRS); do (cd $$d && $(MAKE)); done
|
57
x11-toolkits/wxgtk-devel/files/patch-src-makelib.env.in
Normal file
57
x11-toolkits/wxgtk-devel/files/patch-src-makelib.env.in
Normal file
@ -0,0 +1,57 @@
|
||||
--- src/makelib.env.in.orig Tue Nov 4 05:00:26 2003
|
||||
+++ src/makelib.env.in Tue Nov 4 05:01:53 2003
|
||||
@@ -34,9 +34,10 @@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
|
||||
-TARGETLIB_STATIC = $(TARGET_LIBNAME).a
|
||||
-TARGETLIB_SHARED = $(TARGET_LIBNAME).so.$(LIBVERSION_CURRENT).$(LIBVERSION_REVISION).$(LIBVERSION_AGE)
|
||||
-TARGETLIB_LINK1 = $(TARGET_LIBNAME).so.$(LIBVERSION_CURRENT)
|
||||
+target_libname = $(TARGET_LIBNAME:-@WX_MAJOR_VERSION_NUMBER@.@WX_MINOR_VERSION_NUMBER@=)
|
||||
+TARGETLIB_STATIC = $(target_libname).a
|
||||
+TARGETLIB_SHARED = $(target_libname).so.$(LIBVERSION_CURRENT)
|
||||
+TARGETLIB_LINK1 = $(target_libname).so
|
||||
TARGETLIB_LINK2 = $(TARGET_LIBNAME).so
|
||||
|
||||
TARGETLIB_SONAME = @WX_TARGET_LIBRARY_SONAME@
|
||||
@@ -72,9 +73,8 @@
|
||||
@$(INSTALL) -d $(top_builddir)/lib
|
||||
$(SHARED_LD) $@ $(TARGETLIB_SONAME) $(OBJECTS) $(LDFLAGS_VERSIONING)
|
||||
cd $(top_builddir)/lib \
|
||||
- && $(RM) $(TARGETLIB_LINK1) $(TARGETLIB_LINK2) \
|
||||
- && $(LN_S) $(TARGETLIB_SHARED) $(TARGETLIB_LINK1) \
|
||||
- && $(LN_S) $(TARGETLIB_SHARED) $(TARGETLIB_LINK2)
|
||||
+ && $(RM) $(TARGETLIB_LINK1) \
|
||||
+ && $(LN_S) $(TARGETLIB_SHARED) $(TARGETLIB_LINK1)
|
||||
|
||||
$(top_builddir)/lib/$(TARGETLIB_STATIC): $(OBJECTS)
|
||||
@$(INSTALL) -d $(top_builddir)/lib
|
||||
@@ -86,10 +86,9 @@
|
||||
|
||||
install_so:
|
||||
$(INSTALL_PROGRAM) $(top_builddir)/lib/$(TARGETLIB_SHARED) $(libdir)/$(TARGETLIB_SHARED)
|
||||
- @$(RM) $(libdir)/$(TARGETLIB_LINK1) $(libdir)/$(TARGETLIB_LINK2)
|
||||
+ @$(RM) $(libdir)/$(TARGETLIB_LINK1)
|
||||
cd $(libdir) \
|
||||
- && $(LN_S) $(TARGETLIB_SHARED) $(TARGETLIB_LINK1) \
|
||||
- && $(LN_S) $(TARGETLIB_SHARED) $(TARGETLIB_LINK2)
|
||||
+ && $(LN_S) $(TARGETLIB_SHARED) $(TARGETLIB_LINK1)
|
||||
|
||||
install_a:
|
||||
$(INSTALL_PROGRAM) $(top_builddir)/lib/$(TARGETLIB_STATIC) $(libdir)/$(TARGETLIB_STATIC)
|
||||
@@ -105,7 +104,6 @@
|
||||
$(RM) $(libdir)/$(TARGETLIB_STATIC)
|
||||
$(RM) $(libdir)/$(TARGETLIB_SHARED)
|
||||
$(RM) $(libdir)/$(TARGETLIB_LINK1)
|
||||
- $(RM) $(libdir)/$(TARGETLIB_LINK2)
|
||||
@echo "removing headers"
|
||||
@for h in $(HEADERS); do \
|
||||
$(RM) $(includedir)/wx/$(HEADER_SUBDIR)/$$h; \
|
||||
@@ -118,7 +116,6 @@
|
||||
clean:
|
||||
$(RM) $(OBJECTS) $(top_builddir)/lib/$(TARGETLIB_SHARED) \
|
||||
$(top_builddir)/lib/$(TARGETLIB_LINK1) \
|
||||
- $(top_builddir)/lib/$(TARGETLIB_LINK2) \
|
||||
$(top_builddir)/lib/$(TARGETLIB_STATIC) core
|
||||
|
||||
.PHONY: all libtype_so libtype_a install install_so install_a install_headers uninstall clean
|
115
x11-toolkits/wxgtk-devel/pkg-plist.contrib
Normal file
115
x11-toolkits/wxgtk-devel/pkg-plist.contrib
Normal file
@ -0,0 +1,115 @@
|
||||
include/wx/canvas/bbox.h
|
||||
include/wx/canvas/canvas.h
|
||||
include/wx/canvas/liner.h
|
||||
include/wx/canvas/polygon.h
|
||||
include/wx/fl/antiflickpl.h
|
||||
include/wx/fl/bardragpl.h
|
||||
include/wx/fl/barhintspl.h
|
||||
include/wx/fl/cbcustom.h
|
||||
include/wx/fl/controlbar.h
|
||||
include/wx/fl/dynbarhnd.h
|
||||
include/wx/fl/dyntbar.h
|
||||
include/wx/fl/dyntbarhnd.h
|
||||
include/wx/fl/fldefs.h
|
||||
include/wx/fl/frmview.h
|
||||
include/wx/fl/garbagec.h
|
||||
include/wx/fl/gcupdatesmgr.h
|
||||
include/wx/fl/hintanimpl.h
|
||||
include/wx/fl/newbmpbtn.h
|
||||
include/wx/fl/panedrawpl.h
|
||||
include/wx/fl/rowdragpl.h
|
||||
include/wx/fl/rowlayoutpl.h
|
||||
include/wx/fl/toolwnd.h
|
||||
include/wx/fl/updatesmgr.h
|
||||
include/wx/gizmos/dynamicsash.h
|
||||
include/wx/gizmos/editlbox.h
|
||||
include/wx/gizmos/ledctrl.h
|
||||
include/wx/gizmos/multicell.h
|
||||
include/wx/gizmos/splittree.h
|
||||
include/wx/net/email.h
|
||||
include/wx/net/msg.h
|
||||
include/wx/net/web.h
|
||||
include/wx/ogl/basic.h
|
||||
include/wx/ogl/basicp.h
|
||||
include/wx/ogl/bmpshape.h
|
||||
include/wx/ogl/canvas.h
|
||||
include/wx/ogl/composit.h
|
||||
include/wx/ogl/constrnt.h
|
||||
include/wx/ogl/divided.h
|
||||
include/wx/ogl/drawn.h
|
||||
include/wx/ogl/drawnp.h
|
||||
include/wx/ogl/lines.h
|
||||
include/wx/ogl/linesp.h
|
||||
include/wx/ogl/mfutils.h
|
||||
include/wx/ogl/misc.h
|
||||
include/wx/ogl/ogl.h
|
||||
include/wx/ogl/ogldiag.h
|
||||
include/wx/plot/plot.h
|
||||
include/wx/stc/stc.h
|
||||
include/wx/svg/dcsvg.h
|
||||
include/wx/xrc/xh_all.h
|
||||
include/wx/xrc/xh_bmp.h
|
||||
include/wx/xrc/xh_bmpbt.h
|
||||
include/wx/xrc/xh_bttn.h
|
||||
include/wx/xrc/xh_cald.h
|
||||
include/wx/xrc/xh_chckb.h
|
||||
include/wx/xrc/xh_chckl.h
|
||||
include/wx/xrc/xh_choic.h
|
||||
include/wx/xrc/xh_combo.h
|
||||
include/wx/xrc/xh_dlg.h
|
||||
include/wx/xrc/xh_frame.h
|
||||
include/wx/xrc/xh_gauge.h
|
||||
include/wx/xrc/xh_gdctl.h
|
||||
include/wx/xrc/xh_html.h
|
||||
include/wx/xrc/xh_listb.h
|
||||
include/wx/xrc/xh_listc.h
|
||||
include/wx/xrc/xh_menu.h
|
||||
include/wx/xrc/xh_notbk.h
|
||||
include/wx/xrc/xh_panel.h
|
||||
include/wx/xrc/xh_radbt.h
|
||||
include/wx/xrc/xh_radbx.h
|
||||
include/wx/xrc/xh_scrol.h
|
||||
include/wx/xrc/xh_scwin.h
|
||||
include/wx/xrc/xh_sizer.h
|
||||
include/wx/xrc/xh_slidr.h
|
||||
include/wx/xrc/xh_spin.h
|
||||
include/wx/xrc/xh_split.h
|
||||
include/wx/xrc/xh_stbmp.h
|
||||
include/wx/xrc/xh_stbox.h
|
||||
include/wx/xrc/xh_stlin.h
|
||||
include/wx/xrc/xh_sttxt.h
|
||||
include/wx/xrc/xh_text.h
|
||||
include/wx/xrc/xh_toolb.h
|
||||
include/wx/xrc/xh_tree.h
|
||||
include/wx/xrc/xh_unkwn.h
|
||||
include/wx/xrc/xh_wizrd.h
|
||||
include/wx/xrc/xml.h
|
||||
include/wx/xrc/xmlres.h
|
||||
lib/libwx_gtk_canvas.so
|
||||
lib/libwx_gtk_canvas.so.0
|
||||
lib/libwx_gtk_dcsvg.so
|
||||
lib/libwx_gtk_dcsvg.so.0
|
||||
lib/libwx_gtk_fl.so
|
||||
lib/libwx_gtk_fl.so.0
|
||||
lib/libwx_gtk_gizmos.so
|
||||
lib/libwx_gtk_gizmos.so.0
|
||||
lib/libwx_gtk_net.so
|
||||
lib/libwx_gtk_net.so.0
|
||||
lib/libwx_gtk_ogl.so
|
||||
lib/libwx_gtk_ogl.so.0
|
||||
lib/libwx_gtk_plot.so
|
||||
lib/libwx_gtk_plot.so.0
|
||||
lib/libwx_gtk_stc.so
|
||||
lib/libwx_gtk_stc.so.0
|
||||
lib/libwx_gtk_xrc.so
|
||||
lib/libwx_gtk_xrc.so.0
|
||||
@dirrm include/wx/xrc
|
||||
@dirrm include/wx/svg
|
||||
@dirrm include/wx/stc
|
||||
@dirrm include/wx/plot
|
||||
@dirrm include/wx/ogl
|
||||
@dirrm include/wx/net
|
||||
@dirrm include/wx/gizmos
|
||||
@dirrm include/wx/fl
|
||||
@dirrm include/wx/canvas
|
||||
@unexec rmdir %D/include/wx 2>/dev/null || true
|
20
x11-toolkits/wxgtk24-contrib/Makefile
Normal file
20
x11-toolkits/wxgtk24-contrib/Makefile
Normal file
@ -0,0 +1,20 @@
|
||||
# New ports collection makefile for: wxgtk-contrib
|
||||
# Date created: November 4, 2003
|
||||
# Whom: fjoe@FreeBSD.ORG
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTREVISION= 0
|
||||
PKGNAMESUFFIX= -contrib
|
||||
|
||||
MAINTAINER= fjoe@FreeBSD.org
|
||||
COMMENT= The wxWindows GUI toolkit contributed libraries
|
||||
|
||||
BUILD_WRKSRC= ${WRKSRC}/contrib/src
|
||||
INSTALL_WRKSRC= ${BUILD_WRKSRC}
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../wxgtk-devel
|
||||
PLIST= ${PKGDIR}/pkg-plist.contrib
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
Loading…
Reference in New Issue
Block a user