Add nbsmtp 0.8, simple program for outgoing SMTP delivery.

PR:		27096
Submitted by:	Anders Nordby <anders@fix.no>
This commit is contained in:
Will Andrews 2001-05-20 03:25:18 +00:00
parent 3911ac5b81
commit df90566360
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42783
7 changed files with 54 additions and 0 deletions

View File

@ -87,6 +87,7 @@
SUBDIR += muttzilla
SUBDIR += nail
SUBDIR += namg
SUBDIR += nbsmtp
SUBDIR += newmail
SUBDIR += nmh
SUBDIR += nullmailer

22
mail/nbsmtp/Makefile Normal file
View File

@ -0,0 +1,22 @@
# New ports collection makefile for: nbsmtp
# Date created: 5 May 2001
# Whom: Anders Nordby <anders@fix.no>
#
# $FreeBSD$
#
PORTNAME= nbsmtp
PORTVERSION= 0.8
CATEGORIES= mail
MASTER_SITES= http://www2.fastdial.net/~drysdam/software/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
EXTRACT_SUFX= .tgz
MAINTAINER= anders@fix.no
NO_WRKSUBDIR= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nbsmtp ${PREFIX}/bin/
.include <bsd.port.mk>

1
mail/nbsmtp/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (nbsmtp-0.8.tgz) = 88e43a1d9d22210a4c9beba57ba96058

View File

@ -0,0 +1,10 @@
--- Makefile.orig Sat May 5 19:30:42 2001
+++ Makefile Sat May 5 19:31:41 2001
@@ -1,5 +1,5 @@
-linux: nbsmtp.c
- gcc -o nbsmtp nbsmtp.c
+all: nbsmtp.c
+ gcc $(CFLAGS) -o nbsmtp nbsmtp.c
solaris: nbsmtp.c
gcc -o nbsmtp nbsmtp.c -lxnet

1
mail/nbsmtp/pkg-comment Normal file
View File

@ -0,0 +1 @@
Simple program for outgoing SMTP delivery

18
mail/nbsmtp/pkg-descr Normal file
View File

@ -0,0 +1,18 @@
No-Brainer SMTP is for people who just need a plain old SMTP outgoing delivery
system. Nothing as fancy as qmail or, heaven forbid, sendmail. It just has 3
required parameters (and 2 optional ones).
Usage:
nbsmtp -d domain -f from@addr -h host [-p port] [-l debuglevel]
domain: The domain you want nbsmtp to say it belongs to. This will
almost invariably be the same as the domain in your email address.
from@addr: This is the address you want nbsmtp to say the message is from. Note
that this can be different than the "From:" line in your MUA.
host: This is the smtp server you are sending to.
port: The smtp port you want to connect to. 25 is standard, don't change it
unless you know what you are doing.
WWW: http://www2.fastdial.net/~drysdam/software/software.html
- Anders Nordby <anders@fix.no>

1
mail/nbsmtp/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/nbsmtp