Added patches to get it compiling on -current.

Informed maitna.er
This commit is contained in:
Edwin Groothuis 2003-10-16 05:38:54 +00:00
parent d01c77a494
commit df41c55859
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=91399
2 changed files with 43 additions and 9 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= mod_watch
PORTVERSION= 3.12
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.snert.com/Software/mod_watch/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
@ -32,12 +33,6 @@ DOCS= apache2mrtg.html index.shtml mailto.js mod_watch.html style.css
DOCS_HTMLIMAGES= apache-header-476-62.png mrpixel.gif mrtg-bar.png \
sun-logo.jpg wave1.jpg
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 501000
BROKEN= "Does not compile"
.endif
post-patch:
${PERL} -pi -e "s@^APXS.*@@" ${WRKSRC}/Makefile
@ -60,4 +55,4 @@ do-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,5 +1,5 @@
--- mod_watch.c.orig Thu Mar 14 12:44:07 2002
+++ mod_watch.c Mon Oct 28 00:48:48 2002
--- mod_watch.c.orig Thu Mar 14 03:44:07 2002
+++ mod_watch.c Wed Oct 15 22:37:21 2003
@@ -41,6 +41,10 @@
* ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
*/
@ -11,3 +11,42 @@
#ifndef SPOOLDIR
#define SPOOLDIR "/var/spool/mod_watch/"
#endif
@@ -1037,22 +1041,22 @@
if (shLock(shtable) && MutexLock(mutex))
goto error0;
- ap_rprintf(r, "
-<html>
-<style type='text/css'>
-th {
- font-family: Verdana, Arial, Helvetica, sans-serif;
- font-size: 10pt;
- background-color: #0080D7;
- color: #ffffff;
-}
-.normal, p, ul, td {
- font-family: Verdana, Arial, Helvetica, sans-serif;
- font-size: 10pt;
- color: #000000;
-}
-</style>
-<body>
+ ap_rprintf(r, "\n\
+<html>\n\
+<style type='text/css'>\n\
+th {\n\
+ font-family: Verdana, Arial, Helvetica, sans-serif;\n\
+ font-size: 10pt;\n\
+ background-color: #0080D7;\n\
+ color: #ffffff;\n\
+}\n\
+.normal, p, ul, td {\n\
+ font-family: Verdana, Arial, Helvetica, sans-serif;\n\
+ font-size: 10pt;\n\
+ color: #000000;\n\
+}\n\
+</style>\n\
+<body>\n\
"
);