- Update to match editors/emacs
PR: ports/82916 Submitted by: NAKAJI Hiroyuki <nakaji@jp.freebsd.org> (maintainer)
This commit is contained in:
parent
39eb85576c
commit
df3f16b5bc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=138677
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= emcws
|
||||
PORTVERSION= ${EMACS_VER}
|
||||
PORTREVISION= 6
|
||||
PORTREVISION= 7
|
||||
CATEGORIES= japanese editors ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= emacs
|
||||
@ -149,6 +149,13 @@ EMACS_BASE=${PREFIX}
|
||||
EMACS_BASE=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "ia64"
|
||||
CFLAGS:= ${CFLAGS:C/-O.?/-O0/g}
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
@${CAT} ${FILESDIR}/emcws-message
|
||||
.if !defined(WITH_MENUBAR_FONTSET)
|
||||
@ -215,4 +222,4 @@ post-install:
|
||||
@${ECHO_MSG} "====>"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
11
japanese/emacs-emcws/files/patch-lib-src:movemail.c
Normal file
11
japanese/emacs-emcws/files/patch-lib-src:movemail.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- lib-src/movemail.c.orig Mon Feb 14 11:29:49 2005
|
||||
+++ lib-src/movemail.c Mon Feb 14 11:33:06 2005
|
||||
@@ -787,7 +787,7 @@
|
||||
mbx_delimit_begin (mbf);
|
||||
if (pop_retr (server, i, mbf) != OK)
|
||||
{
|
||||
- error (Errmsg, 0, 0);
|
||||
+ error ("%s", Errmsg, 0);
|
||||
close (mbfi);
|
||||
return (1);
|
||||
}
|
13
japanese/emacs-emcws/files/patch-src:Makefile.in
Normal file
13
japanese/emacs-emcws/files/patch-src:Makefile.in
Normal file
@ -0,0 +1,13 @@
|
||||
--- src/Makefile.in.orig Mon Dec 17 23:09:32 2001
|
||||
+++ src/Makefile.in Mon Oct 21 13:37:26 2002
|
||||
@@ -155,6 +155,10 @@
|
||||
/* This holds special options for linking temacs
|
||||
that should be used for linking anything else. */
|
||||
#ifndef LD_SWITCH_SYSTEM_TEMACS
|
||||
+#if defined(__FreeBSD_version) && (__FreeBSD_version >= 500042)
|
||||
+#define LD_SWITCH_SYSTEM_TEMACS -znocombreloc
|
||||
+#else
|
||||
#define LD_SWITCH_SYSTEM_TEMACS
|
||||
+#endif
|
||||
#endif
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- src/s/freebsd.h.orig Tue Feb 20 19:52:17 2001
|
||||
+++ src/s/freebsd.h Sat Nov 16 21:46:03 2002
|
||||
+++ src/s/freebsd.h Mon Feb 18 11:51:50 2002
|
||||
@@ -68,6 +68,11 @@
|
||||
#define LIBS_SYSTEM -lutil
|
||||
#if __FreeBSD_version < 400000
|
||||
@ -12,11 +12,3 @@
|
||||
#endif
|
||||
|
||||
#define SYSV_SYSTEM_DIR
|
||||
@@ -220,3 +225,7 @@
|
||||
of sigblock says it is obsolete. */
|
||||
|
||||
#define POSIX_SIGNALS 1
|
||||
+
|
||||
+#if __FreeBSD_version >= 500000
|
||||
+#define LD_SWITCH_SYSTEM_TEMACS -znocombreloc
|
||||
+#endif
|
||||
|
11
japanese/emacs-emcws/files/patch-src:xterm.h
Normal file
11
japanese/emacs-emcws/files/patch-src:xterm.h
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/xterm.h.orig Mon Feb 28 13:53:40 2005
|
||||
+++ src/xterm.h Mon Feb 28 13:53:57 2005
|
||||
@@ -21,8 +21,8 @@
|
||||
|
||||
#include <X11/Xlib.h>
|
||||
#include <X11/cursorfont.h>
|
||||
-#include <X11/Xutil.h>
|
||||
#include <X11/keysym.h>
|
||||
+#include <X11/Xutil.h>
|
||||
#include <X11/Xatom.h>
|
||||
#include <X11/Xresource.h>
|
Loading…
Reference in New Issue
Block a user