- Port completely superseded and replaced by archivers/star

archivers/star-devel
This commit is contained in:
Martin Matuska 2009-12-26 10:26:55 +00:00
parent 63f914218e
commit df2813e03c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=246701
8 changed files with 1 additions and 123 deletions

1
MOVED
View File

@ -4238,3 +4238,4 @@ sysutils/freebsd-sha1||2009-12-24|Incorporated into base system long ago
sysutils/freebsd-sha256||2009-12-24|Incorporated into base system long ago
irc/znc-extras||2009-12-24|Has expired: Migrate to irc/znc instead
games/love|devel/love|2009-12-26|Move to better category
archivers/star-devel||2009-12-26|Removed

View File

@ -156,7 +156,6 @@
SUBDIR += sharutils
SUBDIR += squsq
SUBDIR += star
SUBDIR += star-devel
SUBDIR += stuffit
SUBDIR += szip
SUBDIR += tardy

View File

@ -1,57 +0,0 @@
# New ports collection makefile for: star-devel
# Date created: 19.06.2004 22:27:00 CEST
# Whom: Martin Matuska <mm@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= star
DISTVERSION= 1.5
PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= ftp://ftp.berlios.de/pub/star/
MAINTAINER= mm@FreeBSD.org
COMMENT= Unique standard tape archiver with many enhancements
BUILD_DEPENDS= ${LOCALBASE}/bin/smake:${PORTSDIR}/devel/smake
CONFLICTS= star-1.4*
LATEST_LINK= star-devel
USE_BZIP2= yes
USE_GETTEXT= yes
USE_ICONV= yes
.if !defined(NO_INSTALL_MANPAGES)
MAN1= star.1
MAN5= star.5
MLINKS= star.1 ustar.1 star.5 ustar.5
.else
XMKFLAGS= XMK_FILE=""
.endif
MAKE_ENV+= MAKEFLAGS=${MAKEFLAGS}
PORTDOCS= README README.crash README.mtio README.pattern STARvsGNUTAR \
README.ACL README.largefiles README.otherbugs \
README.posix-2001
do-build:
@cd ${WRKSRC} && ${MAKE_ENV} ${LOCALBASE}/bin/smake
@cd ${WRKSRC}/star && ${MAKE_ENV} ${LOCALBASE}/bin/smake -f Makefile.doc
do-install:
@cd ${WRKSRC}/star && ${MAKE_ENV} ${LOCALBASE}/bin/smake \
${INSTALL_TARGET} INS_BASE=${PREFIX} ${XMKFLAGS}
@${STRIP_CMD} ${PREFIX}/bin/star
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/star/${FILE} ${DOCSDIR}/${FILE}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
MD5 (star-1.5.tar.bz2) = a7b1a5e830935cc1bf1001a558c7f8c4
SHA256 (star-1.5.tar.bz2) = 6dbb345d75c88d70ebdea04b13b80d7f3e9cf5d29316d803a355afd03df2723f
SIZE (star-1.5.tar.bz2) = 783704

View File

@ -1,21 +0,0 @@
--- star/Makefile.orig 2008-04-06 20:02:25.000000000 +0200
+++ star/Makefile 2008-05-16 10:49:50.928160632 +0200
@@ -15,7 +15,7 @@
INSDIR= bin
TARGET= star
#SYMLINKS= ustar tar
-SYMLINKS= ustar tar gnutar suntar scpio spax
+SYMLINKS= ustar
CPPOPTS += -D__STAR__
CPPOPTS += -DSET_CTIME -DFIFO -DUSE_MMAP -DUSE_REMOTE -DUSE_RCMD_RSH
#CPPOPTS += -DSET_CTIME -DFIFO -DUSE_MMAP
@@ -52,8 +52,7 @@
#
# Wenn -lfind, dann auch $(LIB_INTL)
#
-XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \
- spaxman.mk suntarman.mk Makefile.dfl Makefile.doc
+XMK_FILE= Makefile.man starformatman.mk
star_fat.c: star.c
$(RM) $(RM_FORCE) $@; cp star.c $@

View File

@ -1,17 +0,0 @@
--- star/star.1.orig Thu Nov 24 21:05:10 2005
+++ star/star.1 Thu Nov 24 21:06:26 2005
@@ -32,14 +32,6 @@
.I file1 .\|.\|. filen
[\fIfind_expr\fP]
.br
-.ie n .B "tar\ \ "
-.el .B "tar\ \ \ "
-.I command
-[\fIoptions\fP]
-.ie n .B "\ \ \ \ \ \ \ "
-.el .B "\ \ \ \ \ \ \ \ \ "
-.I file1 .\|.\|. filen
-.br
.B "star\ "
.ie n .B "\-copy\ \ "
.el .B "\-copy\ \ \ \ "

View File

@ -1,22 +0,0 @@
Star is the fastest known implementation of a tar archiver.
This is the development version of star.
Main advantages over other tar implementations:
fifo - Keeps the tape streaming.
pattern matcher - For a convenient user interface.
sophisticated diff - User tailorable interface for comparing tar
archives against file trees.
no namelen limitation - Pathnames up to 1024 Bytes may be archived.
deals with all 3 times - Stores/restores all 3 times of a file.
does not clobber files - More recent copies on disk will not be
clobbered from tape.
automatic byte swap - star automatically detects swapped archives.
automatic format detect - Automatically detects archive formats:
old tar, gnu tar, ansi tar, star.
fully ansi compatible - star is fully ANSI/Posix 1003.1 compatible.
WWW: http://cdrecord.berlios.de/old/private/star.html
Author: Joerg Schilling <js@cs.tu-berlin.de>
Please mail bugs and suggestions to him.

View File

@ -1,2 +0,0 @@
bin/star
bin/ustar