Update to 0.1.20

This commit is contained in:
Emanuel Haupt 2010-05-17 11:33:50 +00:00
parent 8903287a84
commit df11c215ec
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=254485
7 changed files with 27 additions and 104 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= ocp
PORTVERSION= 0.1.18
PORTREVISION= 1
PORTVERSION= 0.1.20
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= http://stian.cubic.org/ocp/ \
@ -28,6 +27,7 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE= yes
WANT_GNOME= desktopfileutils
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@ -40,8 +40,11 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} ${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-dir-suffix="" \
--without-alsa \
--libdir=${LOCALBASE}/lib
INFO= ocp
TIMIDITY_CFG= ${LOCALBASE}/share/timidity/timidity.cfg
PFILES= configure cpiface/cpianal.c cpiface/cpidots.c \
@ -60,8 +63,6 @@ OPTIONS= ADPLUG "Build with adplug support" on \
X11 "Build with X11 support" on \
SDL "Build with SDL support" on
PORTSCOUT= skipv:0.1.19
.include <bsd.port.pre.mk>
.if exists(${TIMIDITY_CFG}) || !defined(WITHOUT_MIDI)
@ -72,16 +73,12 @@ RUN_DEPENDS+= ${TIMIDITY_CFG}:${PORTSDIR}/audio/eawpats
CONFIGURE_ARGS+= --without-x11
PLIST_SUB+= XORG="@comment "
.else
USE_XORG= xxf86dga xxf86vm xpm
USE_XORG= xxf86dga xxf86vm xpm
USE_GNOME= desktopfileutils
CONFIGURE_ARGS+= --with-x11=yes
PLIST_SUB+= XORG=""
.endif
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --with-debug
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-*
.endif
.if defined(WITH_ADPLUG)
LIB_DEPENDS+= adplug-2.2:${PORTSDIR}/audio/libadplug
CONFIGURE_ARGS+= --with-adplug
@ -93,6 +90,7 @@ CONFIGURE_ARGS+= --without-adplug
.if defined(WITH_SDL)
USE_SDL= sound
USE_GNOME+= desktopfileutils
CONFIGURE_ARGS+= --with-sdl=yes
PLIST_SUB+= SDL=""
.else
@ -100,6 +98,12 @@ CONFIGURE_ARGS+= --with-sdl=no
PLIST_SUB+= SDL="@comment "
.endif
.if defined(WITH_SDL) || defined(WITH_X11)
PLIST_SUB+= DESKTOP=""
.else
PLIST_SUB+= DESKTOP="@comment "
.endif
.if defined(WITH_FLAC)
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
CONFIGURE_ARGS+= --with-flac
@ -118,11 +122,6 @@ LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
.endif
post-patch:
.if defined(WITH_DEBUG)
@${REINPLACE_CMD} -e 's|/\*\ \(#define\ LD_DEBUG\ 1\)\ \*/|\1|' \
${WRKSRC}/config.h.in
.endif
@${REINPLACE_CMD} -e 's|stdint\.h|inttypes\.h|' ${WRKSRC}/types.h
@${REINPLACE_CMD} -e 's|/etc/.*\.cfg|${TIMIDITY_CFG}|' \
${WRKSRC}/playgmi/gmitimidity.c
# conflicts with fnmatch.h from security/heimdal

View File

@ -1,3 +1,3 @@
MD5 (ocp-0.1.18.tar.gz) = 7e1118126160f92aa7e52c728ac1439d
SHA256 (ocp-0.1.18.tar.gz) = 0cb1c97f731ba7748cc135f1728f99fc14b154e021fad4c2a7cd39d91fe22a81
SIZE (ocp-0.1.18.tar.gz) = 827309
MD5 (ocp-0.1.20.tar.gz) = 225fd5b39bc20d9b0ce3dc7e3823180d
SHA256 (ocp-0.1.20.tar.gz) = 625aef6c43baefd3ab854f9fca22163f63366ed8df4e5125510a8e9b4ee0b6e4
SIZE (ocp-0.1.20.tar.gz) = 898906

View File

@ -1,11 +0,0 @@
--- ./config.h.in.orig 2009-06-27 12:15:43.000000000 +0200
+++ ./config.h.in 2009-09-21 14:22:56.000000000 +0200
@@ -135,7 +135,7 @@
/* #define INITCLOSE_DEBUG 1*/
/* #define LD_DEBUG 1 */
/* #define TIMER_DEBUG 1 */
-/* #define OSS_DEBUG 1 */
+#define OSS_DEBUG 1
/* #define ALSA_DEBUG 1 */
/* #define OSS_LOCK_DEBUG 1 */
/* #define S3M_LOAD_DEBUG 1 */

View File

@ -1,5 +1,5 @@
--- Makefile.in.orig 2009-06-27 12:15:43.000000000 +0200
+++ Makefile.in 2009-09-20 14:26:13.000000000 +0200
--- Makefile.in.orig 2010-05-17 11:55:17.000000000 +0200
+++ Makefile.in 2010-05-17 12:44:57.000000000 +0200
@@ -35,8 +35,8 @@
@ -11,30 +11,3 @@
mkdir -p "$(DESTDIR)$(PREFIX)/share/ocp$(DIR_SUFFIX)/data"
$(CP) ocp.hlp "$(DESTDIR)$(PREFIX)/share/ocp$(DIR_SUFFIX)/data"
mkdir -p "$(DESTDIR)$(PREFIX)/share/ocp$(DIR_SUFFIX)/etc"
@@ -52,7 +52,7 @@
if ! test -z $(DIR_SUFFIX); then ln -sf "ocp$(DIR_SUFFIX)" "$(DESTDIR)$(BINDIR)/ocp"; fi
$(CP) ultrafix.sh "$(DESTDIR)$(BINDIR)/ultrafix.sh"
mkdir -p "$(DESTDIR)$(ULTRADIR)"
- $(MAKE) -C doc DESTDIR="$(DESTDIR)" install TOPDIR="../$(TOPDIR)"
+ $(DOCS)$(MAKE) -C doc DESTDIR="$(DESTDIR)" install TOPDIR="../$(TOPDIR)"
ifeq ($(HAVE_X11),1)
mkdir -p "$(DESTDIR)$(PREFIX)/share/applications" "$(DESTDIR)$(PREFIX)/share/icons/hicolor/16x16/apps/" "$(DESTDIR)$(PREFIX)/share/icons/hicolor/48x48/apps/" "$(DESTDIR)$(SYSCONFDIR)/X11/wmconfig"
$(CP) desktop/opencubicplayer.desktop "$(DESTDIR)$(PREFIX)/share/applications"
@@ -143,7 +143,7 @@
$(MAKE) -C playxm TOPDIR=../$(TOPDIR)
$(MAKE) -C stuff TOPDIR=../$(TOPDIR)
$(MAKE) -C medialib TOPDIR=../$(TOPDIR)
- $(MAKE) -C doc TOPDIR="../$(TOPDIR)"
+ $(DOCS)$(MAKE) -C doc TOPDIR="../$(TOPDIR)"
ocp: boot/kickload.o
$(CC) $(LDFLAGS) -o $@ $^ -pthread @DL_LIBS@ @EFENCE_LIBS@ @DUMA_LIBS@
@@ -177,7 +177,7 @@
$(MAKE) -C playxm TOPDIR=../$(TOPDIR) clean
$(MAKE) -C stuff TOPDIR=../$(TOPDIR) clean
$(MAKE) -C medialib TOPDIR=../$(TOPDIR) clean
- $(MAKE) -C doc TOPDIR="../$(TOPDIR)" clean
+ $(DOCS)$(MAKE) -C doc TOPDIR="../$(TOPDIR)" clean
find . -name '*~' -exec rm {} ';'
rm -f ocp.hlp ocp *$(LIB_SUFFIX)
rm -f CPARCH.DAT

View File

@ -1,34 +0,0 @@
--- ./devp/devposs.c.orig 2009-09-21 14:23:33.000000000 +0200
+++ ./devp/devposs.c 2009-09-21 14:25:24.000000000 +0200
@@ -448,6 +448,7 @@
if (fcntl(fd_dsp, F_SETFD, FD_CLOEXEC)<0)
perror("devposs: fcntl(fd_dsp, F_SETFD, FD_CLOEXEC)");
#ifdef OSS_DEBUG
+/*
#if defined(OSS_GETVERSION)
if (ioctl(fd_dsp, OSS_GETVERSION, &tmp)<0)
tmp=0;
@@ -458,6 +459,7 @@
#elif defined(SOUND_VERSION)
fprintf(stderr, "devposs: compiled agains OSS version %d.%d.%d\n", (SOUND_VERSION&0xff0000)>>16, (SOUND_VERSION&0xff00)>>8, SOUND_VERSION&0xff);
#endif
+*/
#endif
plrSetOptions(plrRate, plrOpt);
@@ -597,6 +599,7 @@
return 0;
}
+/*
#if defined(OSS_GETVERSION)
if (ioctl(fd_dsp, OSS_GETVERSION, &tmp)<0)
{
@@ -607,6 +610,7 @@
return 0;
}
#endif
+*/
#ifdef OSS_DEBUG
fprintf(stderr, "devposs: OSS detected\n");

View File

@ -1,15 +1,11 @@
--- doc/texi/Makefile.orig 2009-09-20 14:30:44.000000000 +0200
+++ doc/texi/Makefile 2009-09-20 14:30:47.000000000 +0200
@@ -17,10 +17,10 @@
install: all
--- doc/texi/Makefile.orig 2010-05-17 11:55:16.000000000 +0200
+++ doc/texi/Makefile 2010-05-17 12:33:02.000000000 +0200
@@ -19,8 +19,8 @@
mkdir -p "$(DESTDIR)$(INFODIR)"
- $(CP) ocp.info.gz "$(DESTDIR)$(INFODIR)"
- install-info --dir-file="$(DESTDIR)$(INFODIR)/dir" "$(DESTDIR)$(INFODIR)/ocp.info.gz" || true
$(CP) ocp.info.gz "$(DESTDIR)$(INFODIR)"
install-info --dir-file="$(DESTDIR)$(INFODIR)/dir" "$(DESTDIR)$(INFODIR)/ocp.info.gz" || true
- mkdir -p "$(DESTDIR)$(PREFIX)/share/doc/ocp$(DIR_SUFFIX)/html"
- $(CP) -R ocp.html/* "$(DESTDIR)$(PREFIX)/share/doc/ocp$(DIR_SUFFIX)/html"
+ #$(CP) ocp.info.gz "$(DESTDIR)$(INFODIR)"
+ $(DOCS)install-info --dir-file="$(DESTDIR)$(INFODIR)/dir" "$(DESTDIR)$(INFODIR)/ocp.info.gz" || true
+ $(DOCS)mkdir -p "$(DESTDIR)$(PREFIX)/share/doc/ocp$(DIR_SUFFIX)/html"
+ $(DOCS)$(CP) -R ocp.html/* "$(DESTDIR)$(PREFIX)/share/doc/ocp$(DIR_SUFFIX)/html"
uninstall:

View File

@ -3,7 +3,6 @@ bin/ocp-curses
%%XORG%%bin/ocp-x11
%%SDL%%bin/ocp-sdl
bin/ultrafix.sh
%%XORG%%etc/X11/wmconfig/opencubicplayer
lib/ocp/autoload/10-compat.so
lib/ocp/autoload/10-devi.so
lib/ocp/autoload/10-hardware.so
@ -23,6 +22,7 @@ lib/ocp/autoload/30-mcpbase.so
lib/ocp/autoload/30-playsid.so
lib/ocp/autoload/30-plrbase.so
lib/ocp/autoload/30-smpbase.so
lib/ocp/autoload/30-ymtype.so
lib/ocp/autoload/35-cpiface.so
lib/ocp/autoload/40-cphlpif.so
%%FLAC%%lib/ocp/autoload/30-flacptype.so
@ -54,10 +54,10 @@ lib/ocp/playmp2.so
lib/ocp/playogg.so
lib/ocp/playsid.so
lib/ocp/playwav.so
lib/ocp/playym.so
lib/ocp/playxm.so
%%FLAC%%lib/ocp/playflac.so
%%ADPLUG%%lib/ocp/playopl.so
%%XORG%%share/applications/opencubicplayer.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
@ -79,6 +79,7 @@ lib/ocp/playxm.so
%%PORTDOCS%%%%DOCSDIR%%/html/wap.html
%%XORG%%share/icons/hicolor/16x16/apps/opencubicplayer.xpm
%%XORG%%share/icons/hicolor/48x48/apps/opencubicplayer.xpm
%%DESKTOP%%share/applications/cubic.org-opencubicplayer.desktop
%%DATADIR%%/data/ocp.hlp
%%DATADIR%%/etc/ocp.ini
@dirrm share/ocp/ultradir
@ -96,5 +97,4 @@ lib/ocp/playxm.so
%%XORG%%@dirrmtry share/applications
@dirrm lib/ocp/autoload
@dirrm lib/ocp
%%XORG%%@dirrm etc/X11/wmconfig
%%XORG%%@dirrmtry etc/X11