Upfdate to version 5.1.2. Necessary for this version was an update of

XmHTML to version 1.1.7. By the way xbae was updated to 4.8.4.
PR: ports/20464, ports/20975, ports/21919
This commit is contained in:
Lars Koeller 2000-12-29 16:22:02 +00:00
parent 22d9d76d60
commit de624ba756
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36442
8 changed files with 69 additions and 93 deletions

View File

@ -1,15 +1,15 @@
# New ports collection makefile for: grace
# Date created: Dec 28 1998
# Whom: Lars Koeller <lkoeller@cc.fh-lippe.de>
# Whom: Lars Koeller <Lars.Köller@Uni-Bielefeld.de>
#
# $FreeBSD$
#
PORTNAME= grace
PORTVERSION= 5.0.3g
PORTVERSION= 5.1.2
CATEGORIES= math print
#
# You never know when and why this caotic team moves it to ../src/old/ :-)
# You never know when and why it is moved to ../src/old/ :-)
#
MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/ \
ftp://plasma-gate.weizmann.ac.il/pub/grace/src/old/ \
@ -17,33 +17,29 @@ MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/ \
ftp://abragam.med.utoronto.ca/pub/mirrors/grace/src/old/ \
ftp://linux.mathematik.tu-darmstadt.de/pub/linux/mirrors/misc/grace/src/old/ \
ftp://linux.mathematik.tu-darmstadt.de/pub/linux/mirrors/misc/grace/src/
DISTNAME= grace-5.0.3gamma
MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
BUILD_DEPENDS= ${X11BASE}/lib/libhlpclient.a:${PORTSDIR}/x11/libhelp
LIB_DEPENDS= Xbae.7:${PORTSDIR}/x11-toolkits/xbae \
LIB_DEPENDS= Xbae.8:${PORTSDIR}/x11-toolkits/xbae \
netcdf.1:${PORTSDIR}/math/netcdf \
fftw.2:${PORTSDIR}/math/fftw \
pdf.2:${PORTSDIR}/print/pdflib \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png \
t1.1:${PORTSDIR}/devel/t1lib
t1.1:${PORTSDIR}/devel/t1lib \
XmHTML.1:${PORTSDIR}/x11-toolkits/xmhtml \
pdf.3:${PORTSDIR}/print/pdflib3
MAN1= grace.1 xmgrace.1 gracebat.1 grconvert.1
USE_X_PREFIX= YES
USE_XPM= yes
USE_GMAKE= YES
USE_MOTIF= YES
HAS_CONFIGURE= YES
CONFIGURE_ARGS= -prefix=${X11BASE} \
--enable-extra-incpath=${X11BASE}/include/X11:${LOCALBASE}/include:${LOCALBASE}/include/gd \
--enable-libhelp \
--enable-extra-ldpath=${LOCALBASE}/lib \
--enable-grace-home=${X11BASE}/lib/X11/grace \
--enable-config=generic
--with-extra-incpath=${X11BASE}/include/X11:${LOCALBASE}/include \
--with-extra-ldpath=${LOCALBASE}/lib \
--enable-grace-home=${X11BASE}/lib/X11/grace
ALL_TARGET=
INSTALL_TARGET= install links
@ -54,6 +50,10 @@ post-patch:
${RM} -f ${WRKSRC}/configure.input
post-install:
${LN} -s ${X11BASE}/lib/X11/grace/doc ${X11BASE}/share/doc/grace
.if !defined(NOPORTDOCS)
if [ ! -e ${X11BASE}/share/doc/grace ]; then \
${LN} -s ${X11BASE}/lib/X11/grace/doc ${X11BASE}/share/doc/grace; \
fi
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (grace-5.0.3gamma.tar.gz) = fe200b1fe353afa3cd0cb580ef9d2106
MD5 (grace-5.1.2.tar.gz) = 3f630258a3572d9988aa6010a8167e39

View File

@ -1,40 +1,18 @@
*** configure.orig Sun Aug 22 12:11:35 1999
--- configure Fri Sep 10 16:22:17 1999
*** configure.orig Mon May 22 19:54:43 2000
--- configure Mon May 22 19:54:47 2000
***************
*** 1096,1106 ****
if test "x${GCC}" = "xyes"
then
- case "${host}" in
- i?86-*-linux-*) CFLAGS="-m486 -malign-double $CFLAGS";;
- i?86-*) CFLAGS="-m486 $CFLAGS";;
- esac
-
echo $ac_n "checking "for gcc strength-reduce bug"""... $ac_c" 1>&6
echo "configure:1106: checking "for gcc strength-reduce bug"" >&5
if eval "test \"`echo '$''{'ac_cv_c_gcc_strength_bug'+set}'`\" = set"; then
--- 1096,1101 ----
***************
*** 1832,1838 ****
*** 2590,2596 ****
# It thinks the first close brace ends the variable substitution.
test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
! test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL_PROGRAM}'
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
--- 1827,1833 ----
--- 2590,2596 ----
# It thinks the first close brace ends the variable substitution.
test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
! test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL} -m 555'
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
***************
*** 8939,8942 ****
chmod +x $CONFIG_STATUS
rm -fr confdefs* $ac_clean_files
test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
-
--- 8934,8936 ----

View File

@ -1,19 +1,11 @@
*** conf/Make.conf.in.org Fri Sep 10 09:32:03 1999
--- conf/Make.conf.in Fri Sep 10 09:32:27 1999
*** ac-tools/Make.conf.in.orig Mon May 22 19:57:32 2000
--- ac-tools/Make.conf.in Mon May 22 19:57:36 2000
***************
*** 93,98 ****
--- 93,99 ----
*** 90,95 ****
--- 90,96 ----
# BSD install
INSTALL=@INSTALL@
INSTALL_PROGRAM=@INSTALL_PROGRAM@
+ INSTALL_SCRIPT=@INSTALL_SCRIPT@
INSTALL_DATA=@INSTALL_DATA@
MKINSTALLDIRS=@MKINSTALLDIRS@
***************
*** 119,122 ****
# HTML help viewer command
HELPVIEWER=@HELPVIEWER@
-
--- 120,122 ----

View File

@ -1,19 +1,18 @@
*** examples/Makefile.org Fri Sep 10 09:25:47 1999
--- examples/Makefile Fri Sep 10 09:25:57 1999
*** examples/Makefile.orig Mon May 22 19:58:45 2000
--- examples/Makefile Mon May 22 19:59:07 2000
***************
*** 31,37 ****
*** 33,39 ****
install : $(EXAMPLES) $(DOTEST)
$(MKINSTALLDIRS) $(GRACE_HOME)/examples
for i in $(EXAMPLES); do $(INSTALL_DATA) $$i $(GRACE_HOME)/examples; done
! $(INSTALL_PROGRAM) $(DOTEST) $(GRACE_HOME)/examples/$(DOTEST)
links : dummy
--- 31,37 ----
--- 33,39 ----
install : $(EXAMPLES) $(DOTEST)
$(MKINSTALLDIRS) $(GRACE_HOME)/examples
for i in $(EXAMPLES); do $(INSTALL_DATA) $$i $(GRACE_HOME)/examples; done
! $(INSTALL_SCRIPT) $(DOTEST) $(GRACE_HOME)/examples/$(DOTEST)
links : dummy

View File

@ -1,19 +1,18 @@
*** doc/Makefile.orig Fri Aug 20 00:31:44 1999
--- doc/Makefile Fri Sep 10 11:06:06 1999
*** doc/Makefile.orig Mon May 22 20:00:24 2000
--- doc/Makefile Mon May 22 20:00:51 2000
***************
*** 66,72 ****
*** 78,84 ****
$(MKINSTALLDIRS) $(PREFIX)/man
$(MKINSTALLDIRS) $(PREFIX)/man/man1
cd $(PREFIX)/man/man1; \
! for i in $? $(MANLINKS); do $(RM) $$i; $(LN_S) $(GRACE_HOME)/doc/$$i $$i; done
tests : dummy
--- 66,72 ----
--- 78,84 ----
$(MKINSTALLDIRS) $(PREFIX)/man
$(MKINSTALLDIRS) $(PREFIX)/man/man1
cd $(PREFIX)/man/man1; \
! for i in $? $(MANLINKS); do $(RM) $$i; $(INSTALL_DATA) $(GRACE_HOME)/doc/$$i $$i; done
tests : dummy

View File

@ -1,16 +1,13 @@
--- conf/generic.orig Mon Mar 29 01:02:41 1999
+++ conf/generic Fri Sep 10 16:10:36 1999
@@ -17,11 +17,11 @@
###############################
# Misc optimization flags
#
-OPTIMIZE="-O"
+#OPTIMIZE="-O"
###############################
###############################
# Flags used for debugging
#
-DEBUG="-g"
+#DEBUG="-g"
###############################
*** src/pdfdrv.c.org Thu Apr 20 22:34:34 2000
--- src/pdfdrv.c Thu Aug 3 21:23:05 2000
***************
*** 57,62 ****
--- 57,64 ----
# include "motifinc.h"
#endif
+ #define PDF_set_fillrule(handle, rule) PDF_set_parameter(handle, "fillrule", rule)
+
static void pdf_error_handler(PDF *p, int type, const char* msg);
static unsigned long page_scale;

View File

@ -28,7 +28,7 @@ lib/X11/grace/doc/UsersGuide.html
lib/X11/grace/doc/grace.1
lib/X11/grace/doc/gracebat.1
lib/X11/grace/doc/grconvert.1
lib/X11/grace/doc/mygraph.gif
lib/X11/grace/doc/mygraph.png
lib/X11/grace/doc/nohelp.html
lib/X11/grace/doc/philosophical-gnu-sm.jpg
lib/X11/grace/doc/shiftdata.sh
@ -38,6 +38,7 @@ lib/X11/grace/examples/arrows.agr
lib/X11/grace/examples/au.agr
lib/X11/grace/examples/axes.agr
lib/X11/grace/examples/bar.agr
lib/X11/grace/examples/boxplot.agr
lib/X11/grace/examples/brw.dat
lib/X11/grace/examples/chartebar.agr
lib/X11/grace/examples/charts.agr
@ -52,14 +53,16 @@ lib/X11/grace/examples/log.dat
lib/X11/grace/examples/log2.agr
lib/X11/grace/examples/logistic.agr
lib/X11/grace/examples/logistic.fit
lib/X11/grace/examples/logit.agr
lib/X11/grace/examples/logtest.par
lib/X11/grace/examples/manygraphs.agr
lib/X11/grace/examples/mlo.dat
lib/X11/grace/examples/moresyms.agr
lib/X11/grace/examples/motif.agr
lib/X11/grace/examples/pie.agr
lib/X11/grace/examples/polar.agr
lib/X11/grace/examples/props.agr
lib/X11/grace/examples/regions.par
lib/X11/grace/examples/spectrum.agr
lib/X11/grace/examples/stackedb.agr
lib/X11/grace/examples/symslines.agr
lib/X11/grace/examples/terr.agr
@ -74,12 +77,20 @@ lib/X11/grace/examples/tinset.agr
lib/X11/grace/examples/tlog.agr
lib/X11/grace/examples/tmc.c
lib/X11/grace/examples/tstack.agr
lib/X11/grace/examples/txttrans.agr
lib/X11/grace/examples/txyr.agr
lib/X11/grace/examples/typeset.agr
lib/X11/grace/examples/vmap.agr
lib/X11/grace/examples/xysize.agr
lib/X11/grace/examples/xyz.agr
lib/X11/grace/fonts/FontDataBase
lib/X11/grace/fonts/enc/IsoLatin1.enc
lib/X11/grace/fonts/enc/IsoLatin2.enc
lib/X11/grace/fonts/enc/IsoLatin9.enc
lib/X11/grace/fonts/enc/MacRoman.enc
lib/X11/grace/fonts/enc/PDFDoc.enc
lib/X11/grace/fonts/enc/PSLatin1.enc
lib/X11/grace/fonts/enc/WinAnsi.enc
lib/X11/grace/fonts/type1/d050000l.afm
lib/X11/grace/fonts/type1/d050000l.pfb
lib/X11/grace/fonts/type1/n019003l.afm