Build and install a shared library version, too.

This commit is contained in:
Jacques Vidrine 1998-10-07 19:34:46 +00:00
parent ffe162b612
commit de2c0f5c6d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=13717
6 changed files with 128 additions and 4 deletions

View File

@ -3,14 +3,14 @@
# Date created: 6/11/1998
# Whom: n@nectar.com
#
# $Id: Makefile,v 1.1.1.1 1998/07/04 19:51:53 steve Exp $
# $Id: Makefile,v 1.2 1998/07/05 13:09:46 asami Exp $
#
DISTNAME= hesiod-3.0.2
CATEGORIES= net
MASTER_SITES= ftp://athena-dist.mit.edu/pub/ATHENA/hesiod/
MAINTAINER= n@nectar.com
MAINTAINER= nectar@FreeBSD.ORG
MAN1= hesinfo.1
MAN3= hesiod.3 hesiod_end.3 hesiod_free_list.3 \
@ -23,4 +23,23 @@ MAN5= hesiod.conf.5
GNU_CONFIGURE= YES
post-install:
${SETENV} OBJFORMAT="${PORTOBJFORMAT}" ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
.if !defined(PORTOBJFORMAT) # bsd.port.mk must be out of date
PORTOBJFORMAT= aout
CONFIGURE_ENV+= PORTOBJFORMAT="${PORTOBJFORMAT}"
MAKE_ENV+= PORTOBJFORMAT="${PORTOBJFORMAT}"
.endif
.if ${PORTOBJFORMAT} == elf
SHLIB=libhesiod.so.3
CONFIGURE_ENV+= LDFLAGS="-shared -Wl,-soname,${SHLIB}"
.else
SHLIB=libhesiod.so.3.0
CONFIGURE_ENV+= LDFLAGS="-shared"
.endif
MAKE_ENV+= SHLIB="${SHLIB}"

39
dns/hesiod/files/patch-aa Normal file
View File

@ -0,0 +1,39 @@
--- Makefile.in.orig Fri Jan 3 15:02:55 1997
+++ Makefile.in Wed Oct 7 11:43:17 1998
@@ -24,12 +24,15 @@
ALL_CFLAGS=-I. -DSYSCONFDIR=\"${sysconfdir}\" ${CPPFLAGS} ${CFLAGS}
OBJS=hesiod.o hesmailhost.o hespwnam.o hesservbyname.o hescompat.o
-all: libhesiod.a hesinfo hestest
+all: libhesiod.a hesinfo hestest ${SHLIB}
libhesiod.a: ${OBJS}
ar cru $@ ${OBJS}
${RANLIB} $@
+${SHLIB}: ${OBJS}
+ ${CC} ${LDFLAGS} ${OBJS} -o ${SHLIB}
+
hesinfo: hesinfo.o libhesiod.a
${CC} ${LDFLAGS} -o $@ hesinfo.o libhesiod.a ${LIBS}
@@ -55,6 +58,9 @@
${INSTALL} -c -m 644 libhesiod.a ${DESTDIR}${libdir}
${RANLIB} ${DESTDIR}${libdir}/libhesiod.a
chmod u-w ${DESTDIR}${libdir}/libhesiod.a
+ ${INSTALL} -c -m 444 ${SHLIB} ${DESTDIR}${libdir}
+ ln -f -s ${DESTDIR}${libdir}/${SHLIB} \
+ ${DESTDIR}${libdir}/libhesiod.so
${INSTALL_PROGRAM} -c -m 555 hesinfo ${DESTDIR}${lbindir}
${INSTALL} -c -m 444 ${srcdir}/hesiod.h ${DESTDIR}${includedir}
${INSTALL} -c -m 444 ${srcdir}/hesinfo.1 ${DESTDIR}${mandir}/man1
@@ -85,7 +93,8 @@
${INSTALL} -c -m 444 ${srcdir}/hesiod.conf.5 ${DESTDIR}${mandir}/man5
clean:
- rm -f ${OBJS} libhesiod.a hesinfo.o hesinfo hestest.o hestest
+ rm -f ${OBJS} libhesiod.a hesinfo.o hesinfo hestest.o hestest \
+ libhesiod.so.3
distclean: clean
rm -f config.cache config.log config.status Makefile config.h

View File

@ -1,3 +1,7 @@
bin/hesinfo
include/hesiod.h
lib/libhesiod.a
lib/libhesiod.so
lib/libhesiod.so.3.0
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R

View File

@ -3,14 +3,14 @@
# Date created: 6/11/1998
# Whom: n@nectar.com
#
# $Id: Makefile,v 1.1.1.1 1998/07/04 19:51:53 steve Exp $
# $Id: Makefile,v 1.2 1998/07/05 13:09:46 asami Exp $
#
DISTNAME= hesiod-3.0.2
CATEGORIES= net
MASTER_SITES= ftp://athena-dist.mit.edu/pub/ATHENA/hesiod/
MAINTAINER= n@nectar.com
MAINTAINER= nectar@FreeBSD.ORG
MAN1= hesinfo.1
MAN3= hesiod.3 hesiod_end.3 hesiod_free_list.3 \
@ -23,4 +23,23 @@ MAN5= hesiod.conf.5
GNU_CONFIGURE= YES
post-install:
${SETENV} OBJFORMAT="${PORTOBJFORMAT}" ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
.if !defined(PORTOBJFORMAT) # bsd.port.mk must be out of date
PORTOBJFORMAT= aout
CONFIGURE_ENV+= PORTOBJFORMAT="${PORTOBJFORMAT}"
MAKE_ENV+= PORTOBJFORMAT="${PORTOBJFORMAT}"
.endif
.if ${PORTOBJFORMAT} == elf
SHLIB=libhesiod.so.3
CONFIGURE_ENV+= LDFLAGS="-shared -Wl,-soname,${SHLIB}"
.else
SHLIB=libhesiod.so.3.0
CONFIGURE_ENV+= LDFLAGS="-shared"
.endif
MAKE_ENV+= SHLIB="${SHLIB}"

39
net/hesiod/files/patch-aa Normal file
View File

@ -0,0 +1,39 @@
--- Makefile.in.orig Fri Jan 3 15:02:55 1997
+++ Makefile.in Wed Oct 7 11:43:17 1998
@@ -24,12 +24,15 @@
ALL_CFLAGS=-I. -DSYSCONFDIR=\"${sysconfdir}\" ${CPPFLAGS} ${CFLAGS}
OBJS=hesiod.o hesmailhost.o hespwnam.o hesservbyname.o hescompat.o
-all: libhesiod.a hesinfo hestest
+all: libhesiod.a hesinfo hestest ${SHLIB}
libhesiod.a: ${OBJS}
ar cru $@ ${OBJS}
${RANLIB} $@
+${SHLIB}: ${OBJS}
+ ${CC} ${LDFLAGS} ${OBJS} -o ${SHLIB}
+
hesinfo: hesinfo.o libhesiod.a
${CC} ${LDFLAGS} -o $@ hesinfo.o libhesiod.a ${LIBS}
@@ -55,6 +58,9 @@
${INSTALL} -c -m 644 libhesiod.a ${DESTDIR}${libdir}
${RANLIB} ${DESTDIR}${libdir}/libhesiod.a
chmod u-w ${DESTDIR}${libdir}/libhesiod.a
+ ${INSTALL} -c -m 444 ${SHLIB} ${DESTDIR}${libdir}
+ ln -f -s ${DESTDIR}${libdir}/${SHLIB} \
+ ${DESTDIR}${libdir}/libhesiod.so
${INSTALL_PROGRAM} -c -m 555 hesinfo ${DESTDIR}${lbindir}
${INSTALL} -c -m 444 ${srcdir}/hesiod.h ${DESTDIR}${includedir}
${INSTALL} -c -m 444 ${srcdir}/hesinfo.1 ${DESTDIR}${mandir}/man1
@@ -85,7 +93,8 @@
${INSTALL} -c -m 444 ${srcdir}/hesiod.conf.5 ${DESTDIR}${mandir}/man5
clean:
- rm -f ${OBJS} libhesiod.a hesinfo.o hesinfo hestest.o hestest
+ rm -f ${OBJS} libhesiod.a hesinfo.o hesinfo hestest.o hestest \
+ libhesiod.so.3
distclean: clean
rm -f config.cache config.log config.status Makefile config.h

View File

@ -1,3 +1,7 @@
bin/hesinfo
include/hesiod.h
lib/libhesiod.a
lib/libhesiod.so
lib/libhesiod.so.3.0
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R