This module provides an implementation of Canonical XML Recommendation

(Version 1, 15 March 2001). It uses XML::GDOME for its DOM tree and
XPath nodes.

It provides a XS wrapper around libxml2's Canonical XML code.

WWW:	http://search.cpan.org/dist/XML-Canonical/

PR:		ports/114596
Submitted by:	Gea-Suan Lin <gslin at gslin.org>
This commit is contained in:
Cheng-Lung Sung 2007-07-23 03:09:36 +00:00
parent baf5aef2bf
commit de1da38e13
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=196089
6 changed files with 53 additions and 0 deletions

View File

@ -602,6 +602,7 @@
SUBDIR += p5-XML-Atom-Stream
SUBDIR += p5-XML-Atom-Syndication
SUBDIR += p5-XML-AutoWriter
SUBDIR += p5-XML-Canonical
SUBDIR += p5-XML-Catalog
SUBDIR += p5-XML-Clean
SUBDIR += p5-XML-Compile

View File

@ -0,0 +1,24 @@
# New ports collection makefile for: p5-XML-Canonical
# Date created: 2007-07-15
# Whom: Gea-Suan Lin <gslin@gslin.org>
#
# $FreeBSD$
#
PORTNAME= XML-Canonical
PORTVERSION= 0.10
CATEGORIES= textproc
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= XML
PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Perl Implementation of Canonical XML
LIB_DEPENDS= gdome:${PORTSDIR}/textproc/gdome2
PERL_CONFIGURE= yes
MAN3= XML::Canonical.3
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (XML-Canonical-0.10.tar.gz) = 9c75fadad906ee63e43ced695b3412fd
SHA256 (XML-Canonical-0.10.tar.gz) = 419ea71c91b8cdb07cb48075ff04424ea7ce69a90955dd5f73bd23f60488c488
SIZE (XML-Canonical-0.10.tar.gz) = 6243

View File

@ -0,0 +1,10 @@
--- Makefile.PL.orig Sun Jul 15 16:00:28 2007
+++ Makefile.PL Sun Jul 15 16:00:31 2007
@@ -17,7 +17,6 @@
print "running gdome-config... ";
my $ver = backtick('gdome-config --version');
my ($major, $minor, $point) = $ver =~ /(\d+).(\d+)\.(\d+)/g;
- die "VERSION" unless $major == 0 && $minor == 7 && $point == 1;
$config{LIBS} ||= backtick('gdome-config --libs');
$config{INC} ||= backtick('gdome-config --cflags');
print "ok\n";

View File

@ -0,0 +1,7 @@
This module provides an implementation of Canonical XML Recommendation
(Version 1, 15 March 2001). It uses XML::GDOME for its DOM tree and
XPath nodes.
It provides a XS wrapper around libxml2's Canonical XML code.
WWW: http://search.cpan.org/dist/XML-Canonical/

View File

@ -0,0 +1,8 @@
@comment $FreeBSD$
%%SITE_PERL%%/%%PERL_ARCH%%/XML/Canonical.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Canonical/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Canonical/Canonical.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Canonical/Canonical.so
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Canonical
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/XML