Update to 1.0.3
Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D9566
This commit is contained in:
parent
0fa6736da0
commit
de0ba2723a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=434061
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xpra
|
||||
PORTVERSION= 1.0.2
|
||||
PORTVERSION= 1.0.3
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://xpra.org/src/
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1486238713
|
||||
SHA256 (xpra-1.0.2.tar.xz) = e32d2550c13d175681643696664790c9c59eda1e0ce1cea779ef7b0785f8bd2c
|
||||
SIZE (xpra-1.0.2.tar.xz) = 1888452
|
||||
TIMESTAMP = 1486998413
|
||||
SHA256 (xpra-1.0.3.tar.xz) = f83c5946f67fe26eee8b44fba0fa30bca9fbc7aa58ee66b903b7385c2d332166
|
||||
SIZE (xpra-1.0.3.tar.xz) = 1888908
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- setup.py.orig 2017-02-01 05:52:14 UTC
|
||||
--- setup.py.orig 2017-02-06 09:47:42 UTC
|
||||
+++ setup.py
|
||||
@@ -218,7 +218,7 @@ else:
|
||||
nvenc7_ENABLED = DEFAULT and pkg_config_ok("--exists", "nvenc7")
|
||||
@ -9,17 +9,6 @@
|
||||
csc_libyuv_ENABLED = DEFAULT and memoryview_ENABLED and pkg_config_ok("--exists", "libyuv", fallback=WIN32)
|
||||
|
||||
#Cython / gcc / packaging build options:
|
||||
@@ -798,8 +798,8 @@ def get_base_conf_dir(install_dir, strip
|
||||
elif "usr" in dirs:
|
||||
#ie: ["some", "path", "to", "usr"] -> ["usr"]
|
||||
#assume "/usr" or "/usr/local" is the build root
|
||||
- while "usr" in dirs and dirs.index("usr")>0:
|
||||
- dirs = dirs[dirs.index("usr"):]
|
||||
+ while "usr" in dirs[1:]:
|
||||
+ dirs = dirs[dirs[1:].index("usr")+1:]
|
||||
elif "image" in dirs:
|
||||
# Gentoo's "${PORTAGE_TMPDIR}/portage/${CATEGORY}/${PF}/image/_python2.7" -> ""
|
||||
while "image" in dirs:
|
||||
@@ -1839,12 +1839,12 @@ if WIN32:
|
||||
else:
|
||||
#OSX and *nix:
|
||||
|
@ -1,18 +0,0 @@
|
||||
# Chaneset 15036 in xpra
|
||||
# Timestamp: 02/11/17 05:03:04
|
||||
# Author: Antoine Martin
|
||||
# Message: make sure we call makedirs on the expanded path
|
||||
#
|
||||
--- xpra/scripts/config.py.orig 2016-12-30 04:31:45 UTC
|
||||
+++ xpra/scripts/config.py
|
||||
@@ -401,8 +401,8 @@ def may_create_user_config(xpra_conf_fil
|
||||
ad = os.path.expanduser(d)
|
||||
conf_file = os.path.join(ad, xpra_conf_filename)
|
||||
try:
|
||||
- if not os.path.exists(d):
|
||||
- os.makedirs(d, int('700', 8))
|
||||
+ if not os.path.exists(ad):
|
||||
+ os.makedirs(ad, int('700', 8))
|
||||
with open(conf_file, 'wb') as f:
|
||||
f.write("# xpra user configuration file\n")
|
||||
f.write("# place your custom settings in this file\n")
|
Loading…
Reference in New Issue
Block a user