irc/kvirc: link to thread library

- when building outside of poudriere kvirc can fail linking
- it is not quite clear yet why this is required

PR:		242305
Reported by:	VVD <vvd@unislabs.com>
This commit is contained in:
Tobias C. Berner 2020-08-05 18:07:44 +00:00
parent 98e2d1025d
commit ddc48c0f6d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=544236

View File

@ -0,0 +1,10 @@
--- src/kvilib/CMakeLists.txt.orig 2020-01-25 22:07:57 UTC
+++ src/kvilib/CMakeLists.txt
@@ -129,6 +129,7 @@ endif()
add_library(${KVILIB_BINARYNAME} SHARED ${kvilib_SRCS} ${kvilib_MOC_SRCS})
target_link_libraries(${KVILIB_BINARYNAME} ${LIBS})
+target_link_libraries(${KVILIB_BINARYNAME} Threads::Threads)
# Enable C++14
set_property(TARGET ${KVILIB_BINARYNAME} PROPERTY CXX_STANDARD 14)