Update to 0.8.

PR:		11540
Submitted by:	maintainer
This commit is contained in:
Michael Haro 1999-05-07 01:08:31 +00:00
parent a0dab8ccf3
commit ddae3a4fef
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=18575
3 changed files with 12 additions and 14 deletions

View File

@ -1,27 +1,25 @@
# New ports collection makefile for: greed
# Version required: 0.750
# Version required: 0.8
# Date created: 13 April 1999
# Whom: Chris Piazza <cpiazza@home.net>
#
# $Id: Makefile,v 1.4 1999/04/25 17:51:23 mharo Exp $
# $Id: Makefile,v 1.5 1999/05/01 02:12:32 steve Exp $
#
DISTNAME= greed-0.750
DISTNAME= greed-0.8
CATEGORIES= net
MASTER_SITES= http://www.public.asu.edu/~arturner/
MAINTAINER= cpiazza@home.net
MAN1= greed.1
MANCOMPRESSED= yes
MAN1= greed.1
ALL_TARGET= freebsd
WRKSRC= ${WRKDIR}/greed
post-extract:
@${GUNZIP_CMD} ${WRKSRC}/greed.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/greed ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/greed.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/greed.1.gz ${PREFIX}/man/man1
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (greed-0.750.tar.gz) = ebc282ef12afdc3dfb1bf7845f00040e
MD5 (greed-0.8.tar.gz) = 46a40f1047217e980ab2d3c88dfc2756

View File

@ -1,5 +1,5 @@
--- Makefile.orig Wed Apr 21 07:09:00 1999
+++ Makefile Fri Apr 23 23:28:02 1999
--- Makefile.orig Tue May 4 09:49:31 1999
+++ Makefile Thu May 6 07:12:36 1999
@@ -4,10 +4,10 @@
# Where to install binary and manpage on "make install":
@ -12,17 +12,17 @@
###################################################
###### ######
@@ -52,11 +52,10 @@
@@ -50,11 +50,10 @@
#CFLAGS='-DI386_ASSEM -DREAL_IS_FLOAT -DLINUX -Wall -O2 -m486 -fomit-frame-pointer -funroll-all-loops -finline-functions -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2'
freebsd:
- $(MAKE) CC=cc LDFLAGS= \
+ $(MAKE) LDFLAGS= \
OBJECTS= \
- CFLAGS='-Wall -ansi -pedantic -O4 -m486 -fomit-frame-pointer \
- CFLAGS='-Wall -ansi -pedantic -O4 -m486 \
- -funroll-all-loops -ffast-math -DROT_I386 \
- -DI386_ASSEM -DREAL_IS_FLOAT -DUSE_MMAP' \
+ CFLAGS='-fomit-frame-pointer -funroll-all-loops -ffast-math \
+ CFLAGS='-funroll-all-loops -ffast-math \
+ -DREAL_IS_FLOAT -DUSE_MMAP ${FLAGS}' \
greed