multimedia/libopenshot: Update to 0.2.5.172
PR: 249271 Submitted by: Tatsuki Makino <tatsuki_makino@hotmail.com> (maintainer)
This commit is contained in:
parent
fe4d2b920c
commit
dd918c8356
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=548459
@ -2,9 +2,8 @@
|
||||
|
||||
PORTNAME= libopenshot
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.2.5-106
|
||||
DISTVERSIONSUFFIX= -g517f289
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 0.2.5-172
|
||||
DISTVERSIONSUFFIX= -gac8966a
|
||||
CATEGORIES= multimedia
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1592888400
|
||||
SHA256 (OpenShot-libopenshot-v0.2.5-106-g517f289_GH0.tar.gz) = e8cce2ce90a16798519522cb0bca21a8b1367bca3608694552d951bf03350aaa
|
||||
SIZE (OpenShot-libopenshot-v0.2.5-106-g517f289_GH0.tar.gz) = 10303100
|
||||
TIMESTAMP = 1599886800
|
||||
SHA256 (OpenShot-libopenshot-v0.2.5-172-gac8966a_GH0.tar.gz) = d90d146d167108eab98dbf1aadce564267c2f6741e2836501e25f3037f4b3b9c
|
||||
SIZE (OpenShot-libopenshot-v0.2.5-172-gac8966a_GH0.tar.gz) = 10305575
|
||||
|
@ -1,7 +1,7 @@
|
||||
--- src/CMakeLists.txt.orig 2020-06-18 10:04:32 UTC
|
||||
--- src/CMakeLists.txt.orig 2020-09-11 02:37:02 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -361,7 +361,13 @@ if (TARGET RESVG::resvg)
|
||||
set(CMAKE_SWIG_FLAGS "-DUSE_RESVG=1")
|
||||
@@ -384,7 +384,13 @@ if (TARGET RESVG::resvg)
|
||||
|
||||
endif()
|
||||
|
||||
+find_library(EXECINFO_LIBRARY NAMES execinfo)
|
||||
@ -13,4 +13,4 @@
|
||||
+
|
||||
# Link remaining dependency libraries
|
||||
target_link_libraries(openshot PUBLIC
|
||||
${LIBOPENSHOT_AUDIO_LIBRARIES}
|
||||
${LIBOPENSHOT_AUDIO_LIBRARIES}
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/FFmpegReader.cpp.orig 2020-02-10 17:52:00 UTC
|
||||
--- src/FFmpegReader.cpp.orig 2020-09-11 02:37:02 UTC
|
||||
+++ src/FFmpegReader.cpp
|
||||
@@ -162,7 +162,7 @@ static enum AVPixelFormat get_hw_dec_format(AVCodecCon
|
||||
@@ -165,7 +165,7 @@ static enum AVPixelFormat get_hw_dec_format(AVCodecCon
|
||||
|
||||
for (p = pix_fmts; *p != AV_PIX_FMT_NONE; p++) {
|
||||
switch (*p) {
|
||||
@ -9,7 +9,7 @@
|
||||
// Linux pix formats
|
||||
case AV_PIX_FMT_VAAPI:
|
||||
hw_de_av_pix_fmt_global = AV_PIX_FMT_VAAPI;
|
||||
@@ -318,7 +318,7 @@ void FFmpegReader::Open() {
|
||||
@@ -321,7 +321,7 @@ void FFmpegReader::Open() {
|
||||
pCodecCtx->get_format = get_hw_dec_format;
|
||||
|
||||
if (adapter_num < 3 && adapter_num >=0) {
|
||||
@ -18,7 +18,7 @@
|
||||
snprintf(adapter,sizeof(adapter),"/dev/dri/renderD%d", adapter_num+128);
|
||||
adapter_ptr = adapter;
|
||||
i_decoder_hw = openshot::Settings::Instance()->HARDWARE_DECODER;
|
||||
@@ -381,11 +381,13 @@ void FFmpegReader::Open() {
|
||||
@@ -384,11 +384,13 @@ void FFmpegReader::Open() {
|
||||
}
|
||||
|
||||
// Check if it is there and writable
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- src/FFmpegWriter.cpp.orig 2020-06-18 10:04:32 UTC
|
||||
--- src/FFmpegWriter.cpp.orig 2020-09-11 02:37:02 UTC
|
||||
+++ src/FFmpegWriter.cpp
|
||||
@@ -172,7 +172,7 @@ void FFmpegWriter::SetVideoOptions(bool has_video, std
|
||||
AVCodec *new_codec;
|
||||
@ -21,7 +21,7 @@
|
||||
#else // not ffmpeg 3
|
||||
new_codec = avcodec_find_encoder_by_name(codec.c_str());
|
||||
#endif // HAVE_HW_ACCEL
|
||||
@@ -554,6 +554,7 @@ void FFmpegWriter::SetOption(StreamType stream, std::s
|
||||
@@ -556,6 +556,7 @@ void FFmpegWriter::SetOption(StreamType stream, std::s
|
||||
else {
|
||||
av_opt_set_int(c->priv_data, "crf", std::min(std::stoi(value),63), 0);
|
||||
}
|
||||
@ -29,7 +29,7 @@
|
||||
case AV_CODEC_ID_HEVC :
|
||||
c->bit_rate = 0;
|
||||
if (strstr(info.vcodec.c_str(), "svt_hevc") != NULL) {
|
||||
@@ -562,6 +563,8 @@ void FFmpegWriter::SetOption(StreamType stream, std::s
|
||||
@@ -564,6 +565,8 @@ void FFmpegWriter::SetOption(StreamType stream, std::s
|
||||
av_opt_set_int(c->priv_data, "forced-idr",1,0);
|
||||
}
|
||||
break;
|
||||
@ -38,7 +38,7 @@
|
||||
}
|
||||
#endif
|
||||
} else {
|
||||
@@ -1447,7 +1450,7 @@ void FFmpegWriter::open_video(AVFormatContext *oc, AVS
|
||||
@@ -1456,7 +1459,7 @@ void FFmpegWriter::open_video(AVFormatContext *oc, AVS
|
||||
adapter_num = openshot::Settings::Instance()->HW_EN_DEVICE_SET;
|
||||
fprintf(stderr, "\n\nEncodiing Device Nr: %d\n", adapter_num);
|
||||
if (adapter_num < 3 && adapter_num >=0) {
|
||||
@ -47,7 +47,7 @@
|
||||
snprintf(adapter,sizeof(adapter),"/dev/dri/renderD%d", adapter_num+128);
|
||||
// Maybe 127 is better because the first card would be 1?!
|
||||
adapter_ptr = adapter;
|
||||
@@ -1455,17 +1458,21 @@ void FFmpegWriter::open_video(AVFormatContext *oc, AVS
|
||||
@@ -1464,17 +1467,21 @@ void FFmpegWriter::open_video(AVFormatContext *oc, AVS
|
||||
adapter_ptr = NULL;
|
||||
#elif defined(__APPLE__)
|
||||
adapter_ptr = NULL;
|
||||
|
@ -51,6 +51,7 @@ include/libopenshot/QtHtmlReader.h
|
||||
include/libopenshot/QtImageReader.h
|
||||
include/libopenshot/QtPlayer.h
|
||||
include/libopenshot/QtTextReader.h
|
||||
include/libopenshot/QtUtilities.h
|
||||
include/libopenshot/ReaderBase.h
|
||||
include/libopenshot/RendererBase.h
|
||||
include/libopenshot/Settings.h
|
||||
|
Loading…
Reference in New Issue
Block a user