Replace contents which were repocopied from devel/ros with the real contents,

do not yet connect the port to the build:

The documentation stack houses documentation tools for ROS.  This stack
exists separately from the main ros stack in order to minimize heavyweight
dependencies, such as Doxygen, LaTeX, Epydoc, and Sphinx.

WWW: http://www.ros.org/wiki/documentation
This commit is contained in:
Rene Ladan 2011-05-04 21:31:22 +00:00
parent 42c2f344bc
commit dd741f84d0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=273639
14 changed files with 106 additions and 4872 deletions

View File

@ -1,349 +1,73 @@
# New ports collection makefile for: ros
# Date created: 2010-08-01
# New ports collection makefile for: ros-documentation
# Date created: 2011-03-19
# Whom: Rene Ladan <rene@FreeBSD.org>
#
# $FreeBSD$
PORTNAME= ros
PORTVERSION= 1.2.6
PORTNAME= ros-documentation
PORTVERSION= 1.4.1
CATEGORIES= devel
MASTER_SITES= ftp://rene-ladan.nl/pub/distfiles/ros/
DISTFILES= ros-${PORTVERSION}.tar.bz2 SWIG-1.3.29-wx.tar.gz \
gtest-1.5.0.tar.gz
MASTER_SITES= https://code.ros.org/svn/release/download/stacks/documentation/documentation-${PORTVERSION}/
DISTNAME= documentation-${PORTVERSION}
DIST_SUBDIR= ros
EXTRACT_ONLY= ros-${PORTVERSION}.tar.bz2
MAINTAINER= rene@FreeBSD.org
COMMENT= Robot Operating System - core utilities
COMMENT= Robot Operating System - documentation utilities
LICENSE= BSD
WRKSRC= ${WRKDIR}/ros
STACKNAME= ${PORTNAME:S/ros-//}
CFLAGS+= -I${LOCALBASE}/include
LIB_DEPENDS= log4cxx.10:${PORTSDIR}/devel/log4cxx \
boost_python:${PORTSDIR}/devel/boost-python-libs
# we need cmake and gmake for the build, but the build is triggered by make
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/yaml/__init__.py:${PORTSDIR}/devel/py-yaml \
bash:${PORTSDIR}/shells/bash \
chrpath:${PORTSDIR}/devel/chrpath \
cmake:${PORTSDIR}/devel/cmake \
gmake:${PORTSDIR}/devel/gmake
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/matplotlib/__init__.py:${PORTSDIR}/math/py-matplotlib \
${PYTHON_SITELIBDIR}/paramiko/__init__.py:${PORTSDIR}/security/py-paramiko \
BUILD_DEPENDS= rosmake:${PORTSDIR}/devel/ros
RUN_DEPENDS= rosrun:${PORTSDIR}/devel/ros \
${LOCALBASE}/ros/stacks/ros_comm/stack.xml:${PORTSDIR}/devel/ros_comm \
${PYTHON_SITELIBDIR}/yaml/__init__.py:${PORTSDIR}/devel/py-yaml \
bash:${PORTSDIR}/shells/bash \
cmake:${PORTSDIR}/devel/cmake \
cppunit-config:${PORTSDIR}/devel/cppunit \
sphinx-build:${PORTSDIR}/textproc/py-sphinx \
doxygen:${PORTSDIR}/devel/doxygen \
epydoc:${PORTSDIR}/devel/epydoc \
f2py:${PORTSDIR}/math/py-numpy \
gmake:${PORTSDIR}/devel/gmake \
dot:${PORTSDIR}/graphics/graphviz \
pilconvert.py:${PORTSDIR}/graphics/py-imaging \
sudo:${PORTSDIR}/security/sudo \
wget:${PORTSDIR}/ftp/wget
USE_GNOME= pkgconfig pygtk2
epydoc:${PORTSDIR}/devel/epydoc
USE_PYTHON= yes
USE_WX= 2.8
WX_COMPS= python:build python:run
USE_BZIP2= yes
USE_LDCONFIG= yes
# rosmake does its own threading
MAKE_JOBS_UNSAFE= yes
MAKE_ENV+= CPATH=${LOCALBASE}/include \
EXTRA_CMAKE_FLAGS="-DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG}" \
LIBRARY_PATH=${LOCALBASE}/lib \
MAKE=${LOCALBASE}/bin/gmake \
PATH=${PATH}:${WRKSRC}/bin \
PYTHONPATH=${WRKSRC}/core/roslib/src \
ROS_ROOT=${LOCALBASE}/ros/ros \
PYTHONPATH=${LOCALBASE}/ros/ros/core/roslib/src \
ROS_BOOST_ROOT=${LOCALBASE} \
ROS_PACKAGE_PATH= \
ROS_ROOT=${WRKSRC}
ALL_TARGET=
SUB_FILES= pkg-message
SUB_LIST= LOCALBASE=${LOCALBASE} \
PREFIX=${PREFIX} \
WX_CONFIG=${WX_CONFIG}
PORTDOCS= AUTHORS README
post-extract:
# move 3rdparty distfiles into place
${MKDIR} ${WRKSRC}/3rdparty/gtest/build
${CP} ${_DISTDIR}/gtest-1.5.0.tar.gz ${WRKSRC}/3rdparty/gtest/build
${MKDIR} ${WRKSRC}/3rdparty/wxswig/build
${CP} ${_DISTDIR}/SWIG-1.3.29-wx.tar.gz ${WRKSRC}/3rdparty/wxswig/build
ROS_PACKAGE_PATH=${LOCALBASE}/ros/stacks/ros_comm:${WRKSRC}
MAKE_ARGS= -i --no-rosdep --status-rate=0 --disable-logging
post-patch:
# fix path to the wx configure tool and bash
${REINPLACE_CMD} -E -e "s|wx-config|${WX_CONFIG}|" \
${WRKSRC}/3rdparty/wxswig/manifest.xml
# fix path to bash
${GREP} -l -r "^#\!/bin/bash" ${WRKSRC} | ${XARGS} \
${REINPLACE_CMD} -E -e "s|#!/bin/bash|#!${LOCALBASE}/bin/bash|"
# temporarily alter how ROS is built for the port build
${REINPLACE_CMD} -E -e "s|--rosdep-install|--no-rosdep -i --disable-logging|" \
${WRKSRC}/Makefile
pre-build:
.if exists(${LOCALBASE}/lib/libgtest.so)
# temporarily move libraries from devel/googletest out of the way
${MKDIR} ${WRKSRC}/googletest_backup
.for f in .a .la .so .so.* _main.a _main.la _main.so _main.so.*
${MV} ${LOCALBASE}/lib/libgtest${f} ${WRKSRC}/googletest_backup
.endfor
.endif
post-build:
.if exists(${WRKSRC}/googletest_backup/libgtest.so)
# restore libraries from devel/googletest
.for f in .a .la .so .so.* _main.a _main.la _main.so _main.so.*
${MV} ${WRKSRC}/googletest_backup/libgtest${f} ${LOCALBASE}/lib
.endfor
.endif
# restore original ROS Makefile
${MV} ${WRKSRC}/Makefile.bak ${WRKSRC}/Makefile
do-build:
(cd ${WRKSRC} ; ${MAKE_ENV} ${LOCALBASE}/bin/rosmake ${MAKE_ARGS})
do-install:
${MKDIR} ${PREFIX}/ros/ros/bin
${MKDIR} ${PREFIX}/ros/stacks
.for f in rospack rosplay rosrecord rosstack rxconsole rxloggerlevel
${LOCALBASE}/bin/chrpath -d ${WRKSRC}/bin/${f}
${INSTALL_PROGRAM} ${WRKSRC}/bin/${f} ${PREFIX}/ros/ros/bin
${LN} -s ${PREFIX}/ros/ros/bin/${f} ${PREFIX}/bin/${f}
.endfor
.for f in rosbag rosboost-cfg rosclean rosconfig roscore roscreate-pkg \
roscreate-stack rosdep rosgraph roslaunch roslaunch-deps roslaunch-logs \
roslocate rosmake rosmaster rosmsg rosnode rosparam rosrebag rosrun \
rosservice rossrv rostest rostopic rosversion roswtf rxbag rxdeps rxgraph \
rxplot
${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${PREFIX}/ros/ros/bin
${LN} -s ${PREFIX}/ros/ros/bin/${f} ${PREFIX}/bin/${f}
.endfor
${INSTALL_DATA} ${WRKSRC}/bin/rospack_nosubdirs ${PREFIX}/ros/ros/bin
${MKDIR} ${PREFIX}/ros/stacks/${STACKNAME}
.for f in CMakeLists.txt Makefile rosdep.yaml stack.xml
${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/ros/ros
${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/ros/stacks/${STACKNAME}
.endfor
# delete files explicitly because negation in find (for COPYTREE_SHARE) is bogus
.for d in 3rdparty config core std_msgs std_srvs test tools
.for d in rosdoc
${FIND} ${WRKSRC}/${d} -name build -type d -or -name \*.bak -type f \
-or -name .svnignore -type f -or -name .cvsignore -type f \
-or -name \*.orig -type f | ${XARGS} ${RM} -rf
(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${PREFIX}/ros/ros)
.endfor
# strip and symlink libraries to PREFIX/lib (except gtest)
.for f in core/message_filters/lib/libmessage_filters.so \
core/rosconsole/lib/librosconsole.so core/roscpp/lib/libros.so \
core/roslib/lib/libroslib.so \
test/performance/perf_roscpp/lib/libperf_roscpp.so \
tools/rosbag/lib/librosbag.so tools/rospack/lib/librospack.so \
tools/rospack/lib/librosstack.so tools/rosrecord/lib/librosrecorder.so \
tools/rxtools/lib/librxtools.so tools/rxtools/lib/_rxtoolscpp.so \
tools/topic_tools/lib/libtopic_tools.so 3rdparty/xmlrpcpp/lib/libXmlRpc.so
${STRIP_CMD} ${PREFIX}/ros/ros/${f}
${LOCALBASE}/bin/chrpath -d ${PREFIX}/ros/ros/${f}
${LN} -s ${PREFIX}/ros/ros/${f} ${PREFIX}/lib
.endfor
# strip gtest libraries
.for f in 3rdparty/gtest/gtest/lib/libgtest.so.0 \
3rdparty/gtest/gtest/lib/libgtest_main.so.0
${STRIP_CMD} ${PREFIX}/ros/ros/${f}
${LOCALBASE}/bin/chrpath -d ${PREFIX}/ros/ros/${f}
.endfor
# strip ELF binaries and make them executable
.for f in 3rdparty/wxswig/bin/swig-real core/genmsg_cpp/genmsg_java \
core/genmsg_cpp/genmsg_lisp core/genmsg_cpp/genmsg_oct \
core/genmsg_cpp/gensrv_java core/genmsg_cpp/gensrv_lisp \
core/genmsg_cpp/gensrv_oct core/rosout/rosout \
test/performance/perf_roscpp/bin/intra_suite \
test/performance/test_roscpp_serialization_perf/pointcloud_serdes \
test/test_roscpp/bin/check_master \
test/test_roscpp/bin/get_master_information test/test_roscpp/bin/handles \
test/test_roscpp/bin/incrementing_sequence test/test_roscpp/bin/inspection \
test/test_roscpp/bin/intraprocess_subscriptions \
test/test_roscpp/bin/latching_publisher \
test/test_roscpp/bin/loads_of_publishers \
test/test_roscpp/bin/log test/test_roscpp/bin/multiple_init_fini \
test/test_roscpp/bin/multiple_subscriptions \
test/test_roscpp/bin/name_remapping \
test/test_roscpp/bin/name_remapping_with_ns \
test/test_roscpp/bin/namespaces \
test/test_roscpp/bin/nonconst_subscriptions \
test/test_roscpp/bin/param_update_test \
test/test_roscpp/bin/parameter_validation test/test_roscpp/bin/params \
test/test_roscpp/bin/pub_sub test/test_roscpp/bin/publish_constantly \
test/test_roscpp/bin/publish_empty test/test_roscpp/bin/publish_n_fast \
test/test_roscpp/bin/publish_onsub \
test/test_roscpp/bin/publish_unadvertise \
test/test_roscpp/bin/publisher_for_star_subscriber \
test/test_roscpp/bin/real_time_test test/test_roscpp/bin/service_adv \
test/test_roscpp/bin/service_adv_a \
test/test_roscpp/bin/service_adv_multiple \
test/test_roscpp/bin/service_adv_unadv test/test_roscpp/bin/service_call \
test/test_roscpp/bin/service_call_expect_b \
test/test_roscpp/bin/service_call_repeatedly \
test/test_roscpp/bin/service_callback_types \
test/test_roscpp/bin/service_wait_a_adv_b \
test/test_roscpp/bin/sim_time_test test/test_roscpp/bin/sub_pub \
test/test_roscpp/bin/subscribe_empty test/test_roscpp/bin/subscribe_n_fast \
test/test_roscpp/bin/subscribe_resubscribe \
test/test_roscpp/bin/subscribe_retry_tcp \
test/test_roscpp/bin/subscribe_self test/test_roscpp/bin/subscribe_star \
test/test_roscpp/bin/subscribe_unsubscribe \
test/test_roscpp/bin/subscribe_unsubscribe_repeatedly \
test/test_roscpp/bin/subscription_callback_types \
test/test_roscpp/bin/timer_callbacks test/test_roscpp/bin/wait_for_message \
test/test_roscpp_serialization/bin/builtin_types \
test/test_roscpp_serialization/bin/pre_deserialize tools/rosbag/bin/play \
tools/rosbag/bin/record tools/rosrecord/bin/rosplay \
tools/rosrecord/bin/rosrecord tools/rxtools/bin/rxconsole \
tools/rxtools/bin/rxloggerlevel tools/topic_tools/bin/drop \
tools/topic_tools/bin/mux tools/topic_tools/bin/relay \
tools/topic_tools/bin/switch_mux tools/topic_tools/bin/throttle \
tools/topic_tools/test/test_shapeshifter
${STRIP_CMD} ${PREFIX}/ros/ros/${f}
${LOCALBASE}/bin/chrpath -d ${PREFIX}/ros/ros/${f}
${CHMOD} 0555 ${PREFIX}/ros/ros/${f}
(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${PREFIX}/ros/stacks/${STACKNAME})
.endfor
# make scripts executable
.for f in 3rdparty/gtest/gtest/bin/gtest-config 3rdparty/wxswig/bin/swig \
core/mk/make_pydev_project.py core/rosbuild/bin/check_same_directories.py \
core/rosbuild/bin/checkout_latest_stable \
core/rosbuild/bin/create_release.py core/rosbuild/bin/download_checkmd5.py \
core/rosbuild/bin/makestackdist core/rosbuild/bin/package_source.py \
core/rosbuild/bin/roscheck \
core/rosbuild/bin/rosgcov core/rosbuild/bin/rosgcov_summarize \
core/rosbuild/bin/rosmakeall core/rosbuild/bin/rosmakeall_osx \
core/rosbuild/bin/rosmakeall_stackdist core/rosbuild/bin/rossvnignore \
core/rosbuild/bin/rostar core/rosbuild/tests/count_cores.py \
core/rosconsole/scripts/generate_macros.py \
core/rosconsole/scripts/generate_speed_test.py \
core/roscpp/scripts/genmsg_cpp.py core/roscpp/scripts/genmsgtest \
core/roscpp/scripts/gensrv_cpp.py core/roslib/scripts/gendeps \
core/roslib/scripts/pythontest core/roslisp/s-xml-rpc/test/test.b64 \
core/roslisp/scripts/genmsg_lisp.py core/roslisp/scripts/make_node_exec \
core/roslisp/scripts/make_roslisp_image core/rosout/rosout_agg_listener \
core/rosout/rosout_talker core/rospy/scripts/genmsg_py.py \
core/rospy/scripts/gensrv_py.py test/rostest/bin/catunit \
test/rostest/bin/cleanunit test/rostest/bin/coverage-html \
test/rostest/bin/roslaunch-check.py test/rostest/bin/rostest \
test/rostest/bin/rostest-check-results test/rostest/bin/rostest-results \
test/rostest/bin/test-results-dir test/rostest/nodes/hztest \
test/rostest/test/time_limit_test.py \
test/test_ros/nodes/add_two_ints_client \
test/test_ros/nodes/add_two_ints_server \
test/test_ros/nodes/fail_two_ints_server test/test_ros/nodes/listener.py \
test/test_ros/nodes/talker.py test/test_ros/nodes/testAllCommonFlows \
test/test_ros/nodes/testMaster test/test_ros/nodes/testSlave \
test/test_ros/test/test_master_api.py test/test_ros/test/test_node_api.py \
test/test_ros/test/test_ps_encapsulation.py \
test/test_ros/test/test_ps_get_param.py \
test/test_ros/test/test_ps_has_param.py \
test/test_ros/test/test_ps_private_names.py \
test/test_ros/test/test_ps_scope_down.py \
test/test_ros/test/test_ps_scope_up.py \
test/test_ros/test/test_ps_search_param.py \
test/test_ros/test/test_ps_set_param.py \
test/test_ros/test/test_ps_values.py test/test_ros/test/test_roslocate.py \
test/test_rosbag/current test/test_rosbag/gen1 test/test_rosbag/gen2 \
test/test_rosbag/gen3 test/test_rosbag/generate_data \
test/test_rosbag/scripts/generate_data_1.py \
test/test_rosbag/scripts/generate_data_2.py \
test/test_rosbag/scripts/generate_data_3.py \
test/test_rosbag/test/migrate_test.py test/test_rosbag/test/random_play.py \
test/test_rosbag/test/random_record.py test/test_rosbagmigration/current \
test/test_rosbagmigration/gen1 test/test_rosbagmigration/gen2 \
test/test_rosbagmigration/gen3 test/test_rosbagmigration/generate_data \
test/test_rosbagmigration/scripts/generate_data_1.py \
test/test_rosbagmigration/scripts/generate_data_2.py \
test/test_rosbagmigration/scripts/generate_data_3.py \
test/test_rosbagmigration/test/migrate_test.py \
test/test_rosgraph/test/test_rosgraph_masterapi_online.py \
test/test_roslaunch/test/env.py test/test_roslaunch/test/params_basic.py \
test/test_roslaunch/test/test_roslaunch_command_line_online.py \
test/test_roslaunch/test/test_xmlloader.py \
test/test_roslib/test/fake_node.py \
test/test_roslib/test/test_roslib_masterapi_online.py \
test/test_rosmake/test/test_parallel_build.py \
test/test_rosnode/test/test_rosnode_command_online.py \
test/test_rospack/test/rosbar/scripts/genmsg_bar \
test/test_rospack/test/rosfoo/scripts/genmsg_foo \
test/test_rospack/test/utest_rosstack.py \
test/test_rosparam/test/test_rosparam.py \
test/test_rosparam/test/test_rosparam_command_line_online.py \
test/test_rospy/nodes/listener.py \
test/test_rospy/nodes/publish_on_shutdown.py \
test/test_rospy/nodes/talker.py test/test_rospy/test/listenerpublisher.py \
test/test_rospy/test/listenerpublisher_embed.py \
test/test_rospy/test/talker test/test_rospy/test/test_basic_services.py \
test/test_rospy/test/test_client_param_api.py \
test/test_rospy/test/test_client_param_server.py \
test/test_rospy/test/test_deregister.py \
test/test_rospy/test/test_embed_msg.py \
test/test_rospy/test/test_empty_service.py \
test/test_rospy/test/test_latch.py test/test_rospy/test/test_node.py \
test/test_rospy/test/test_on_shutdown.py \
test/test_rospy/test/test_pubsub_order.py \
test/test_rospy/test/test_rospy_client_online.py \
test/test_rospy/test/test_service_failure.py \
test/test_rospy/test/test_service_order.py \
test/test_rosrecord/scripts/generate_data.py \
test/test_rosrecord/test/random_play.py \
test/test_rosrecord/test/random_pub_node.py \
test/test_rosrecord/test/random_record.py \
test/test_rosrecord/test/rename_test.py \
test/test_rosservice/test/test_rosservice.py \
test/test_rosservice/test/test_rosservice_command_line_online.py \
test/test_rostopic/test/test_rostopic.py \
test/test_rostopic/test/test_rostopic_command_line_online.py \
test/test_roswtf/test/test_roswtf_command_line_online.py \
tools/rosbag/bin/rosbag tools/rosbag/scripts/bag2png.py \
tools/rosbag/scripts/bagsort.py tools/rosbag/scripts/fastrebag.py \
tools/rosbag/scripts/fix_md5sums.py \
tools/rosbag/scripts/fix_moved_messages.py tools/rosbag/scripts/fixbag.py \
tools/rosbag/scripts/fixbag_batch.py tools/rosbag/scripts/makerule.py \
tools/rosbag/scripts/savemsg.py \
tools/rosbag/scripts/topic_renamer.py tools/rosbag/test/latched_pub.py \
tools/rosbag/test/latched_sub.py tools/rosbagmigration/scripts/checkbag.py \
tools/rosbagmigration/scripts/fixbag.py \
tools/rosbagmigration/scripts/fixbag_batch.py \
tools/rosbagmigration/scripts/makerule.py \
tools/rosbagmigration/scripts/savemsg.py \
tools/rosdep/installers/preinstall.macports tools/rosdep/scripts/rosdep \
tools/rosdoc/rosdoc tools/rosdoc/scripts/checkout.py \
tools/rosdoc/scripts/upload tools/rosemacs/poll-rosnode \
tools/rosemacs/poll-rostopic tools/rosgraph/nodes/rosgraph \
tools/rosgraph/nodes/rxgraph tools/roslaunch/bin/roslaunch \
tools/roslaunch/bin/roslaunch-console tools/rospack/markstack \
tools/rospack/rosalldeps tools/rospack/rosallpkgs \
tools/rospack/roscachesvncert tools/rospack/rospack_lite.py \
tools/rospack/rossearch tools/rosrecord/scripts/bag2png.py \
tools/rosrecord/scripts/bagsort.py tools/rosrecord/scripts/fastrebag.py \
tools/rosrecord/scripts/fix_md5sums.py \
tools/rosrecord/scripts/fix_moved_messages.py \
tools/rosrecord/test/test_rosrecord_offline.py \
tools/rosservice/bin/rosservice tools/rostopic/bin/rostopic \
tools/roswtf/bin/roswtf tools/rxbag/scripts/rxbag \
tools/rxtools/nodes/rxplot tools/topic_tools/demos/test_drop \
tools/topic_tools/demos/test_mux tools/topic_tools/demos/test_relay \
tools/topic_tools/demos/test_throttle tools/topic_tools/scripts/mux_add \
tools/topic_tools/scripts/mux_delete tools/topic_tools/scripts/mux_list \
tools/topic_tools/scripts/mux_select \
tools/topic_tools/test/test_mux_delete_add.py \
tools/topic_tools/test/test_mux_services.py tools/xdot/dot_viewer.py
${CHMOD} 0555 ${PREFIX}/ros/ros/${f}
.for f in rosdoc/scripts/upload rosdoc/rosdoc
${CHMOD} 0555 ${PREFIX}/ros/stacks/${STACKNAME}/${f}
.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
post-install:
@${CAT} ${PKGMESSAGE}
${PYTHON_CMD} -O -mcompileall ${PREFIX}/ros/stacks/${STACKNAME}/
${PYTHON_CMD} -mcompileall ${PREFIX}/ros/stacks/${STACKNAME}/
.include <bsd.port.mk>

View File

@ -1,6 +1,2 @@
SHA256 (ros/ros-1.2.6.tar.bz2) = 4dd3ed44c88655a6e4947531a8dd7a57c3fc64f0d2b3e8e660a2d50a2f091acd
SIZE (ros/ros-1.2.6.tar.bz2) = 1537227
SHA256 (ros/SWIG-1.3.29-wx.tar.gz) = fbd316cb2da250a846a5dbedf48e1deee0600b40af88da5f7ca5c01f3d02c66d
SIZE (ros/SWIG-1.3.29-wx.tar.gz) = 3143417
SHA256 (ros/gtest-1.5.0.tar.gz) = 24156a23cfa49a194c48d1b630fd8eaa63fffc403719b5ddb94cdbe8d9a96aff
SIZE (ros/gtest-1.5.0.tar.gz) = 896874
SHA256 (ros/documentation-1.4.1.tar.bz2) = eb6f756c43084a6ba56820c35d1f7714112ca885b2b403d7f92cf23300223e46
SIZE (ros/documentation-1.4.1.tar.bz2) = 23923

View File

@ -1,11 +0,0 @@
--- core/rosconsole/include/ros/console.h.orig 2010-03-13 03:03:10.000000000 +0100
+++ core/rosconsole/include/ros/console.h 2010-11-03 22:46:51.000000000 +0100
@@ -105,7 +105,7 @@
*/
void initialize();
-struct FilterBase;
+class FilterBase;
/**
* \brief Don't call this directly. Use the ROS_LOG() macro instead.
* @param level Logging level

View File

@ -1,81 +0,0 @@
--- core/roscpp/include/ros/subscribe_options.h.orig 2010-05-11 23:23:34.000000000 +0200
+++ core/roscpp/include/ros/subscribe_options.h 2010-10-28 00:53:16.000000000 +0200
@@ -80,7 +80,7 @@
template<class P>
void initByFullCallbackType(const std::string& _topic, uint32_t _queue_size,
const boost::function<void (P)>& _callback,
- const boost::function<boost::shared_ptr<typename ParameterAdapter<P>::Message>(void)>& factory_fn = defaultMessageCreateFunction<typename ParameterAdapter<P>::Message>)
+ boost::function<boost::shared_ptr<typename ParameterAdapter<P>::Message>(void)> factory_fn = defaultMessageCreateFunction<typename ParameterAdapter<P>::Message>)
{
typedef typename ParameterAdapter<P>::Message MessageType;
topic = _topic;
@@ -101,7 +101,7 @@
template<class M>
void init(const std::string& _topic, uint32_t _queue_size,
const boost::function<void (const boost::shared_ptr<M const>&)>& _callback,
- const boost::function<boost::shared_ptr<M>(void)>& factory_fn = defaultMessageCreateFunction<M>)
+ boost::function<boost::shared_ptr<M>(void)> factory_fn = defaultMessageCreateFunction<M>)
{
typedef typename ParameterAdapter<M>::Message MessageType;
topic = _topic;
--- core/roscpp/include/ros/service_callback_helper.h.orig 2010-02-18 23:22:20.000000000 +0100
+++ core/roscpp/include/ros/service_callback_helper.h 2010-10-28 01:05:35.000000000 +0200
@@ -165,7 +165,7 @@
typedef boost::function<RequestPtr()> ReqCreateFunction;
typedef boost::function<ResponsePtr()> ResCreateFunction;
- ServiceCallbackHelperT(const Callback& callback, const ReqCreateFunction& create_req = defaultServiceCreateFunction<RequestType>, const ResCreateFunction& create_res = defaultServiceCreateFunction<ResponseType>)
+ ServiceCallbackHelperT(const Callback& callback, ReqCreateFunction create_req = defaultServiceCreateFunction<RequestType>, ResCreateFunction create_res = defaultServiceCreateFunction<ResponseType>)
: callback_(callback)
, create_req_(create_req)
, create_res_(create_res)
--- core/roscpp/include/ros/topic_manager.h.orig 2010-02-18 23:22:20.000000000 +0100
+++ core/roscpp/include/ros/topic_manager.h 2010-11-03 22:48:40.000000000 +0100
@@ -42,8 +42,8 @@
{
class Message;
-class SubscribeOptions;
-class AdvertiseOptions;
+struct SubscribeOptions;
+struct AdvertiseOptions;
class TopicManager;
typedef boost::shared_ptr<TopicManager> TopicManagerPtr;
--- core/roscpp/include/ros/message_event.h.orig 2010-07-13 04:08:40.000000000 +0200
+++ core/roscpp/include/ros/message_event.h 2010-11-03 22:50:05.000000000 +0100
@@ -93,7 +93,7 @@
nonconst_need_copy_ = nonconst_need_copy;
}
- MessageEvent(const MessageEvent<void const>& rhs, const CreateFunction& create)
+ MessageEvent(const MessageEvent<void const>& rhs, CreateFunction create)
{
init(boost::const_pointer_cast<Message>(boost::static_pointer_cast<ConstMessage>(rhs.getMessage())), rhs.getConnectionHeaderPtr(), rhs.getReceiptTime(), rhs.nonConstWillCopy(), create);
}
@@ -116,12 +116,12 @@
init(message, getConnectionHeader(message.get()), receipt_time, true, ros::defaultMessageCreateFunction<Message>);
}
- MessageEvent(const ConstMessagePtr& message, const boost::shared_ptr<M_string>& connection_header, ros::Time receipt_time, bool nonconst_need_copy, const CreateFunction& create)
+ MessageEvent(const ConstMessagePtr& message, const boost::shared_ptr<M_string>& connection_header, ros::Time receipt_time, bool nonconst_need_copy, CreateFunction create)
{
init(message, connection_header, receipt_time, nonconst_need_copy, create);
}
- void init(const ConstMessagePtr& message, const boost::shared_ptr<M_string>& connection_header, ros::Time receipt_time, bool nonconst_need_copy, const CreateFunction& create)
+ void init(const ConstMessagePtr& message, const boost::shared_ptr<M_string>& connection_header, ros::Time receipt_time, bool nonconst_need_copy, CreateFunction create)
{
message_ = message;
connection_header_ = connection_header;
--- core/roscpp/include/ros/transport_publisher_link.h.orig 2010-03-16 19:38:21.000000000 +0100
+++ core/roscpp/include/ros/transport_publisher_link.h 2010-11-03 22:50:31.000000000 +0100
@@ -41,7 +41,7 @@
class Connection;
typedef boost::shared_ptr<Connection> ConnectionPtr;
-class WallTimerEvent;
+struct WallTimerEvent;
/**
* \brief Handles a connection to a single publisher on a given topic. Receives messages from a publisher

View File

@ -1,10 +0,0 @@
--- core/roslib/include/ros/serialization.h.orig 2010-04-22 03:40:40.000000000 +0200
+++ core/roslib/include/ros/serialization.h 2010-11-03 22:51:34.000000000 +0100
@@ -37,6 +37,7 @@
#include "macros.h"
#include <vector>
+#include <cstring>
#include <boost/array.hpp>
#include <boost/call_traits.hpp>

View File

@ -1,66 +0,0 @@
--- core/message_filters/include/message_filters/synchronizer.h.orig 2010-03-16 01:10:42.000000000 +0100
+++ core/message_filters/include/message_filters/synchronizer.h 2010-11-03 22:52:18.000000000 +0100
@@ -357,7 +357,7 @@
template<int i>
void cb(const typename mpl::at_c<Events, i>::type& evt)
{
- add<i>(evt);
+ this->add<i>(evt);
}
uint32_t queue_size_;
--- core/message_filters/include/message_filters/chain.h.orig 2010-04-23 19:40:54.000000000 +0200
+++ core/message_filters/include/message_filters/chain.h 2010-11-03 22:52:42.000000000 +0100
@@ -234,7 +234,7 @@
void lastFilterCB(const EventType& evt)
{
- signalMessage(evt);
+ this->signalMessage(evt);
}
struct FilterInfo
--- core/message_filters/include/message_filters/cache.h.orig 2010-04-23 19:40:54.000000000 +0200
+++ core/message_filters/include/message_filters/cache.h 2010-11-03 22:53:01.000000000 +0100
@@ -152,7 +152,7 @@
}
- signalMessage(evt);
+ this->signalMessage(evt);
}
/**
--- core/message_filters/include/message_filters/subscriber.h.orig 2010-04-23 19:40:54.000000000 +0200
+++ core/message_filters/include/message_filters/subscriber.h 2010-11-03 22:53:21.000000000 +0100
@@ -202,7 +202,7 @@
void cb(const EventType& e)
{
- signalMessage(e);
+ this->signalMessage(e);
}
ros::Subscriber sub_;
--- core/message_filters/include/message_filters/pass_through.h.orig 2010-03-15 23:46:55.000000000 +0100
+++ core/message_filters/include/message_filters/pass_through.h 2010-11-03 22:54:26.000000000 +0100
@@ -75,7 +75,7 @@
void add(const EventType& evt)
{
- signalMessage(evt);
+ this->signalMessage(evt);
}
private:
--- core/message_filters/include/message_filters/time_sequencer.h.orig 2010-02-18 23:22:20.000000000 +0100
+++ core/message_filters/include/message_filters/time_sequencer.h 2010-11-03 22:54:50.000000000 +0100
@@ -208,7 +208,7 @@
typename V_Message::iterator end = to_call.end();
for (; it != end; ++it)
{
- signalMessage(*it);
+ this->signalMessage(*it);
}
}
}

View File

@ -1,10 +0,0 @@
--- tools/rosbash/rosbash.orig 2010-06-28 22:22:33.000000000 +0200
+++ tools/rosbash/rosbash 2010-12-03 19:52:43.000000000 +0100
@@ -1,6 +1,6 @@
function _rossed {
- if [[ `uname` == Darwin ]]; then
+ if [[ `uname` == Darwin || `uname` == FreeBSD ]]; then
sed -E "$@"
else
sed -r "$@"

View File

@ -1,17 +0,0 @@
--- core/roscpp/src/libros/CMakeLists.txt.orig 2010-03-13 00:27:34.000000000 +0100
+++ core/roscpp/src/libros/CMakeLists.txt 2010-12-03 18:53:09.000000000 +0100
@@ -2,9 +2,12 @@
include(CheckFunctionExists)
# Not everybody has <ifaddrs.h> (e.g., embedded arm-linux)
-CHECK_INCLUDE_FILES(ifaddrs.h HAVE_IFADDRS_H)
+#XXX ugly hack, should update the tests themselves
+#CHECK_INCLUDE_FILES(ifaddrs.h HAVE_IFADDRS_H)
+set(HAVE_IFADDRS_H true)
# Not everybody has trunc (e.g., Windows, embedded arm-linux)
-CHECK_FUNCTION_EXISTS(trunc HAVE_TRUNC)
+#CHECK_FUNCTION_EXISTS(trunc HAVE_TRUNC)
+set(HAVE_TRUNC true)
# Output test results to config.h
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/config.h)

View File

@ -1,12 +0,0 @@
--- core/roscpp/src/libros/network.cpp.orig 2010-07-21 01:48:07.000000000 +0200
+++ core/roscpp/src/libros/network.cpp 2010-12-03 20:18:21.000000000 +0100
@@ -34,6 +34,9 @@
#include <ros/assert.h>
#include <netinet/in.h>
+#ifdef HAVE_IFADDRS_H
+ #include <sys/types.h>
+#endif
#include <sys/socket.h>
#include <netdb.h>

View File

@ -1,43 +0,0 @@
--- 3rdparty/gtest/Makefile.orig 2010-10-25 08:35:45.000000000 +0200
+++ 3rdparty/gtest/Makefile 2010-10-27 21:24:06.000000000 +0200
@@ -1,9 +1,9 @@
all: gtest
-TARBALL = build/gtest-1.3.0.tar.gz
+TARBALL = build/gtest-1.5.0.tar.gz
TARBALL_URL = http://pr.willowgarage.com/downloads/gtest-1.3.0.tar.gz
-SOURCE_DIR = build/gtest-1.3.0
-MD5SUM_FILE = gtest-1.3.0.tar.gz.md5sum
+SOURCE_DIR = build/gtest-1.5.0
+MD5SUM_FILE = gtest-1.5.0.tar.gz.md5sum
include $(shell rospack find mk)/download_unpack_build.mk
# gtest's death test appears to hang when gtest is compiled with Bullseye's
@@ -17,7 +17,7 @@
endif
gtest: $(SOURCE_DIR)/unpacked
- cd $(SOURCE_DIR) && PATH=$(NEWPATH) ./configure --prefix=$(CURDIR)/gtest
+ cd $(SOURCE_DIR) && PATH=$(NEWPATH) CXXFLAGS="$(CXXFLAGS) -DGTEST_HAS_TR1_TUPLE=0" ./configure --prefix=$(CURDIR)/gtest
cd $(SOURCE_DIR) && PATH=$(NEWPATH) make install
touch gtest
--- core/rosbuild/public.cmake.orig 2010-10-25 08:35:45.000000000 +0200
+++ core/rosbuild/public.cmake 2010-10-28 11:40:56.000000000 +0200
@@ -419,7 +419,7 @@
include_directories(${_gtest_PACKAGE_PATH}/gtest/include)
link_directories(${_gtest_PACKAGE_PATH}/gtest/lib)
set(_gtest_LIBRARIES -lgtest)
- set(_gtest_CFLAGS_OTHER "")
+ set(_gtest_CFLAGS_OTHER "-DGTEST_HAS_TR1_TUPLE=0")
set(_gtest_LDFLAGS_OTHER "-Wl,-rpath,${_gtest_PACKAGE_PATH}/gtest/lib")
#
--- /dev/null 2010-11-01 00:11:00.000000000 +0100
+++ 3rdparty/gtest/gtest-1.5.0.tar.gz.md5sum 2010-11-01 00:12:51.000000000 +0100
@@ -0,0 +1 @@
+7e27f5f3b79dd1ce9092e159cdbd0635 gtest-1.5.0.tar.gz
--- 3rdparty/gtest/gtest-1.3.0.tar.gz.md5sum 2010-05-11 00:43:08.000000000 +0200
+++ /dev/null 2010-11-01 00:52:23.000000000 +0100
@@ -1 +0,0 @@
-714e9c00c0616ea72ba076c6c5f401d2 gtest-1.3.0.tar.gz

View File

@ -0,0 +1,7 @@
--- ./rosdep.yaml.orig 2011-02-15 21:21:47.000000000 +0100
+++ ./rosdep.yaml 2011-03-19 23:21:12.000000000 +0100
@@ -18,3 +18,4 @@
ubuntu: python-sphinx
macports: py26-sphinx
debian: python-sphinx
+ freebsd: py27-sphinx

View File

@ -1,12 +0,0 @@
To use ROS, add these variables to your environment:
ROS_MASTER_URI <HTTP address of the host running roscore>:11311
ROS_ROOT %%PREFIX%%/ros/ros
ROS_PACKAGE_PATH %%PREFIX%%/ros/stacks:/my_other_ROS_directory
PYTHONPATH ${ROS_ROOT}/core/roslib/src
If you intend to build software with ROS:
CPATH %%LOCALBASE%%/include
EXTRA_CMAKE_FLAGS -DwxWidgets_CONFIG_EXECUTABLE=%%WX_CONFIG%%
LIBRARY_PATH %%LOCALBASE%%/lib
MAKE %%LOCALBASE%%/bin/gmake
ROS_BOOST_ROOT %%LOCALBASE%%

View File

@ -1,14 +1,5 @@
Robot Operating System (ROS) is a meta-operating system for your robot.
It provides several services for a robot control system, including but
not limited to:
* language-independent and network-transparent communication
* including hardware abstraction
* low-level device control
* implementation of commonly-used functionality
* message-passing between processes
The documentation stack houses documentation tools for ROS. This stack
exists separately from the main ros stack in order to minimize heavyweight
dependencies, such as Doxygen, LaTeX, Epydoc, and Sphinx.
This port provides the core part of ROS: the base system and the tools
to develop additional nodes. These additional nodes can be installed
manually or via the Ports Collection.
WWW: http://www.ros.org/wiki/
WWW: http://www.ros.org/wiki/documentation

File diff suppressed because it is too large Load Diff