- Update to 0.8 b2 which fixes build with gcc 4.x

- Fix WWW in pkg-descr
- Remove nop knob USE_GETOPT_LONG
- Install additional documents

PR:		ports/114565
Submitted by:	Petar Zhivkov Petrov <sinn at debian.fmi.uni-sofia.bg>
Approved by:	Samy Bahra <sbahra at gwu.edu> (maintainer)
This commit is contained in:
Rong-En Fan 2007-07-15 07:15:42 +00:00
parent 8cb62f243e
commit dd4c16bd46
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=195642
6 changed files with 32 additions and 59 deletions

View File

@ -6,18 +6,16 @@
#
PORTNAME= nvclock
PORTVERSION= 0.7
PORTREVISION= 6
DISTVERSION= 0.8b2
CATEGORIES= sysutils
MASTER_SITES= http://www.linuxhardware.org/nvclock/ \
http://www.kerneled.com/freebsd/ports/
DISTNAME= nvclock${PORTVERSION}
DISTNAME= nvclock${DISTVERSION}
MAINTAINER= sbahra@gwu.edu
COMMENT= The nVidia graphic card status and overclocking tool
USE_GMAKE= yes
USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig
@ -29,6 +27,10 @@ USE_GNOME+= gtk20
PLIST_SUB+= GTK=""
.endif
MAN1= nvclock.1
PORTDOCS= ABOUT AUTHORS ChangeLog FAQ README
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "************************************************"
@ -42,4 +44,15 @@ post-patch:
@${REINPLACE_CMD} -e 's|"CFLAGS="|"CFLAGS+="|g' ${WRKSRC}/${i}
.endfor
do-install:
@${GMAKE} -C ${WRKSRC}/src install
@${GMAKE} -C ${WRKSRC} install-man
.if !defined(WITHOUT_GUI)
@${GMAKE} -C ${WRKSRC}/src/gtk install
.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${GMAKE} -C ${WRKSRC} install-docs
.endif
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (nvclock0.7.tar.gz) = a3bb5ff1c2638317f1a69c7c2442b9e4
SHA256 (nvclock0.7.tar.gz) = 469678f436b974b62af51aa4bf71fdf695c402ed0cd890c25fc0b757577657e8
SIZE (nvclock0.7.tar.gz) = 68966
MD5 (nvclock0.8b2.tar.gz) = 8b9f55115f3c5b7b9a9a16fe40cec4a5
SHA256 (nvclock0.8b2.tar.gz) = b3c05f1cceb57a816cea096f9b71154c0ce5e2ec31febb85e3db831b0b3407aa
SIZE (nvclock0.8b2.tar.gz) = 316510

View File

@ -0,0 +1,10 @@
--- src/backend/back_bsd.c 2007-07-07 09:39:58.000000000 +0300
+++ src/backend/back_bsd.c_new 2007-07-07 09:39:15.000000000 +0300
@@ -51,6 +51,7 @@
static void *map_dev_mem (int fd, unsigned long Base, unsigned long Size);
static void unmap_dev_mem (unsigned long Base, unsigned long Size);
+static int probe_devices();
int init_nvclock()
{

View File

@ -1,33 +0,0 @@
--- src/gtk/callbacks.c Wed Aug 20 22:13:50 2003
+++ src/gtk/callbacks.c.patch Wed Aug 20 23:14:35 2003
@@ -36,11 +36,12 @@
{
va_list arg;
char* message;
+ GtkWidget *dialog;
+
va_start(arg, format);
message = g_strdup_vprintf(format, arg);
- GtkWidget *dialog;
switch(code)
{
case ERROR:
@@ -108,6 +109,7 @@
{
GtkWidget *label;
Timeout *timeout;
+ gint result;
timeout = g_malloc(sizeof(Timeout));
timeout->dialog = GTK_DIALOG(gtk_dialog_new_with_buttons("Testing the new speeds",
@@ -126,7 +128,7 @@
/* Create the real timeout */
timeout->timeout_id = g_timeout_add(1000, timeout_callback, timeout);
- gint result = gtk_dialog_run(GTK_DIALOG(timeout->dialog));
+ result = gtk_dialog_run(GTK_DIALOG(timeout->dialog));
/* Stop the timer because we got an answer back */
g_source_remove(timeout->timeout_id);

View File

@ -1,17 +0,0 @@
--- src/Makefile.in Sun Jun 22 23:19:18 2003
+++ src/Makefile.in.patch Wed Aug 20 23:30:46 2003
@@ -1,4 +1,5 @@
CC=@CC@
+LDFLAGS=@LDFLAGS@
INSTALL=@INSTALL@
SOURCES=nvclock.c
@@ -19,7 +20,7 @@
nvclock: $(libbackend) nvclock.c
- $(CC) -o nvclock $(INCLUDES) $(SOURCES) backend/libbackend.a
+ $(CC) -o nvclock $(INCLUDES) -I$(LOCALBASE)/include $(LDFLAGS) $(SOURCES) backend/libbackend.a
clean: clean-recursive clean-app

View File

@ -7,6 +7,6 @@ in order to make the utility much more user friendly
and to make it play nice with current distros and
drivers.
WWW: http://www.linuxhardware.org/nvclock/
- Samy Al Bahra <samy@kerneled.com>
WWW: http://www.linuxhardware.org/nvclock/