- Fix build on recent current: properly handle removed ioctl

- Add LICENSE_FILE
- Fix whitespace
- Remove unneeded options.mk include
This commit is contained in:
Dmitry Marakasov 2015-02-03 20:14:39 +00:00
parent c650efd1cd
commit dd0944a4b3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=378373
2 changed files with 17 additions and 7 deletions

View File

@ -10,8 +10,9 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= File and block device wiping utility
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= tar:bzip2
USES= tar:bzip2
GNU_CONFIGURE= yes
PLIST_FILES= bin/wipe man/man1/wipe.1.gz
@ -19,8 +20,6 @@ PORTDOCS= CHANGES INSTALL LICENSE README TESTING TODO copyright
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|@CFLAGS@|${CFLAGS}|' ${WRKSRC}/Makefile.in

View File

@ -1,6 +1,17 @@
--- blkdev.c.orig Sun Aug 3 16:07:29 2003
+++ blkdev.c Sat Mar 5 00:23:40 2005
@@ -141,6 +141,10 @@
--- blkdev.c.orig 2009-04-06 06:09:27.000000000 +0400
+++ blkdev.c 2015-02-03 23:00:08.000000000 +0300
@@ -46,7 +46,9 @@
#ifdef HAVE_SYS_DISKLABEL_H
# include <sys/disklabel.h>
-# define BSD_BLKDEV
+# ifdef DIOCGDINFO
+# define BSD_BLKDEV
+# endif
#endif
#ifndef LINUX_BLKDEV
@@ -141,6 +143,10 @@
int code;
#ifdef BSD_BLKDEV
@ -11,7 +22,7 @@
struct partinfo pinfo;
#endif
@@ -173,7 +177,7 @@
@@ -173,7 +179,7 @@
}
#ifdef BSD_BLKDEV