Update to version 0.5.2
PR: ports/73906 Submitted by: Ports Fury
This commit is contained in:
parent
cb5636162e
commit
dce3c88387
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=121549
@ -7,7 +7,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= vamos
|
||||
PORTVERSION= 0.5.0
|
||||
PORTVERSION= 0.5.2
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -15,17 +15,16 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= An automotive simulation framework
|
||||
|
||||
BUILD_DEPENDS= ${X11BASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
|
||||
${X11BASE}/lib/libplibul.a:${PORTSDIR}/x11-toolkits/plib
|
||||
BUILD_DEPENDS= ${X11BASE}/lib/libplibul.a:${PORTSDIR}/x11-toolkits/plib
|
||||
LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
|
||||
glut.3:${PORTSDIR}/graphics/libglut \
|
||||
png.5:${PORTSDIR}/graphics/png
|
||||
|
||||
USE_GNOME= gnometarget lthack
|
||||
USE_GL= yes
|
||||
USE_GETOPT_LONG= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL_VER=13
|
||||
USE_LIBTOOL_VER= 15
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
|
||||
MAKEINFO="makeinfo --no-split"
|
||||
INSTALLS_SHLIB= yes
|
||||
@ -46,9 +45,4 @@ BROKEN= "Does not compile on 4.x (port and dependencies need recent C++ compile
|
||||
post-extract:
|
||||
@${RM} -f ${WRKSRC}/doc/*.info*
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|-lsgxml -lsgmisc|-lsgxml -lsgstructure -lsgmisc|g ; \
|
||||
s|-pedantic||g'
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (vamos-0.5.0.tar.gz) = 410c3384a9daf28421086f6d36d1c500
|
||||
SIZE (vamos-0.5.0.tar.gz) = 1446002
|
||||
MD5 (vamos-0.5.2.tar.gz) = cdb00905342ea5fbf79998ba433b7a04
|
||||
SIZE (vamos-0.5.2.tar.gz) = 1449657
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.orig Sun Nov 9 06:15:34 2003
|
||||
+++ configure Mon Nov 10 13:08:47 2003
|
||||
@@ -8402,7 +8403,6 @@
|
||||
--- configure.orig Tue Oct 12 11:11:25 2004
|
||||
+++ configure Tue Nov 2 19:29:17 2004
|
||||
@@ -8722,7 +8722,6 @@
|
||||
fi
|
||||
|
||||
LIBS="$LIBS -L$x_libraries"
|
||||
@ -8,7 +8,7 @@
|
||||
|
||||
|
||||
ac_ext=cc
|
||||
@@ -10890,71 +10890,6 @@
|
||||
@@ -11352,81 +11351,6 @@
|
||||
opengl_LIBS="$LIBS $x_suffix"
|
||||
|
||||
|
||||
@ -20,7 +20,6 @@
|
||||
- ac_check_lib_save_LIBS=$LIBS
|
||||
-LIBS="-lfreeglut $opengl_LIBS $LIBS"
|
||||
-cat >conftest.$ac_ext <<_ACEOF
|
||||
-#line $LINENO "configure"
|
||||
-/* confdefs.h. */
|
||||
-_ACEOF
|
||||
-cat confdefs.h >>conftest.$ac_ext
|
||||
@ -44,11 +43,21 @@
|
||||
-_ACEOF
|
||||
-rm -f conftest.$ac_objext conftest$ac_exeext
|
||||
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
- (eval $ac_link) 2>&5
|
||||
- (eval $ac_link) 2>conftest.er1
|
||||
- ac_status=$?
|
||||
- grep -v '^ *+' conftest.er1 >conftest.err
|
||||
- rm -f conftest.er1
|
||||
- cat conftest.err >&5
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } &&
|
||||
- { ac_try='test -s conftest$ac_exeext'
|
||||
- { ac_try='test -z "$ac_c_werror_flag"
|
||||
- || test ! -s conftest.err'
|
||||
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
- (eval $ac_try) 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); }; } &&
|
||||
- { ac_try='test -s conftest$ac_exeext'
|
||||
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
- (eval $ac_try) 2>&5
|
||||
- ac_status=$?
|
||||
@ -61,7 +70,8 @@
|
||||
-
|
||||
-ac_cv_lib_freeglut_glutGetModifiers=no
|
||||
-fi
|
||||
-rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
|
||||
-rm -f conftest.err conftest.$ac_objext \
|
||||
- conftest$ac_exeext conftest.$ac_ext
|
||||
-LIBS=$ac_check_lib_save_LIBS
|
||||
-fi
|
||||
-echo "$as_me:$LINENO: result: $ac_cv_lib_freeglut_glutGetModifiers" >&5
|
||||
@ -80,7 +90,7 @@
|
||||
echo "$as_me:$LINENO: checking for glutGetModifiers in -lglut" >&5
|
||||
echo $ECHO_N "checking for glutGetModifiers in -lglut... $ECHO_C" >&6
|
||||
if test "${ac_cv_lib_glut_glutGetModifiers+set}" = set; then
|
||||
@@ -11018,7 +10953,6 @@
|
||||
@@ -11500,7 +11424,6 @@
|
||||
|
||||
fi
|
||||
|
||||
|
@ -1,23 +0,0 @@
|
||||
--- geometry/Ac3d.cc.orig Fri Jun 25 01:10:29 2004
|
||||
+++ geometry/Ac3d.cc Fri Jun 25 01:11:59 2004
|
||||
@@ -27,6 +27,8 @@
|
||||
#include <cassert>
|
||||
#include <iostream>
|
||||
#include <cstdlib>
|
||||
+#include <algorithm>
|
||||
+#include <functional>
|
||||
|
||||
using namespace Vamos_Geometry;
|
||||
|
||||
@@ -188,7 +190,11 @@
|
||||
m_normal [2] = 1.0;
|
||||
|
||||
std::istringstream is (figure_type_code);
|
||||
+#if defined(__GNUC__) && __GNUC__ < 3
|
||||
+ is.setf (std::ios::hex, std::ios::basefield);
|
||||
+#else
|
||||
is.setf (std::ios_base::hex, std::ios_base::basefield);
|
||||
+#endif
|
||||
int code;
|
||||
is >> code;
|
||||
|
Loading…
Reference in New Issue
Block a user