MFH: r464472 (commit leading to r465275 that patches CVE-2018-8740)

databases/sqlite: Update to 3.22.0

Changelog:
https://www.sqlite.org/releaselog/3_22_0.html

Port changes:
* Added the OFFSET option for the new sqlite_offset() function
* Added 'Optional extensions' and 'Optional functions' option
  groups for better options readability
* Deleted patches from files/ because they were disabling certain
  options in the command-line utility that the upstream keeps
  always enabled there
* Changed capitalization in some options according to
  common spelling rules

Approved by:	ports-secteam (feld)
This commit is contained in:
Yuri Victorovich 2018-03-23 19:19:49 +00:00
parent 87a8596afd
commit dcd4512b15
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q1/; revision=465398
4 changed files with 30 additions and 41 deletions

View File

@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= sqlite3
PORTVERSION= 3.21.0
PORTREVISION= 1
DISTVERSION= 3.22.0
CATEGORIES= databases
MASTER_SITES= https://www.sqlite.org/2017/ http://www2.sqlite.org/2017/ http://www3.sqlite.org/2017/
MASTER_SITES= https://www.sqlite.org/2018/ http://www2.sqlite.org/2018/ http://www3.sqlite.org/2018/
DISTNAME= sqlite-autoconf-${PORTVERSION:C/\.([[:digit:]])[[:>:]]/0\1/g:S/.//g}00
MAINTAINER= pavelivolkov@gmail.com
@ -14,28 +13,33 @@ COMMENT= SQL database engine in a C library
LICENSE= PD
USES= libtool ncurses pathfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
# Compilation Options For SQLite https://www.sqlite.org/compile.html
OPTIONS_DEFINE= FTS4 UPD_DEL_LIMIT URI URI_AUTHORITY SOUNDEX METADATA \
DIRECT_READ MEMMAN SECURE_DELETE UNLOCK_NOTIFY THREADS \
EXTENSION ARMOR STMT DBPAGE DBSTAT FTS5 JSON1 RBU NULL_TRIM \
LIKENOTBLOB STSHELL FTS3_TOKEN SESSION UNKNOWN_SQL
OPTIONS_SINGLE= RAMT
OPTIONS_RADIO= STAT
OPTIONS_GROUP= UNICODE RTREEG RL
OPTIONS_DEFINE= FTS4 UPD_DEL_LIMIT URI URI_AUTHORITY METADATA \
DIRECT_READ MEMMAN SECURE_DELETE UNLOCK_NOTIFY THREADS \
EXTENSION ARMOR STMT DBPAGE DBSTAT FTS5 RBU NULL_TRIM \
LIKENOTBLOB STSHELL FTS3_TOKEN UNKNOWN_SQL
OPTIONS_SINGLE= RAMT
OPTIONS_RADIO= STAT
OPTIONS_GROUP= OPT_EXT OPT_FUNC UNICODE RTREEG RL
OPTIONS_GROUP_OPT_EXT= JSON1 SESSION
OPTIONS_GROUP_OPT_FUNC= OFFSET SOUNDEX
OPT_EXT_DESC= Optional extensions
OPT_FUNC_DESC= Optional functions
UPD_DEL_LIMIT_DESC= ORDER BY and LIMIT on UPDATE and DELETE
URI_DESC= Enable use the URI filename
URI_AUTHORITY_DESC= Allow convert URL into a UNC
SOUNDEX_DESC= Enables the soundex() SQL function
SOUNDEX_DESC= Enable the soundex() SQL function
METADATA_DESC= Enable column metadata
DIRECT_READ_DESC= File is read directly from disk
MEMMAN_DESC= Allows it to release unused memory
MEMMAN_DESC= Allow it to release unused memory
SECURE_DELETE_DESC= Overwrite deleted information with zeros
UNLOCK_NOTIFY_DESC= Enable notification on unlocking
EXTENSION_DESC= Allow loadable extensions
@ -44,8 +48,11 @@ STSHELL_DESC= Statically link libsqlite3 into shell
# https://sqlite.org/compile.html#enable_null_trim
NULL_TRIM_DESC= Omits NULL columns at the ends of rows
# http://www.sqlite.org/compile.html#enable_offset_sql_func
OFFSET_DESC= Enable sqlite_offset() returning record's file offset
# https://www.sqlite.org/sessionintro.html
SESSION_DESC= Enable the Session Extension
SESSION_DESC= Enable the session extension
# https://sqlite.org/compile.html#like_doesnt_match_blobs
LIKENOTBLOB_DESC= LIKE does not match blobs
@ -54,7 +61,7 @@ LIKENOTBLOB_DESC= LIKE does not match blobs
ARMOR_DESC= Detect misuse of the API
# http://sqlite.org/compile.html#enable_unknown_sql_function
UNKNOWN_SQL_DESC= suppress unknown function errors
UNKNOWN_SQL_DESC= Suppress unknown function errors
# https://www.sqlite.org/fts3.html
# https://www.sqlite.org/compile.html#enable_fts3_parenthesis
@ -71,10 +78,10 @@ FTS3_TOKEN_DESC= Enable two-args version fts3_tokenizer
JSON1_DESC= Enable the JSON1 extension
# https://www.sqlite.org/rbu.html
RBU_DESC= Enable the Resumable Bulk Update
RBU_DESC= Enable the resumable bulk update
# https://www.sqlite.org/c3ref/stmt_scanstatus.html
STMT_DESC= Prepared Statement Scan Status
STMT_DESC= Prepared statement scan status
# https://www.sqlite.org/tempfiles.html#tempstore
OPTIONS_SINGLE_RAMT= TS0 TS1 TS2 TS3
@ -86,7 +93,7 @@ TS3_DESC= Always use memory
# https://www.sqlite.org/queryplanner-ng.html#qpstab
OPTIONS_RADIO_STAT= STAT3 STAT4
STAT_DESC= Which query planner to use, Stability or ...
STAT_DESC= Which query planner to use, stability or ...
STAT3_DESC= collect histogram data from leftmost column
STAT4_DESC= collect histogram data from all columns
@ -202,6 +209,8 @@ UNKNOWN_SQL_CPPFLAGS= -DSQLITE_ENABLE_UNKNOWN_SQL_FUNCTION=1
NULL_TRIM_CPPFLAGS= -DSQLITE_ENABLE_NULL_TRIM=1
OFFSET_CPPFLAGS= -DSQLITE_ENABLE_OFFSET_SQL_FUNC=1
.include <bsd.port.options.mk>
# Platform Configuration

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1509525928
SHA256 (sqlite-autoconf-3210000.tar.gz) = d7dd516775005ad87a57f428b6f86afd206cb341722927f104d3f0cf65fbbbe3
SIZE (sqlite-autoconf-3210000.tar.gz) = 2568942
TIMESTAMP = 1517654018
SHA256 (sqlite-autoconf-3220000.tar.gz) = 2824ab1238b706bc66127320afbdffb096361130e23291f26928a027b885c612
SIZE (sqlite-autoconf-3220000.tar.gz) = 2644649

View File

@ -1,9 +0,0 @@
--- Makefile.am.orig 2016-05-29 06:03:15 UTC
+++ Makefile.am
@@ -1,5 +1,5 @@
-AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ @FTS5_FLAGS@ @JSON1_FLAGS@ @SESSION_FLAGS@ -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_RTREE
+AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ @FTS5_FLAGS@ @JSON1_FLAGS@ @SESSION_FLAGS@
lib_LTLIBRARIES = libsqlite3.la
libsqlite3_la_SOURCES = sqlite3.c

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig 2016-05-29 06:04:20 UTC
+++ Makefile.in
@@ -363,7 +363,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ @FTS5_FLAGS@ @JSON1_FLAGS@ @SESSION_FLAGS@ -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_RTREE
+AM_CFLAGS = @THREADSAFE_FLAGS@ @DYNAMIC_EXTENSION_FLAGS@ @FTS5_FLAGS@ @JSON1_FLAGS@ @SESSION_FLAGS@
lib_LTLIBRARIES = libsqlite3.la
libsqlite3_la_SOURCES = sqlite3.c
libsqlite3_la_LDFLAGS = -no-undefined -version-info 8:6:8