- Update to 7.06

This commit is contained in:
Ryan Steinmetz 2015-03-20 12:37:17 +00:00
parent 9e63f2c68a
commit dca82c433c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=381730
4 changed files with 34 additions and 8 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openconnect
PORTVERSION= 6.00
PORTVERSION= 7.06
CATEGORIES= security
MASTER_SITES= ftp://ftp.infradead.org/pub/openconnect/ \
http://mirrors.rit.edu/zi/
@ -19,9 +19,9 @@ RUN_DEPENDS= vpnc-script:${PORTSDIR}/sysutils/vpnc-scripts
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls --with-vpnc-script=${LOCALBASE}/sbin/vpnc-script \
--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
--without-liboath --without-openssl-version-check \
--without-stoken
--without-stoken --without-openssl-version-check
USES= gmake libtool pkgconfig python:build
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
PORTDOCS= *
@ -39,6 +39,5 @@ GNUTLS_USE_OFF= OPENSSL=yes
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/TODO ${STAGEDIR}${DOCSDIR}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopenconnect.so.3.3.0
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (openconnect-6.00.tar.gz) = 8a0c684dccac2447d204d544f6f466e41b21bce71e033ba58e2cb17b795ab81c
SIZE (openconnect-6.00.tar.gz) = 1021981
SHA256 (openconnect-7.06.tar.gz) = facf695368dc4537a6a30e2147be90b1d77ee3cb2d269eaef070b6d9ddab70f2
SIZE (openconnect-7.06.tar.gz) = 1343870

View File

@ -0,0 +1,27 @@
From 25e2d3a8e607742b28cddb5443a3b7ad86254b4c Mon Sep 17 00:00:00 2001
From: David Woodhouse <David.Woodhouse@intel.com>
Date: Fri, 20 Mar 2015 12:10:13 +0000
Subject: [PATCH] Fix build without ESP
Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
---
oncp.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/oncp.c b/oncp.c
index c12d86f..c9c7dc6 100644
--- oncp.c
+++ oncp.c
@@ -1049,7 +1049,9 @@ int oncp_mainloop(struct openconnect_info *vpninfo, int *timeout)
/* XXX: Do we have to do this or can we leave it open?
* Perhaps we could even reconnect asynchronously while
* the ESP is still running? */
+#if defined(ESP_GNUTLS) || defined(ESP_OPENSSL)
esp_shutdown(vpninfo);
+#endif
ret = ssl_reconnect(vpninfo);
if (ret) {
vpn_progress(vpninfo, PRG_ERR, _("Reconnect failed\n"));
--
1.9.3

View File

@ -1,7 +1,7 @@
sbin/openconnect
include/openconnect.h
lib/libopenconnect.so
lib/libopenconnect.so.3
lib/libopenconnect.so.3.3.0
lib/libopenconnect.so.5
lib/libopenconnect.so.5.1.0
libdata/pkgconfig/openconnect.pc
man/man8/openconnect.8.gz