Update to 0.8.6.

PR:		206651
Submitted by:	maintainer
This commit is contained in:
Vanilla I. Shu 2016-01-27 14:09:11 +00:00
parent 9d638121ca
commit dc93b0a8e1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=407358
4 changed files with 6 additions and 26 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= jsonnet
PORTVERSION= 0.7.6
PORTVERSION= 0.8.6
DISTVERSIONPREFIX= v
CATEGORIES= devel
@ -15,17 +15,17 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= google
USES= compiler:c++11-lib gmake
USES= gmake
USE_CXXSTD= c++11
USE_LDCONFIG= yes
ALL_TARGET= jsonnet libjsonnet.so
CXXFLAGS+= -fPIC
CXXFLAGS+= -fPIC -Iinclude
PLIST_FILES= bin/jsonnet include/libjsonnet.h lib/libjsonnet.so
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/lib${PORTNAME}.h ${STAGEDIR}${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/include/lib${PORTNAME}.h ${STAGEDIR}${PREFIX}/include
${INSTALL_LIB} ${WRKSRC}/lib${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (google-jsonnet-v0.7.6_GH0.tar.gz) = e7687bbbb395e11451d4a4eac9101f2f960df40b30475abc96cd62f3c1344b7a
SIZE (google-jsonnet-v0.7.6_GH0.tar.gz) = 1034707
SHA256 (google-jsonnet-v0.8.6_GH0.tar.gz) = 6548604e7800c99bb3048cddf30fcd017fd65d40cd0dddae89ec9a0f58384ee9
SIZE (google-jsonnet-v0.8.6_GH0.tar.gz) = 490925

View File

@ -1,10 +0,0 @@
--- jsonnet.cpp.orig 2015-10-28 17:29:36 UTC
+++ jsonnet.cpp
@@ -14,6 +14,7 @@ See the License for the specific languag
limitations under the License.
*/
+#include <cerrno>
#include <cstdlib>
#include <cstring>
#include <cassert>

View File

@ -1,10 +0,0 @@
--- libjsonnet.cpp.orig 2015-06-03 01:28:56 UTC
+++ libjsonnet.cpp
@@ -14,6 +14,7 @@ See the License for the specific languag
limitations under the License.
*/
+#include <cerrno>
#include <cstdlib>
#include <cstring>