Update to 2.0.2 which is required for gitlab-ce 13.4.

This commit is contained in:
Matthias Fechner 2020-09-26 07:33:08 +00:00
parent c7c2b8128c
commit dc85f7235a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=550125
3 changed files with 6 additions and 22 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nokogumbo
PORTVERSION= 1.5.0
PORTVERSION= 2.0.2
CATEGORIES= textproc rubygems
MASTER_SITES= RG
@ -12,10 +12,10 @@ COMMENT= Nokogiri interface to the Gumbo HTML5 parser
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= rubygem-nokogiri>=0:textproc/rubygem-nokogiri
RUN_DEPENDS= rubygem-nokogiri>=1.8.4<2:textproc/rubygem-nokogiri
USES= gem gnome pkgconfig
USE_GNOME= libxml2
USE_RUBY= yes
USES= gem gnome pkgconfig
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1517329595
SHA256 (rubygem/nokogumbo-1.5.0.gem) = d24be0dfa3955bb1ab1d63b3407196484682b3dd7f8ab911a9386da60e0b0c27
SIZE (rubygem/nokogumbo-1.5.0.gem) = 228352
TIMESTAMP = 1600784533
SHA256 (rubygem/nokogumbo-2.0.2.gem) = 3acd625616ec8505fe9c1b22e100f834180419acb109ee6a7b20d8bce5b5b26b
SIZE (rubygem/nokogumbo-2.0.2.gem) = 220672

View File

@ -1,16 +0,0 @@
--- ext/nokogumboc/extconf.rb.orig 2017-06-07 15:19:02 UTC
+++ ext/nokogumboc/extconf.rb
@@ -1,3 +1,4 @@
+require 'rubygems'
require 'mkmf'
$CFLAGS += " -std=c99"
@@ -10,7 +11,7 @@ if have_library('xml2', 'xmlNewDoc')
select { |name| name.match(%r{gems/nokogiri-([\d.]+)/lib/nokogiri}) }.
sort_by {|name| name[/nokogiri-([\d.]+)/,1].split('.').map(&:to_i)}.last
if nokogiri_lib
- nokogiri_ext = nokogiri_lib.sub(%r(lib/nokogiri(.rb)?$), 'ext/nokogiri')
+ nokogiri_ext = Gem::Specification.find_by_name('nokogiri').extension_dir + "/nokogiri"
# if that doesn't work, try workarounds found in Nokogiri's extconf
unless find_header('nokogiri.h', nokogiri_ext)