- Update to 1.14

- Track new repository on github
This commit is contained in:
Pietro Cerutti 2014-04-23 10:07:23 +00:00
parent 5e7065257c
commit dc41b1365a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=351919
7 changed files with 134 additions and 10 deletions

View File

@ -2,26 +2,31 @@
# $FreeBSD$
PORTNAME= flwm
PORTVERSION= 1.02
PORTREVISION= 6
PORTVERSION= 1.14
CATEGORIES= x11-wm
MASTER_SITES= SF
EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= The Fast Light Window Manager
LICENSE= GPLv2
LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk-devel
USES= gmake
USE_AUTOTOOLS= autoconf
USE_XORG= x11 xt
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CXXFLAGS="-DFL_LIBRARY `${LOCALBASE}/bin/fltk-devel/fltk-config --cflags`"
USE_GITHUB= yes
GH_ACCOUNT= bbidulock
GH_TAGNAME= ${PORTVERSION}
GH_COMMIT= 460c8db
CXXFLAGS+= -DFL_LIBRARY -I${LOCALBASE}/include/fltk-devel
PLIST_FILES= bin/flwm \
man/man1/flwm.1.gz
post-patch:
${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g; /^main/s|^|int |g' ${WRKSRC}/${CONFIGURE_SCRIPT}
${REINPLACE_CMD} -e 's|^LIBS =.*|LIBS = `${LOCALBASE}/bin/fltk-devel/fltk-config --ldflags`|' ${WRKSRC}/Makefile
do-install:

View File

@ -1,2 +1,2 @@
SHA256 (flwm-1.02.tgz) = 0570681d68f7ab8873e3a85ec48caea5e456971b222e56d5d615ab46e3cb0478
SIZE (flwm-1.02.tgz) = 64142
SHA256 (flwm-1.14.tar.gz) = e9093cb1bf216d005be299dc9e455a2afb2162cf116e0162aff6b957045bacee
SIZE (flwm-1.14.tar.gz) = 67939

View File

@ -0,0 +1,49 @@
--- Frame.C.orig 2014-04-23 11:18:20.000000000 +0200
+++ Frame.C 2014-04-23 11:20:51.000000000 +0200
@@ -915,7 +915,7 @@
// preserving stacking order:
for (p = &first; *p;) {
Frame* f = *p;
- if (f == this || f->is_transient_for(this) && f->state() != UNMAPPED) {
+ if (f == this || (f->is_transient_for(this) && f->state() != UNMAPPED)) {
*p = f->next; // remove it from list
if (previous) {
XWindowChanges w;
@@ -970,7 +970,7 @@
void Frame::iconize() {
for (Frame* c = first; c; c = c->next) {
- if (c == this || c->is_transient_for(this) && c->state() != UNMAPPED)
+ if (c == this || (c->is_transient_for(this) && c->state() != UNMAPPED))
c->state(ICONIC);
}
}
@@ -1163,7 +1163,7 @@
#endif
}
if (min_h == max_h || flag(KEEP_ASPECT|NO_RESIZE) ||
- !max_h_button.value() && by+label_w+2*BUTTON_H > h()-BUTTON_BOTTOM) {
+ (!max_h_button.value() && by+label_w+2*BUTTON_H > h()-BUTTON_BOTTOM)) {
max_h_button.hide();
} else {
max_h_button.position(BUTTON_LEFT,by);
@@ -1171,7 +1171,7 @@
by += BUTTON_H;
}
if (min_w == max_w || flag(KEEP_ASPECT|NO_RESIZE) ||
- !max_w_button.value() && by+label_w+2*BUTTON_H > h()-BUTTON_BOTTOM) {
+ (!max_w_button.value() && by+label_w+2*BUTTON_H > h()-BUTTON_BOTTOM)) {
max_w_button.hide();
} else {
max_w_button.position(BUTTON_LEFT,by);
@@ -1653,8 +1653,8 @@
else {ny = y(); nh = h();}
if (flag(KEEP_ASPECT)) {
if (nw-dwidth > nh-dwidth
- && (what&(FL_ALIGN_LEFT|FL_ALIGN_RIGHT))
- || !(what&(FL_ALIGN_TOP|FL_ALIGN_BOTTOM)))
+ && ((what&(FL_ALIGN_LEFT|FL_ALIGN_RIGHT))
+ || !(what&(FL_ALIGN_TOP|FL_ALIGN_BOTTOM))))
nh = nw-dwidth+dheight;
else
nw = nh-dheight+dwidth;

View File

@ -0,0 +1,27 @@
--- Hotkeys.C.orig 2014-04-23 11:21:46.000000000 +0200
+++ Hotkeys.C 2014-04-23 11:23:21.000000000 +0200
@@ -86,9 +86,9 @@
{FL_ALT+FL_SHIFT+0xfe20,PreviousWindow}, // XK_ISO_Left_Tab
#endif
#if KWM_HOTKEYS && DESKTOPS // KWM uses these to switch desktops
-// {FL_CTRL+FL_Tab, NextDesk},
-// {FL_CTRL+FL_SHIFT+FL_Tab,PreviousDesk},
-// {FL_CTRL+FL_SHIFT+0xfe20,PreviousDesk}, // XK_ISO_Left_Tab
+ {FL_CTRL+FL_Tab, NextDesk},
+ {FL_CTRL+FL_SHIFT+FL_Tab,PreviousDesk},
+ {FL_CTRL+FL_SHIFT+0xfe20,PreviousDesk}, // XK_ISO_Left_Tab
{FL_CTRL+FL_F+1, DeskNumber},
{FL_CTRL+FL_F+2, DeskNumber},
{FL_CTRL+FL_F+3, DeskNumber},
@@ -182,9 +182,10 @@
int Handle_Hotkey() {
for (int i = 0; keybindings[i].key; i++) {
if (Fl::test_shortcut(keybindings[i].key) ||
+ (
(keybindings[i].key & 0xFFFF) == FL_Delete
&& Fl::event_key() == FL_BackSpace// fltk bug?
- ) {
+ )) {
keybindings[i].func();
return 1;
}

View File

@ -0,0 +1,11 @@
--- Menu.C.orig 2014-04-23 11:21:07.000000000 +0200
+++ Menu.C 2014-04-23 11:21:32.000000000 +0200
@@ -560,7 +560,7 @@
if (d == Desktop::current()) first_on_desk = menu+n;
for (c = Frame::first; c; c = c->next) {
if (c->state() == UNMAPPED || c->transient_for()) continue;
- if (c->desktop() == d || !c->desktop() && d == Desktop::current()) {
+ if (c->desktop() == d || (!c->desktop() && d == Desktop::current())) {
init(menu[n],(char*)c);
#if FL_MAJOR_VERSION < 2
init(menu[n],(char*)c);

View File

@ -0,0 +1,32 @@
--- main.C.orig 2014-04-18 19:48:14.000000000 +0200
+++ main.C 2014-04-23 11:42:47.000000000 +0200
@@ -4,6 +4,7 @@
#include "Frame.H"
#include <X11/Xproto.h>
+#include <X11/XKBlib.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
@@ -102,9 +103,10 @@
if (c->window() == window || fl_xid(c) == window)
#if CLICK_RAISES || CLICK_TO_TYPE
if (fl_xevent->type == ButtonPress) {click_raise(c); return 1;}
- else
+ else {
#endif
return c->handle(fl_xevent);
+ }
switch (fl_xevent->type) {
case ButtonPress:
printf("got a button press in main\n");
@@ -124,7 +126,8 @@
case KeyRelease:
if (!Fl::grab()) return 0;
Fl::e_keysym =
- XKeycodeToKeysym(fl_display, fl_xevent->xkey.keycode, 0);
+ XkbKeycodeToKeysym(fl_display, fl_xevent->xkey.keycode,
+ 0, fl_xevent->xkey.state & ShiftMask ? 1 : 0);
goto KEYUP;
#endif
}

View File

@ -1,4 +1,4 @@
Flwm is a very small and fast X window manager. Its main features are
the lack of icons and the "sideways" title-bars.
WWW: http://flwm.sourceforge.net/
WWW: https://github.com/bbidulock/flwm