- Update to 4.7.2
- Pass maintainership to submitter PR: 199812
This commit is contained in:
parent
6dbafb489f
commit
dc38a15981
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=388877
@ -2,22 +2,19 @@
|
|||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
|
|
||||||
PORTNAME= InsightToolkit
|
PORTNAME= InsightToolkit
|
||||||
PORTVERSION= 2.8.1
|
PORTVERSION= 4.7.2
|
||||||
PORTREVISION= 2
|
|
||||||
CATEGORIES= science biology
|
CATEGORIES= science biology
|
||||||
MASTER_SITES= SF/itk/itk/2.8
|
MASTER_SITES= SF/itk/itk/4.7
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
MAINTAINER= woodsb02@gmail.com
|
||||||
COMMENT= Insight Toolkit
|
COMMENT= Insight Toolkit
|
||||||
|
|
||||||
NO_PACKAGE= License does not allow redistribution of binaries
|
LICENSE= APACHE20
|
||||||
|
|
||||||
USES= cmake
|
USES= cmake:outsource
|
||||||
CMAKE_ARGS+= -DBUILD_SHARED_LIBS:BOOL=ON
|
CMAKE_ARGS+= -DBUILD_SHARED_LIBS:BOOL=ON
|
||||||
USE_LDCONFIG= ${PREFIX}/lib/InsightToolkit
|
USE_LDCONFIG= ${PREFIX}/lib/InsightToolkit
|
||||||
|
|
||||||
SUB_FILES= pkg-message
|
|
||||||
|
|
||||||
OPTIONS_DEFINE= EXAMPLES TESTING
|
OPTIONS_DEFINE= EXAMPLES TESTING
|
||||||
EXAMPLES_DESC= Build examples (very time consuming)
|
EXAMPLES_DESC= Build examples (very time consuming)
|
||||||
TESTING_DESC= Build testing programs (very time consuming)
|
TESTING_DESC= Build testing programs (very time consuming)
|
||||||
@ -25,9 +22,4 @@ TESTING_DESC= Build testing programs (very time consuming)
|
|||||||
EXAMPLES_CMAKE_OFF= -DBUILD_EXAMPLES:BOOL=OFF
|
EXAMPLES_CMAKE_OFF= -DBUILD_EXAMPLES:BOOL=OFF
|
||||||
TESTING_CMAKE_OFF= -DBUILD_TESTING:BOOL=OFF
|
TESTING_CMAKE_OFF= -DBUILD_TESTING:BOOL=OFF
|
||||||
|
|
||||||
post-install:
|
|
||||||
@cd ${STAGEDIR}${PREFIX}/lib/InsightToolkit && for lib in *.so; do \
|
|
||||||
${LN} -s $$lib.2.8.0 $$lib.2 ; \
|
|
||||||
done
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
@ -1,2 +1,2 @@
|
|||||||
SHA256 (InsightToolkit-2.8.1.tar.gz) = 7cced57c60bccc0b47505c5431aeeaf7954fe2b60ff01719848b3e0e4082ec0e
|
SHA256 (InsightToolkit-4.7.2.tar.gz) = 5aa385cc45ceff45c3265557d1b1bae4c3351d443c1e9ec19dfc110966786a91
|
||||||
SIZE (InsightToolkit-2.8.1.tar.gz) = 25240698
|
SIZE (InsightToolkit-4.7.2.tar.gz) = 267109935
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- Code/Common/itkArray.h.orig 2006-03-16 14:43:26.000000000 +0300
|
|
||||||
+++ Code/Common/itkArray.h 2013-12-18 22:35:26.050168890 +0400
|
|
||||||
@@ -78,7 +78,7 @@
|
|
||||||
|
|
||||||
|
|
||||||
/** Set the all the elements of the array to the specified value */
|
|
||||||
- void Fill (TValueType const& v) { fill(v); }
|
|
||||||
+ void Fill (TValueType const& v) { this->fill(v); }
|
|
||||||
|
|
||||||
/** Copy opertor */
|
|
||||||
const Self & operator=( const Self &rhs );
|
|
@ -1,11 +0,0 @@
|
|||||||
--- Code/Common/itkArray2D.h.orig 2003-12-15 17:13:19.000000000 +0300
|
|
||||||
+++ Code/Common/itkArray2D.h 2013-12-18 22:35:49.297942916 +0400
|
|
||||||
@@ -60,7 +60,7 @@
|
|
||||||
const Self & operator=( const Self & array );
|
|
||||||
const Self & operator=( const VnlMatrixType & matrix );
|
|
||||||
|
|
||||||
- void Fill (TValueType const& v) { fill(v); }
|
|
||||||
+ void Fill (TValueType const& v) { this->fill(v); }
|
|
||||||
|
|
||||||
/** Destructively set the size to that given. Will lose data. */
|
|
||||||
void SetSize(unsigned int m, unsigned int n);
|
|
@ -1,33 +0,0 @@
|
|||||||
--- Code/Common/itkKLMSegmentationBorder.h.orig 2006-02-07 01:01:56.000000000 +0300
|
|
||||||
+++ Code/Common/itkKLMSegmentationBorder.h 2013-12-17 17:28:09.961367612 +0400
|
|
||||||
@@ -80,11 +80,11 @@
|
|
||||||
|
|
||||||
bool operator> (const KLMDynamicBorderArray<TBorder>* rhs) const
|
|
||||||
{
|
|
||||||
- if( m_Pointer->GetLambda() == rhs.m_Pointer->GetLambda() )
|
|
||||||
+ if( m_Pointer->GetLambda() == rhs->m_Pointer->GetLambda() )
|
|
||||||
{
|
|
||||||
if( m_Pointer->GetLambda() < 0 )
|
|
||||||
{
|
|
||||||
- return ( m_Pointer > rhs.m_Pointer );
|
|
||||||
+ return ( m_Pointer > rhs->m_Pointer );
|
|
||||||
}
|
|
||||||
else
|
|
||||||
{
|
|
||||||
@@ -99,13 +99,13 @@
|
|
||||||
m_Pointer->GetRegion2()->GetRegionBorderSize() );
|
|
||||||
|
|
||||||
unsigned int v2 = vnl_math_max(
|
|
||||||
- rhs.m_Pointer->GetRegion1()->GetRegionBorderSize(),
|
|
||||||
- rhs.m_Pointer->GetRegion2()->GetRegionBorderSize() );
|
|
||||||
+ rhs->m_Pointer->GetRegion1()->GetRegionBorderSize(),
|
|
||||||
+ rhs->m_Pointer->GetRegion2()->GetRegionBorderSize() );
|
|
||||||
|
|
||||||
return ( v1 > v2 );
|
|
||||||
}
|
|
||||||
}
|
|
||||||
- return(m_Pointer->GetLambda() > rhs.m_Pointer->GetLambda() );
|
|
||||||
+ return(m_Pointer->GetLambda() > rhs->m_Pointer->GetLambda() );
|
|
||||||
}
|
|
||||||
|
|
||||||
TBorder *m_Pointer;
|
|
@ -1,20 +0,0 @@
|
|||||||
--- Code/Common/itkParametricPath.txx.orig 2004-12-04 16:22:44.000000000 +0300
|
|
||||||
+++ Code/Common/itkParametricPath.txx 2013-12-18 22:34:31.538947309 +0400
|
|
||||||
@@ -43,7 +43,7 @@
|
|
||||||
ContinuousIndexType continuousIndex;
|
|
||||||
IndexType index;
|
|
||||||
|
|
||||||
- continuousIndex = Evaluate( input );
|
|
||||||
+ continuousIndex = this->Evaluate( input );
|
|
||||||
|
|
||||||
// Round each coordinate to the nearest integer value
|
|
||||||
for( unsigned int i=0; i<VDimension; i++ )
|
|
||||||
@@ -136,7 +136,7 @@
|
|
||||||
inputStepSize = this->EndOfInput() - input;
|
|
||||||
}
|
|
||||||
|
|
||||||
- return ( Evaluate(input + inputStepSize) - Evaluate(input) ) / inputStepSize;
|
|
||||||
+ return ( this->Evaluate(input + inputStepSize) - this->Evaluate(input) ) / inputStepSize;
|
|
||||||
}
|
|
||||||
|
|
||||||
template<unsigned int VDimension>
|
|
@ -1,11 +0,0 @@
|
|||||||
--- Utilities/vxl/core/vnl/vnl_matrix_fixed_ref.h.orig 2006-03-22 01:25:06.000000000 +0300
|
|
||||||
+++ Utilities/vxl/core/vnl/vnl_matrix_fixed_ref.h 2013-12-17 17:21:57.529194289 +0400
|
|
||||||
@@ -653,7 +653,7 @@
|
|
||||||
//: Return true if *this == rhs
|
|
||||||
bool operator_eq (vnl_matrix_fixed_ref_const<T,num_rows,num_cols> const & rhs) const
|
|
||||||
{
|
|
||||||
- return equal( this->data_block(), rhs.data_block() );
|
|
||||||
+ return this->equal( this->data_block(), rhs.data_block() );
|
|
||||||
}
|
|
||||||
|
|
||||||
//: Equality operator
|
|
@ -1,14 +0,0 @@
|
|||||||
=============================================================================
|
|
||||||
|
|
||||||
For questions or comments regarding this port, please contact the
|
|
||||||
port maintainer: bacon@smithers.neuro.mcw.edu
|
|
||||||
|
|
||||||
Note that -L%%PREFIX%%/lib/InsightToolkit is necessary in order to
|
|
||||||
link to ITK libraries.
|
|
||||||
|
|
||||||
The InsightToolkit developers request that users provide some demographic
|
|
||||||
data to direct future development. Please visit:
|
|
||||||
|
|
||||||
http://www.itk.org/HTML/Download.php.
|
|
||||||
|
|
||||||
=============================================================================
|
|
@ -8,6 +8,3 @@ a CT scan may be aligned with a MRI scan in order to combine the
|
|||||||
information contained in both.
|
information contained in both.
|
||||||
|
|
||||||
WWW: http://www.itk.org
|
WWW: http://www.itk.org
|
||||||
|
|
||||||
Port maintainer: Jason W. Bacon
|
|
||||||
jwbacon@tds.net
|
|
||||||
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user