Add x11-themes/kdmtheme, a KDM theme manager.

PR: 		ports/79938
Submitted by:	Eugene Lebedinec <illusia@inbox.lv>
This commit is contained in:
Michael Nottebrock 2005-04-14 23:24:04 +00:00
parent e3f83b5d18
commit dc2027d6a3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=133367
7 changed files with 71 additions and 0 deletions

View File

@ -100,6 +100,7 @@
SUBDIR += kde-icons-umicons
SUBDIR += kde-icons-wasp
SUBDIR += kdeartwork3
SUBDIR += kdmtheme
SUBDIR += lila-xfwm4
SUBDIR += linux-gtk-bluecurve-theme
SUBDIR += metacity-aluminumalloy-cryogenic-theme

View File

@ -0,0 +1,28 @@
## New ports collection makefile for: KDM theme manager
# Date created: 12 April 2005
# Whom: illusia <illusia@inbox.lv>
#
# $FreeBSD$
#
PORTNAME= kdmtheme
PORTVERSION= 0.9
CATEGORIES= x11-themes
MASTER_SITES= http://smileaf.org/files/
DISTNAME= kdmtheme-${PORTVERSION}
MAINTAINER= illusia@inbox.lv
COMMENT= KDM Theme Manager
EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
USE_KDEBASE_VER=3
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (kdmtheme-0.9.tar.bz2) = 7fef92248f87cbedc86f9be934f997f3
SIZE (kdmtheme-0.9.tar.bz2) = 607187

View File

@ -0,0 +1,13 @@
--- src/kdmtheme.cpp Wed Apr 6 07:50:26 2005
+++ src/kdmtheme.cpp Fri Apr 15 00:35:34 2005
@@ -393,8 +393,8 @@
void kdmtheme::updateTheme( const QString &screenshot, const QString &copyright, const QString &description ) {
p_configWidget->Info->setText(
- ((copyright.length() > 0)?i18n( "<b>Copyright:</b> " ) + copyright + "<br/>":"") +
- ((description.length() > 0)?i18n( "<b>Description:</b> " ) + description:"") );
+ ((copyright.length() > 0)?i18n( "<b>Copyright:</b> " ) + copyright + ("<br/>"):QString("")) +
+ ((description.length() > 0)?i18n( "<b>Description:</b> " ) + description:QString("")) );
p_configWidget->Preview->setPixmap( screenshot );
}

View File

@ -0,0 +1,5 @@
KDM Theme Manager is just what it says - a theme manager for KDM.
This control module allows you to easily add, remove and select
any KDM theme you want.
WWW: http://kde-apps.org/content/show.php?content=22120

View File

@ -0,0 +1,11 @@
=============================================
How to use KDM theme manager:
1) Open the KDE-menu and start Control Center
2) Click on System Administration
3) Select applet kdmtheme
4) Have Fun :)
=============================================

View File

@ -0,0 +1,11 @@
lib/kde3/kcm_kdmtheme.la
lib/kde3/kcm_kdmtheme.so
share/applications/kde/kdmtheme.desktop
share/doc/HTML/en/kdmtheme/common
share/doc/HTML/en/kdmtheme/index.cache.bz2
share/doc/HTML/en/kdmtheme/index.docbook
share/doc/HTML/en/kdmtheme/kdmtheme.png
share/nls/POSIX
share/nls/en_US.US-ASCII
@dirrm share/doc/ja
@dirrm share/doc/HTML/en/kdmtheme