Libghemical port. This port installs support libraries of

science/ghemical port. From version 2.0, science/ghemical becomes
large, splitted into two parts. Update of ghemical port will
follow soon.
This commit is contained in:
Maho Nakata 2006-07-03 07:30:45 +00:00
parent 1a707520db
commit dbe3e25f73
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=166810
7 changed files with 182 additions and 0 deletions

View File

@ -50,6 +50,7 @@
SUBDIR += kst
SUBDIR += lamprop
SUBDIR += libctl
SUBDIR += libghemical
SUBDIR += libsvm
SUBDIR += libsvm-python
SUBDIR += mayavi

View File

@ -0,0 +1,36 @@
# New ports collection makefile for: libghemical
# Date created: July 3, 2006
# Whom: Nakata Maho <maho@FreeBSD.org>
#
# $FreeBSD$
PORTNAME= libghemical
PORTVERSION= 2.00
CATEGORIES= science
MASTER_SITES= http://www.uku.fi/~thassine/projects/download/ \
http://bioinformatics.org/ghemical/download/
DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= maho@FreeBSD.org
COMMENT= Support libraries of science/ghemical port
BUILD_DEPENDS= ${LOCALBASE}/lib/libmpqc.a:${PORTSDIR}/science/mpqc \
openbabel:${PORTSDIR}/science/openbabel \
mopac7:${PORTSDIR}/biology/mopac
USE_GMAKE= yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-mopac7 --enable-mpqc --enable-openbabel \
--with-blas="-L${LOCALBASE}/lib -lf77blas -lcblas -latlas" \
--with-lapack=-lalapack
USE_AUTOTOOLS= autoconf:259
PLIST_SUB= LIBGHEMICAL_VERSION="${PORTVERSION}"
.include <bsd.port.pre.mk>
pre-configure:
@cd ${WRKDIR}/${DISTNAME} ; ${AUTOCONF}
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (libghemical-2.00.tar.gz) = 19ee087b6f3c0ce816ed1722b4a5b002
SHA256 (libghemical-2.00.tar.gz) = e873b3042df75fa1c9f37fc99f2ff14227965ed13c7680169f714ab6575d5f21
SIZE (libghemical-2.00.tar.gz) = 629479

View File

@ -0,0 +1,16 @@
#
# Make new c sources from fortran sources, restore changes,
# made by Tommi Hassinen (3 comments are corrected additionally).
# Should be started in miniMOPAC directory.
f2c fortran/*.f
cp fortran/*.c ./
sed -e 's,/\* fortran/\(.*\)\.f -- translated by f2c (version 20000817),/\* \1.f -- translated by f2c (version 19991025),' \
-e 's,dscal_,mMdscal_,g' \
-e 's,dswap_,mMdswap_,g' \
-e 's,daxpy_,mMdaxpy_,g' \
-i '' *.c
mv etime.c etime.c.orig
head -18 etime.c.orig > etime.c
echo '#include <time.h>' >> etime.c
tail +19 etime.c.orig >> etime.c

View File

@ -0,0 +1,48 @@
--- configure.ac.orig Mon Apr 24 19:58:14 2006
+++ configure.ac Mon Jul 3 10:54:47 2006
@@ -46,6 +46,16 @@
;;
esac
+AC_ARG_WITH(blas,
+[ --with-blas Gives BLAS name you use(e.g., -lblas).],
+BLAS=$withval
+)
+
+AC_ARG_WITH(lapack,
+[ --with-lapack Gives LAPACK name you use(e.g., -llapack).],
+LAPACK=$withval
+)
+
AC_ARG_ENABLE(mpqc,[ --enable-mpqc compile with MPQC support],WITH_MPQC="$enableval",WITH_MPQC="no")
AC_ARG_ENABLE(mopac7,[ --enable-mopac7 compile with MOPAC7 support],WITH_MOPAC7="$enableval",WITH_MOPAC7="no")
##removed20060208##AC_ARG_ENABLE(openbabel,[ --enable-openbabel compile with OpenBabel support],WITH_OPENBABEL="$enableval",WITH_OPENBABEL="no")
@@ -69,8 +79,26 @@
AC_CHECK_LIB([m], [acos])
if test $WITH_MPQC = yes; then
- AC_CHECK_LIB([blas], [main], , AC_MSG_ERROR([Cannot find blas library needed for MPQC support]))
- AC_CHECK_LIB([lapack], [main], , AC_MSG_ERROR([Cannot find lapack library needed for MPQC support]))
+
+#Blas and lapack ...actually not checked...
+BLAS=""
+ if test "$BLASNAME" = NONE; then
+ AC_MSG_ERROR([BLAS is required to complete the build])
+ else
+ HAVE_BLAS="yes"
+ BLAS="$BLASNAME"
+ fi
+
+ AC_SUBST(HAVE_BLAS)
+
+LAPACK=""
+if test "$LAPACKNAME" = NONE; then
+ AC_MSG_ERROR([LAPACK is required to complete the build])
+else
+ HAVE_LAPACK="yes"
+ LAPACK="$LAPACKNAME"
+fi
+
AM_PATH_SC(1.2.5, HAVE_MPQC="yes", HAVE_MPQC="no")
if test "${HAVE_MPQC}" = "yes"; then
AC_DEFINE([ENABLE_MPQC], [], [Define if you are building a version that interfaces directly with MPQC])

View File

@ -0,0 +1,3 @@
libghemical is a support library packages for biology/ghemical
WWW: http://www.uku.fi/~thassine/projects/ghemical/

View File

@ -0,0 +1,75 @@
include/ghemical/libghemicaldefine.h
include/ghemical/libghemicalconfig2.h
include/ghemical/typedef.h
include/ghemical/v3d.h
include/ghemical/atom.h
include/ghemical/bond.h
include/ghemical/constraint.h
include/ghemical/model.h
include/ghemical/engine.h
include/ghemical/typerule.h
include/ghemical/utility.h
include/ghemical/seqbuild.h
include/ghemical/eng1_qm.h
include/ghemical/eng1_qm_mpqc.h
include/ghemical/eng1_qm_mopac.h
include/ghemical/eng1_mm.h
include/ghemical/eng1_mm_tripos52.h
include/ghemical/tab_mm_tripos52.h
include/ghemical/eng1_mm_default.h
include/ghemical/tab_mm_default.h
include/ghemical/eng1_mm_prmfit.h
include/ghemical/tab_mm_prmfit.h
include/ghemical/eng1_sf.h
include/ghemical/eng1_sf_ua.h
include/ghemical/eng1_sf_cg.h
include/ghemical/eng2_qm_mm.h
include/ghemical/notice.h
include/ghemical/conjgrad.h
include/ghemical/intcrd.h
include/ghemical/search.h
include/ghemical/geomopt.h
include/ghemical/moldyn.h
include/ghemical/pop_ana.h
include/ghemical/resonance.h
@dirrm include/ghemical
lib/libghemical.so.0
lib/libghemical.la
lib/libghemical.a
lib/pkgconfig/libghemical.pc
share/libghemical/%%LIBGHEMICAL_VERSION%%/amber/all_amino02.in
share/libghemical/%%LIBGHEMICAL_VERSION%%/amber/all_aminoct02.in
share/libghemical/%%LIBGHEMICAL_VERSION%%/amber/all_aminont02.in
share/libghemical/%%LIBGHEMICAL_VERSION%%/amber/all_nuc02.in
share/libghemical/%%LIBGHEMICAL_VERSION%%/amber/parm99.dat
share/libghemical/%%LIBGHEMICAL_VERSION%%/builder/amino.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/builder/nucleic.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/default/atomtypes.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/default/parameters1.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/default/parameters2.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/default/parameters3.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/default/parameters4.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/prmfit/atomtypes.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/prmfit/parameters1.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/prmfit/parameters2.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/prmfit/parameters3.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/prmfit/parameters4.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/tripos52/atomtypes.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/tripos52/parameters1.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/tripos52/parameters2.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/tripos52/parameters3.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/tripos52/parameters4.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/tripos52/parameters5.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf/default/loopdip.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf/default/looptor.txt
share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf/default/nonbonded.txt
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf/default
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_sf
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/tripos52
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/prmfit
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm/default
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/param_mm
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/amber
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%/builder
@dirrm share/libghemical/%%LIBGHEMICAL_VERSION%%
@dirrm share/libghemical