Resurrect pdflib so that it can be upgraded to pdflib v 4
This commit is contained in:
parent
00b1bf0150
commit
dbdb2a2a2a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53844
38
print/pdflib/Makefile
Normal file
38
print/pdflib/Makefile
Normal file
@ -0,0 +1,38 @@
|
||||
# New ports collection makefile for: pdflib
|
||||
# Date created: Mon Jan 18 17:03:33 CET 1999
|
||||
# Whom: Dirk Froemberg <dirk@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= pdflib
|
||||
PORTVERSION= 3.03
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://www.pdflib.com/pdflib/download/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/lib/afm/Courier:${PORTSDIR}/print/afm
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
png.5:${PORTSDIR}/graphics/png
|
||||
|
||||
RESTRICTED= "many odd restrictions on usage and distribution"
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ARGS= --with-perl5=${PERL} \
|
||||
--with-jpeg=${PREFIX} \
|
||||
--with-pnglib=${PREFIX} \
|
||||
--enable-shared-pdflib \
|
||||
--enable-cxx \
|
||||
--with-zlib=/usr
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/pdflib/.libs/libpdf.so.3 ${PREFIX}/lib
|
||||
${LN} -s libpdf.so.3 ${PREFIX}/lib/libpdf.so
|
||||
${INSTALL_DATA} ${WRKSRC}/pdflib/pdflib.h ${PREFIX}/include
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/pdflib
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/pdflib
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
print/pdflib/distinfo
Normal file
1
print/pdflib/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (pdflib-3.03.tar.gz) = 693c76acb8881b554992786e81ada91b
|
11
print/pdflib/files/patch-ad
Normal file
11
print/pdflib/files/patch-ad
Normal file
@ -0,0 +1,11 @@
|
||||
--- configure.orig Thu Dec 21 18:03:35 2000
|
||||
+++ configure Sat Mar 10 16:47:35 2001
|
||||
@@ -580,7 +580,7 @@
|
||||
|
||||
|
||||
|
||||
-PDFLIB_CURRENT=1
|
||||
+PDFLIB_CURRENT=3
|
||||
PDFLIB_REVISION=1
|
||||
PDFLIB_AGE=1
|
||||
|
1
print/pdflib/pkg-comment
Normal file
1
print/pdflib/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A C library for dynamically generating PDF
|
12
print/pdflib/pkg-descr
Normal file
12
print/pdflib/pkg-descr
Normal file
@ -0,0 +1,12 @@
|
||||
PDFlib is a library of C routines which allow you to programmatically
|
||||
generate files in Adobe's Portable Document Format PDF. PDFlib
|
||||
acts as a backend processor to your own programs. While you (the
|
||||
programmer) are responsible for retrieving or maintaining the data
|
||||
to be processed, PDFlib takes over the task of generating the PDF
|
||||
code which graphically represents your data. While you must still
|
||||
format and arrange your text and graphical objects, PDFlib frees
|
||||
you from the internals and intricacies of PDF. Although being far
|
||||
from complete, PDFlib already offers many useful functions for
|
||||
creating text, graphics, images and hypertext elements in PDF files.
|
||||
|
||||
WWW: http://www.PDFlib.com/
|
15
print/pdflib/pkg-plist
Normal file
15
print/pdflib/pkg-plist
Normal file
@ -0,0 +1,15 @@
|
||||
include/pdflib.h
|
||||
lib/libpdf.so
|
||||
lib/libpdf.so.3
|
||||
share/doc/pdflib/PDFlib-license.pdf
|
||||
share/doc/pdflib/PDFlib-manual.pdf
|
||||
share/doc/pdflib/PDFlib-purchase-order.pdf
|
||||
share/doc/pdflib/aladdin-license.pdf
|
||||
share/doc/pdflib/changes.txt
|
||||
share/doc/pdflib/compatibility.txt
|
||||
share/doc/pdflib/grid.pdf
|
||||
share/doc/pdflib/readme_ebcdic.txt
|
||||
share/doc/pdflib/readme_mac.txt
|
||||
share/doc/pdflib/readme_unix.txt
|
||||
share/doc/pdflib/readme_win.txt
|
||||
@dirrm share/doc/pdflib
|
38
print/pdflib4/Makefile
Normal file
38
print/pdflib4/Makefile
Normal file
@ -0,0 +1,38 @@
|
||||
# New ports collection makefile for: pdflib
|
||||
# Date created: Mon Jan 18 17:03:33 CET 1999
|
||||
# Whom: Dirk Froemberg <dirk@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= pdflib
|
||||
PORTVERSION= 3.03
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://www.pdflib.com/pdflib/download/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/lib/afm/Courier:${PORTSDIR}/print/afm
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
png.5:${PORTSDIR}/graphics/png
|
||||
|
||||
RESTRICTED= "many odd restrictions on usage and distribution"
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ARGS= --with-perl5=${PERL} \
|
||||
--with-jpeg=${PREFIX} \
|
||||
--with-pnglib=${PREFIX} \
|
||||
--enable-shared-pdflib \
|
||||
--enable-cxx \
|
||||
--with-zlib=/usr
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/pdflib/.libs/libpdf.so.3 ${PREFIX}/lib
|
||||
${LN} -s libpdf.so.3 ${PREFIX}/lib/libpdf.so
|
||||
${INSTALL_DATA} ${WRKSRC}/pdflib/pdflib.h ${PREFIX}/include
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/pdflib
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/pdflib
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
print/pdflib4/distinfo
Normal file
1
print/pdflib4/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (pdflib-3.03.tar.gz) = 693c76acb8881b554992786e81ada91b
|
11
print/pdflib4/files/patch-ad
Normal file
11
print/pdflib4/files/patch-ad
Normal file
@ -0,0 +1,11 @@
|
||||
--- configure.orig Thu Dec 21 18:03:35 2000
|
||||
+++ configure Sat Mar 10 16:47:35 2001
|
||||
@@ -580,7 +580,7 @@
|
||||
|
||||
|
||||
|
||||
-PDFLIB_CURRENT=1
|
||||
+PDFLIB_CURRENT=3
|
||||
PDFLIB_REVISION=1
|
||||
PDFLIB_AGE=1
|
||||
|
1
print/pdflib4/pkg-comment
Normal file
1
print/pdflib4/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A C library for dynamically generating PDF
|
12
print/pdflib4/pkg-descr
Normal file
12
print/pdflib4/pkg-descr
Normal file
@ -0,0 +1,12 @@
|
||||
PDFlib is a library of C routines which allow you to programmatically
|
||||
generate files in Adobe's Portable Document Format PDF. PDFlib
|
||||
acts as a backend processor to your own programs. While you (the
|
||||
programmer) are responsible for retrieving or maintaining the data
|
||||
to be processed, PDFlib takes over the task of generating the PDF
|
||||
code which graphically represents your data. While you must still
|
||||
format and arrange your text and graphical objects, PDFlib frees
|
||||
you from the internals and intricacies of PDF. Although being far
|
||||
from complete, PDFlib already offers many useful functions for
|
||||
creating text, graphics, images and hypertext elements in PDF files.
|
||||
|
||||
WWW: http://www.PDFlib.com/
|
15
print/pdflib4/pkg-plist
Normal file
15
print/pdflib4/pkg-plist
Normal file
@ -0,0 +1,15 @@
|
||||
include/pdflib.h
|
||||
lib/libpdf.so
|
||||
lib/libpdf.so.3
|
||||
share/doc/pdflib/PDFlib-license.pdf
|
||||
share/doc/pdflib/PDFlib-manual.pdf
|
||||
share/doc/pdflib/PDFlib-purchase-order.pdf
|
||||
share/doc/pdflib/aladdin-license.pdf
|
||||
share/doc/pdflib/changes.txt
|
||||
share/doc/pdflib/compatibility.txt
|
||||
share/doc/pdflib/grid.pdf
|
||||
share/doc/pdflib/readme_ebcdic.txt
|
||||
share/doc/pdflib/readme_mac.txt
|
||||
share/doc/pdflib/readme_unix.txt
|
||||
share/doc/pdflib/readme_win.txt
|
||||
@dirrm share/doc/pdflib
|
Loading…
Reference in New Issue
Block a user