Xhomer is a machine emulator for the Digital Equipment Corporation

(DEC) Pro 350 computer, a PDP-11-based machine that was sold in the
early to mid-'80's.  Xhomer is based on the PDP-11 CPU core from
the SIMH simulator, and is written entirely in C.

PR:		ports/97803
Submitted by:	trasz <trasz (at) pin.if.uz.zgora.pl>
This commit is contained in:
Thierry Thomas 2006-07-16 20:02:27 +00:00
parent 58deda86b0
commit dbcf5348b9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=168003
6 changed files with 90 additions and 0 deletions

View File

@ -149,6 +149,7 @@
SUBDIR += xbraitenberg
SUBDIR += xgngeo
SUBDIR += xgs
SUBDIR += xhomer
SUBDIR += xmame
SUBDIR += xmess
SUBDIR += xsystem35

39
emulators/xhomer/Makefile Normal file
View File

@ -0,0 +1,39 @@
# New ports collection makefile for: xhomer
# Date created: 24 May 2006
# Whom: trasz
#
# $FreeBSD$
#
PORTNAME= xhomer
DISTVERSION= 12-14-03
CATEGORIES= emulators
MASTER_SITES= http://xhomer.isani.org/xhomer/
EXTRACT_SUFX= .tgz
MAINTAINER= trasz@pin.if.uz.zgora.pl
COMMENT= Emulator for the DEC Pro 350 computer
USE_GMAKE= yes
USE_XLIB= yes
ALL_TARGET= clean xhomer
INSTALL_TARGET=
CFLAGS+= -Wall -ffloat-store
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST_FILES= bin/xhomer %%EXAMPLESDIR%%/xhomer.cfg
PLIST_DIRS= %%EXAMPLESDIR%%
PORTDOCS= README LICENSE SIMH
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
${INSTALL_PROGRAM} ${WRKSRC}/xhomer ${PREFIX}/bin
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/xhomer.cfg ${EXAMPLESDIR}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (xhomer-12-14-03.tgz) = 7eab258f5a130be9950c2032a9e10946
SHA256 (xhomer-12-14-03.tgz) = ed043165ef650997b79aadcf675bdeeddce7bcaae8572222d2bfa09c95f277fc
SIZE (xhomer-12-14-03.tgz) = 312166

View File

@ -0,0 +1,34 @@
--- Makefile.orig Tue Dec 9 18:36:07 2003
+++ Makefile Wed May 24 19:59:13 2006
@@ -115,17 +115,17 @@
# C-Compiler configuration
# All the rest of the flags in this section assume gcc
-CC=gcc -Wall
+#CC=gcc -Wall
# -Wchar-subscripts -W -Wshadow -Wconversion
# -Wtraditional -Wstrict-prototypes
# This prevents "undesirable excess precision" on some machines, says gcc
-CC += -ffloat-store
+#CC += -ffloat-store
# The 1st choice runs about 15% slower than the 2nd (-O3 -fomit-frame-pointer).
# but it (re)compiles faster and unlike the second choice, it is debuggable.
# CC += -g -O -fno-inline
-CC += -O3 -Winline -fomit-frame-pointer
+#CC += -O3 -Winline -fomit-frame-pointer
# Some older gcc's need this on i386 to work around a bug. As long as
# omit-frame-pointer is also set, it doesn't seem to hurt performance, so
@@ -184,8 +184,8 @@
# Try this as the default place for X11 stuff and ncurses
- CCINCS = -I$(X11DIR)/include -I/usr/X11/include -I$(NCURSESINC)
- CCLIBS = -L$(X11DIR)/lib -L/usr/X11/lib -L$(NCURSESLIB)
+ CCINCS = -I$(X11DIR)/include
+ CCLIBS = -L$(X11DIR)/lib -L$(NCURSESLIB)
# But some vendors put things in non-standard places

View File

@ -0,0 +1,7 @@
*****************************************************************************
Please see %%DOCSDIR%%/README for instructions. Copy
the example config file from %%PREFIX%%/share/examples/xhomer/xhomer.cfg
to your home directory as '.xhomerrc' and set 'rd_dir' line to point
to the directory containing disk images downloaded from
http://xhomer.isani.org/xhomer/.
*****************************************************************************

View File

@ -0,0 +1,6 @@
Xhomer is a machine emulator for the Digital Equipment Corporation
(DEC) Pro 350 computer, a PDP-11-based machine that was sold in the
early to mid-'80's. Xhomer is based on the PDP-11 CPU core from
the SIMH simulator, and is written entirely in C.
WWW: http://xhomer.isani.org/