mcwm is a minimalistic floating window manager for the X Window System.

It is built directly on top of XCB, the C binding for the X11 protocol.
It doesn't use the Xlib API at all.

All functions are available from the keyboard, but the mouse can be
used for moving,resizing and raise/lower.

WWW: http://hack.org/mc/hacks/mcwm/

PR:		ports/155610
Submitted by:	Jakub Lach <jakub_lach at mailplus.pl>
This commit is contained in:
Martin Wilke 2011-03-17 13:17:13 +00:00
parent 5e67b3f765
commit dbced3f758
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=271111
5 changed files with 84 additions and 0 deletions

View File

@ -124,6 +124,7 @@
SUBDIR += lxsession
SUBDIR += matchbox
SUBDIR += matwm2
SUBDIR += mcwm
SUBDIR += metacity
SUBDIR += musca
SUBDIR += mutter

44
x11-wm/mcwm/Makefile Normal file
View File

@ -0,0 +1,44 @@
# New ports collection makefile for: mcwm
# Date created: 16 March 2011
# Whom: Jakub Lach <jakub_lach@mailplus.pl>
#
# $FreeBSD$
#
PORTNAME= mcwm
PORTVERSION= 20110308
CATEGORIES= x11-wm
MASTER_SITES= http://hack.org/mc/hacks/mcwm/
MAINTAINER= jakub_lach@mailplus.pl
COMMENT= A small window manager inspired by CTWM, evilwm, and tinywm
BUILD_DEPENDS= xcb-util>=0.3.6:${PORTSDIR}/x11/xcb-util
RUN_DEPENDS= xcb-util>=0.3.6:${PORTSDIR}/x11/xcb-util
USE_XORG= x11
USE_BZIP2= yes
MAN1= mcwm.1
PLIST_FILES= bin/mcwm
PORTDOCS= LICENSE README
pre-everything::
@${ECHO_MSG} "You can build mcwm with your own config.h using the MCWM_CONF knob:"
@${ECHO_MSG} "make MCWM_CONF=/path/to/dwm/config.h install clean"
post-extract:
.if defined(MCWM_CONF)
@${ECHO_MSG} "creating config.h from ${MCWM_CONF}"
@${CP} ${MCWM_CONF} ${WRKSRC}/config.h
.endif
post-install:
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
@${MKDIR} ${DOCSDIR}
@${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
@${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>

2
x11-wm/mcwm/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (mcwm-20110308.tar.bz2) = 871d78eccfdbe00af17551436a886cc352874839c2adae963e83b25fcd770406
SIZE (mcwm-20110308.tar.bz2) = 23392

View File

@ -0,0 +1,29 @@
--- Makefile.orig 2011-03-16 18:19:22.000000000 +0100
+++ Makefile 2011-03-16 18:23:04.000000000 +0100
@@ -3,12 +3,12 @@ DIST=mcwm-$(VERSION)
SRC=mcwm.c list.c config.h events.h list.h
DISTFILES=LICENSE Makefile NEWS README TODO WISHLIST mcwm.man $(SRC)
-CC=gcc
-CFLAGS=-g -std=c99 -Wall -Wextra -O2 -I/usr/local/include #-DDEBUG #-DDMALLOC
-LDFLAGS=-L/usr/local/lib -lxcb -lxcb-keysyms -lxcb-icccm -lxcb-atom # -ldmalloc
+CFLAGS+=-g -std=c99 -Wall -Wextra -I/usr/local/include
+LDFLAGS+=-L/usr/local/lib -lxcb -lxcb-keysyms -lxcb-icccm -lxcb-atom
RM=/bin/rm
-PREFIX=/usr/local
+PREFIX?=/usr/local
+MANPREFIX = ${PREFIX}/man
TARGETS=mcwm
OBJS=mcwm.o list.o
@@ -28,6 +28,9 @@ list.o: list.c list.h Makefile
install: $(TARGETS)
install -m 755 mcwm $(PREFIX)/bin
+ @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
+ @mkdir -p ${DESTDIR}${MANPREFIX}/man1
+ @sed "s/VERSION/${VERSION}/g" < mcwm.man > ${DESTDIR}${MANPREFIX}/man1/mcwm.1
deinstall:
$(RM) $(PREFIX)/bin/mcwm

8
x11-wm/mcwm/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
mcwm is a minimalistic floating window manager for the X Window System.
It is built directly on top of XCB, the C binding for the X11 protocol.
It doesn't use the Xlib API at all.
All functions are available from the keyboard, but the mouse can be
used for moving,resizing and raise/lower.
WWW: http://hack.org/mc/hacks/mcwm/