sysutils/mtpfs: update to use github

PR:	200078
Reported by:	jensh604@gmail.com
This commit is contained in:
John Hixson 2020-07-02 17:38:07 +00:00
parent 5da3679965
commit dbc5577117
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=541051
6 changed files with 32 additions and 72 deletions

View File

@ -3,9 +3,8 @@
PORTNAME= mtpfs
PORTVERSION= 1.1
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://www.adebenham.com/files/mtp/
MAINTAINER= jhixson@FreeBSD.org
COMMENT= MTP device filesystem
@ -18,7 +17,11 @@ LIB_DEPENDS= libmtp.so:multimedia/libmtp \
libid3tag.so:audio/libid3tag \
libmad.so:audio/libmad
USES= fuse gnome pkgconfig
USES= autoreconf fuse gnome pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= cjd
GH_TAGNAME= fd3864dd6f0e8183fa2598d4cf890401d3a1e09a
USE_GNOME= glib20
GNU_CONFIGURE= yes
PLIST_FILES= bin/mtpfs

View File

@ -1,2 +1,3 @@
SHA256 (mtpfs-1.1.tar.gz) = 1baf357de16995a5f0b5bc1b6833517a77456481d861cdba70f1ce1316ce4c1d
SIZE (mtpfs-1.1.tar.gz) = 108329
TIMESTAMP = 1593705811
SHA256 (cjd-mtpfs-1.1-fd3864dd6f0e8183fa2598d4cf890401d3a1e09a_GH0.tar.gz) = f004136a82452d13362581277eb2496033aa13a6c3f35d0501327248f3120456
SIZE (cjd-mtpfs-1.1-fd3864dd6f0e8183fa2598d4cf890401d3a1e09a_GH0.tar.gz) = 82022

View File

@ -0,0 +1,10 @@
--- Makefile.am.orig 2020-07-02 17:25:56 UTC
+++ Makefile.am
@@ -1,6 +1,6 @@
bin_PROGRAMS = mtpfs
mtpfs_SOURCES = mtpfs.c mtpfs.h
-mtpfs_CPPFLAGS = -DFUSE_USE_VERSION=22 $(FUSE_CFLAGS) $(GLIB_CFLAGS) $(MTP_CFLAGS)
+mtpfs_CPPFLAGS = -DFUSE_USE_VERSION=26 $(FUSE_CFLAGS) $(GLIB_CFLAGS) $(MTP_CFLAGS)
mtpfs_LDADD = $(FUSE_LIBS) $(GLIB_LIBS) $(MTP_LIBS)
if USEMAD

View File

@ -1,6 +1,6 @@
--- Makefile.in.orig 2012-02-27 01:02:28 UTC
--- Makefile.in.orig 2016-12-15 23:55:52 UTC
+++ Makefile.in
@@ -181,7 +181,7 @@ top_build_prefix = @top_build_prefix@
@@ -287,7 +287,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
mtpfs_SOURCES = mtpfs.c mtpfs.h $(am__append_1)

View File

@ -1,45 +1,11 @@
--- mtpfs.c.orig 2012-02-27 00:59:39 UTC
--- mtpfs.c.orig 2016-12-15 23:55:52 UTC
+++ mtpfs.c
@@ -1270,7 +1270,7 @@ mtpfs_rename (const char *oldname, const
}
static int
-mtpfs_statfs (const char *path, struct statfs *stbuf)
+mtpfs_statfs (const char *path, struct statvfs *stbuf)
{
DBG("mtpfs_statfs");
stbuf->f_bsize=1024;
@@ -1282,7 +1282,7 @@ mtpfs_statfs (const char *path, struct s
}
void *
-mtpfs_init ()
+mtpfs_init (struct fuse_conn_info *conn)
{
LIBMTP_devicestorage_t *storage;
DBG("mtpfs_init");
@@ -1298,8 +1298,14 @@ mtpfs_blank()
// Do nothing
}
+int
+mtpfs_blank_chmod(const char *path, mode_t mode)
+{
+ return (0);
+}
+
static struct fuse_operations mtpfs_oper = {
- .chmod = mtpfs_blank,
+ .chmod = mtpfs_blank_chmod,
.release = mtpfs_release,
.readdir = mtpfs_readdir,
.getattr = mtpfs_getattr,
@@ -1428,7 +1434,7 @@ main (int argc, char *argv[])
DBG("Start fuse");
- fuse_stat=fuse_main (argc, argv, &mtpfs_oper);
+ fuse_stat=fuse_main (argc, argv, &mtpfs_oper, NULL);
DBG("fuse_main returned %d\n", fuse_stat);
return fuse_stat;
@@ -1774,7 +1774,7 @@ main (int argc, char *argv[])
DBG ("Start fuse");
- fuse_stat = fuse_main (argc, argv, &mtpfs_oper);
+ fuse_stat = fuse_main (argc, argv, &mtpfs_oper, NULL);
DBG ("fuse_main returned %d\n", fuse_stat);
return fuse_stat;
}

View File

@ -1,31 +1,11 @@
--- mtpfs.h.orig 2012-02-24 04:37:14 UTC
--- mtpfs.h.orig 2016-12-15 23:55:52 UTC
+++ mtpfs.h
@@ -18,7 +18,9 @@
@@ -17,7 +17,7 @@
#include <fcntl.h>
#include <dirent.h>
#include <errno.h>
-#include <sys/statfs.h>
+#include <sys/param.h>
+#include <sys/mount.h>
+#include <sys/statvfs.h>
#include <libmtp.h>
#include <glib.h>
@@ -49,7 +51,7 @@ static int find_storage(const gchar * pa
/* fuse functions */
-static void * mtpfs_init (void);
+static void * mtpfs_init (struct fuse_conn_info *);
static int mtpfs_blank ();
static int mtpfs_release (const char *path, struct fuse_file_info *fi);
void mtpfs_destroy ();
@@ -62,7 +64,7 @@ static int mtpfs_write (const gchar * pa
static int mtpfs_unlink (const gchar * path);
static int mtpfs_mkdir (const char *path, mode_t mode);
static int mtpfs_rmdir (const char *path);
-static int mtpfs_statfs (const char *path, struct statfs *stbuf);
+static int mtpfs_statfs (const char *path, struct statvfs *stbuf);
int calc_length(int f);
static LIBMTP_mtpdevice_t *device;