New port: dns/dq

Recursive DNS/DNSCurve server and comandline tool to debug DNS/DNSCurve

WWW: https://mojzis.com/software/dq/

PR:		215073
Submitted by:	Piotr Kubaj <pkubaj@anongoth.pl>
This commit is contained in:
Kurt Jaeger 2016-12-18 17:28:08 +00:00
parent f2758c13ed
commit db3be55a15
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=428883
10 changed files with 146 additions and 2 deletions

2
GIDs
View File

@ -138,7 +138,7 @@ cups:*:193:
saned:*:194:
radns:*:195:
nova:*:196:
# free: 197
dq:*:197:
# free: 198
mcserver:*:199:
sympa:*:200:

2
UIDs
View File

@ -143,7 +143,7 @@ cups:*:193:193::0:0:Cups Owner:/nonexistent:/usr/sbin/nologin
saned:*:194:194::0:0:SANE Scanner Daemon:/nonexistent:/bin/sh
radns:*:195:195::0:0:radns user:/nonexistent:/usr/sbin/nologin
nova:*:196:196::0:0:Nova daemon pseudo-user:/var/lib/nova:/usr/sbin/nologin
# free: 197
dq:*:197:197::0:0:dqcache user:/nonexistent:/usr/sbin/nologin
# free: 198
mcserver:*:199:199::0:0:Minecraft Server:/nonexistent:/bin/sh
sympa:*:200:200::0:0:Sympa Owner:/nonexistent:/usr/sbin/nologin

View File

@ -57,6 +57,7 @@
SUBDIR += dnswalk
SUBDIR += dnswall
SUBDIR += doc
SUBDIR += dq
SUBDIR += dualserver
SUBDIR += erlang-idna
SUBDIR += ez-ipupdate

43
dns/dq/Makefile Normal file
View File

@ -0,0 +1,43 @@
# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
# $FreeBSD$
PORTNAME= dq
PORTVERSION= 20161128
CATEGORIES= dns
MAINTAINER= pkubaj@anongoth.pl
COMMENT= Recursive DNS/DNSCurve server
LICENSE= PD
RUN_DEPENDS= envuidgid:sysutils/daemontools
OPTIONS_DEFINE= DOCS
USE_GITHUB= yes
GH_ACCOUNT= janmojzis
USERS= dq
GROUPS= dq
do-build:
${MAKE_CMD} -C ${WRKSRC} compile
${STRIP_CMD} ${WRKSRC}/build/bin/*
do-install:
cd ${WRKSRC}/build/bin && ${COPYTREE_BIN} . ${STAGEDIR}${PREFIX}/bin/
cd ${WRKSRC}/build/include && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include/
${MKDIR} ${STAGEDIR}${ETCDIR}cache/env ${STAGEDIR}${ETCDIR}cache/root/servers
${ECHO} 10000000 > ${STAGEDIR}${ETCDIR}cache/env/CACHESIZE
${ECHO} 127.0.0.1 > ${STAGEDIR}${ETCDIR}cache/env/IP
${ECHO} "${ETCDIR}cache/root" > ${STAGEDIR}${ETCDIR}cache/env/ROOT
${ECHO} envuidgid ${USERS} envdir ${ETCDIR}cache/env ${GROUPS} > ${STAGEDIR}${ETCDIR}cache/run
${CP} files/root-servers-list ${STAGEDIR}${ETCDIR}cache/root/servers/@
${INSTALL_LIB} ${WRKSRC}/build/lib/libtinynacl.a ${STAGEDIR}${PREFIX}/lib
do-install-DOCS-on:
${GZIP_CMD} ${WRKSRC}/build/man/*
${INSTALL_MAN} ${WRKSRC}/build/man/dq*.1.gz ${STAGEDIR}${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/build/man/dq*.8.gz ${STAGEDIR}${MANPREFIX}/man/man8
.include <bsd.port.mk>

3
dns/dq/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1481131976
SHA256 (janmojzis-dq-20161128_GH0.tar.gz) = de4e6892ec83feb5cea3518289d8a28018377c435561f905de3edb338a03ca73
SIZE (janmojzis-dq-20161128_GH0.tar.gz) = 143373

View File

@ -0,0 +1,14 @@
--- dq/dqcache-start.c.orig 2016-12-07 17:33:44 UTC
+++ dq/dqcache-start.c
@@ -1,7 +1,11 @@
#include <unistd.h>
#include <sys/types.h>
#include <pwd.h>
+/*
+workaround for *BSD
#include <stdlib.h>
+*/
+extern int setenv(const char *, const char *, int);
#include "numtostr.h"
#include "strtonum.h"
#include "e.h"

View File

@ -0,0 +1,10 @@
--- dq/strtoip.c.orig 2016-11-27 15:38:55 UTC
+++ dq/strtoip.c
@@ -7,6 +7,7 @@ Public domain.
#include <arpa/inet.h>
#include "byte.h"
#include "strtoip.h"
+#include <sys/socket.h>
/* taken from nacl-20110221, from curvecp/curvecpserver.c (public-domain) */
int strtoip4(unsigned char *ip, const char *x) {

View File

@ -0,0 +1,24 @@
198.41.0.4
2001:503:ba3e::2:30
192.228.79.201
2001:500:84::b
192.33.4.12
2001:500:2::c
199.7.91.13
2001:500:2d::d
192.203.230.10
192.5.5.241
2001:500:2f::f
192.112.36.4
198.97.190.53
2001:500:1::53
192.36.148.17
2001:7fe::53
192.58.128.30
2001:503:c27::2:30
193.0.14.129
2001:7fd::1
199.7.83.42
2001:500:9f::42
202.12.27.33
2001:dc3::35

3
dns/dq/pkg-descr Normal file
View File

@ -0,0 +1,3 @@
Recursive DNS/DNSCurve server and comandline tool to debug DNS/DNSCurve
WWW: https://mojzis.com/software/dq/

46
dns/dq/pkg-plist Normal file
View File

@ -0,0 +1,46 @@
bin/dq
bin/dqcache
bin/dqcache-makekey
bin/dqcache-start
%%ETCDIR%%cache/env/CACHESIZE
%%ETCDIR%%cache/env/IP
%%ETCDIR%%cache/env/ROOT
%%ETCDIR%%cache/root/servers/@
%%ETCDIR%%cache/run
include/cleanup.h
include/crypto.h
include/crypto_auth_siphash24.h
include/crypto_box_curve25519xsalsa20poly1305.h
include/crypto_core_hsalsa20.h
include/crypto_int16.h
include/crypto_int32.h
include/crypto_int64.h
include/crypto_int8.h
include/crypto_onetimeauth_poly1305.h
include/crypto_scalarmult_curve25519.h
include/crypto_secretbox_xsalsa20poly1305.h
include/crypto_stream_salsa20.h
include/crypto_stream_xsalsa20.h
include/crypto_uint16.h
include/crypto_uint32.h
include/crypto_uint64.h
include/crypto_uint8.h
include/crypto_verify_16.h
include/crypto_verify_32.h
include/crypto_verify_8.h
include/direntry.h
include/hasasmvolatilememory.h
include/hasipv6.h
include/order.h
include/randombytes.h
include/uint32_pack.h
include/uint32_pack_big.h
include/uint32_unpack.h
include/uint32_unpack_big.h
include/uint64_pack.h
include/uint64_unpack.h
lib/libtinynacl.a
%%PORTDOCS%%man/man1/dq.1.gz
%%PORTDOCS%%man/man1/dqcache-makekey.1.gz
%%PORTDOCS%%man/man1/dqcache-start.1.gz
%%PORTDOCS%%man/man8/dqcache.8.gz