www/py-flexget: update to 2.10.60

- Hook tests: 3 failed, 1184 passed, 35 skipped, 4 xfailed, 1 xpassed, 5 warnings

Changes:	https://github.com/Flexget/Flexget/compare/2.10.43...2.10.60
This commit is contained in:
Jan Beich 2017-06-13 19:53:58 +00:00
parent 5630db99ad
commit db2d69466f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=443531
7 changed files with 102 additions and 14 deletions

View File

@ -1831,6 +1831,7 @@
SUBDIR += py-urlobject
SUBDIR += py-user_agent
SUBDIR += py-utidylib
SUBDIR += py-vcrpy
SUBDIR += py-w3lib
SUBDIR += py-waitress
SUBDIR += py-webassets

View File

@ -2,12 +2,10 @@
# $FreeBSD$
PORTNAME= flexget
PORTVERSION= 2.10.43
PORTVERSION= 2.10.60
PORTEPOCH= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= FlexGet-${PORTVERSION}
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Program to automate downloading from different sources
@ -27,7 +25,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=1.0.13:databases/py-sqlalchemy
${PYTHON_PKGNAMEPREFIX}pyparsing>=2.0.3:devel/py-pyparsing \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}progressbar>0:misc/py-progressbar \
${PYTHON_PKGNAMEPREFIX}guessit>=2.0.4:multimedia/py-guessit \
${PYTHON_PKGNAMEPREFIX}guessit>=2.1.0:multimedia/py-guessit \
${PYTHON_PKGNAMEPREFIX}pynzb>0:news/py-pynzb \
${PYTHON_PKGNAMEPREFIX}zxcvbn-python>0:security/py-zxcvbn-python \
${PYTHON_PKGNAMEPREFIX}plumbum>=1.2:sysutils/py-plumbum \
@ -45,9 +43,29 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=1.0.13:databases/py-sqlalchemy
${PYTHON_PKGNAMEPREFIX}flask-restplus08=0.8.6:www/py-flask-restplus08 \
${PYTHON_PKGNAMEPREFIX}html5lib>=0.11:www/py-html5lib \
${PYTHON_PKGNAMEPREFIX}requests>=2.8.0:www/py-requests
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest \
${PYTHON_PKGNAMEPREFIX}pytest-capturelog>0:devel/py-pytest-capturelog \
${PYTHON_PKGNAMEPREFIX}boto3>0:www/py-boto3 \
${PYTHON_PKGNAMEPREFIX}vcrpy>0:www/py-vcrpy
USE_GITHUB= yes
GH_PROJECT= Flexget
NO_ARCH= yes
USES= python:2.7+
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
post-extract:
# Unlock dependencies' versions
@${MV} ${WRKSRC}/requirements.in ${WRKSRC}/requirements.txt
do-test:
@(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest)
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3300
TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock
.endif
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1494224075
SHA256 (FlexGet-2.10.43.tar.gz) = 0127b49dd5350900f92857d14e175650e55d5386c70b469da582b0431ab06f0a
SIZE (FlexGet-2.10.43.tar.gz) = 2662856
TIMESTAMP = 1496715229
SHA256 (flexget-Flexget-2.10.60_GH0.tar.gz) = 7af6b652e568e02803ac46bff37a45dbe48db4d16ffcc0eacaa8815f1fb48eb4
SIZE (flexget-Flexget-2.10.60_GH0.tar.gz) = 6711381

View File

@ -1,11 +1,24 @@
--- requirements.txt.orig 2016-08-14 10:12:26 UTC
--- requirements.txt.orig 2017-06-06 02:13:49 UTC
+++ requirements.txt
@@ -16,7 +16,7 @@ python-dateutil>=2.5.2
@@ -7,18 +7,15 @@ html5lib>=0.11
PyRSS2Gen
pynzb
#PY3 progressbar
-rpyc==3.3.0
+rpyc
jinja2
# There is a bug in requests 2.4.0 where it leaks urllib3 exceptions
-requests~=2.16.3
-#Guessit requires python-dateutil<=2.5.2
+requests>=2.8.0, <3.0
python-dateutil>=2.5.3
jsonschema>=2.0
path.py>=8.1.1
pathlib>=1.0
pathlib>=1.0; python_version<'3.4'
-guessit<=2.0.4
+guessit>=2.0.4
-# Rebulk changes how guessit works higher than 0.8.2
-rebulk==0.8.2
+guessit>=2.1.0
apscheduler>=3.2.0
# WebUI Requirements
cherrypy>=3.7.0
terminaltables>=3.1.0
colorclass>=2.2.0

29
www/py-vcrpy/Makefile Normal file
View File

@ -0,0 +1,29 @@
# $FreeBSD$
PORTNAME= vcrpy
PORTVERSION= 1.11.1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Automatically mock your HTTP interactions to simplify and speed up testing
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.5:devel/py-six \
${PYTHON_PKGNAMEPREFIX}wrapt>0:devel/py-wrapt \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml
NO_ARCH= yes
USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3300
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}contextlib2>0:devel/py-contextlib2
.endif
.include <bsd.port.post.mk>

3
www/py-vcrpy/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1495936275
SHA256 (vcrpy-1.11.1.tar.gz) = f434fe7e05d940d576ac850709ae57a738ba40e7f317076ea8d359ced5b32320
SIZE (vcrpy-1.11.1.tar.gz) = 63122

24
www/py-vcrpy/pkg-descr Normal file
View File

@ -0,0 +1,24 @@
VCR.py simplifies and speeds up tests that make HTTP requests. The
first time you run code that is inside a VCR.py context manager or
decorated function, VCR.py records all HTTP interactions that take
place through the libraries it supports and serializes and writes them
to a flat file (in yaml format by default). This flat file is called a
cassette. When the relevant piece of code is executed again, VCR.py
will read the serialized requests and responses from the
aforementioned cassette file, and intercept any HTTP requests that it
recognizes from the original test run and return the responses that
corresponded to those requests. This means that the requests will not
actually result in HTTP traffic, which confers several benefits
including:
* The ability to work offline
* Completely deterministic tests
* Increased test execution speed
If the server you are testing against ever changes its API, all you
need to do is delete your existing cassette files, and run your tests
again. VCR.py will detect the absence of a cassette file and once
again record all HTTP interactions, which will update them to
correspond to the new API.
WWW: https://pypi.python.org/pypi/vcrpy