comms/airspyhf: Add new port
User mode driver for Airspy HF+, a high performance software defined radio for the HF and VHF bands. WWW: https://github.com/airspy/airspyhf
This commit is contained in:
parent
528d25f7d8
commit
db29af5752
@ -2,6 +2,7 @@
|
||||
|
||||
SUBDIR += acfax
|
||||
SUBDIR += airspy
|
||||
SUBDIR += airspyhf
|
||||
SUBDIR += aldo
|
||||
SUBDIR += amtterm
|
||||
SUBDIR += anyremote
|
||||
|
27
comms/airspyhf/Makefile
Normal file
27
comms/airspyhf/Makefile
Normal file
@ -0,0 +1,27 @@
|
||||
PORTNAME= airspyhf
|
||||
DISTVERSION= 1.6.8-7
|
||||
DISTVERSIONSUFFIX= -gb93dedd
|
||||
CATEGORIES= comms hamradio
|
||||
|
||||
MAINTAINER= dmgk@FreeBSD.org
|
||||
COMMENT= User mode driver for Airspy HF+ SDR
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USES= cmake compiler:c11 pkgconfig
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= airspy
|
||||
|
||||
CMAKE_ARGS= -DLIBUSB_LIBRARIES="/usr/lib/libusb.so"
|
||||
CMAKE_OFF= INSTALL_UDEV_RULES
|
||||
|
||||
OPTIONS_DEFINE_amd64= SIMD
|
||||
OPTIONS_DEFINE_i386= SIMD
|
||||
OPTIONS_DEFAULT_amd64= SIMD
|
||||
OPTIONS_DEFAULT_i386= SIMD
|
||||
|
||||
SIMD_CFLAGS= -DFREEBSD_USE_SIMD -msse -msse2 -mfpmath=sse -mmmx
|
||||
|
||||
.include <bsd.port.mk>
|
3
comms/airspyhf/distinfo
Normal file
3
comms/airspyhf/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1656019287
|
||||
SHA256 (airspy-airspyhf-1.6.8-7-gb93dedd_GH0.tar.gz) = 19075646e6ccbda05ab9d9ccb6678d0905ebf8acd66312cf1de34b17116b9190
|
||||
SIZE (airspy-airspyhf-1.6.8-7-gb93dedd_GH0.tar.gz) = 52949
|
11
comms/airspyhf/files/patch-libairspyhf_src_airspyhf.c
Normal file
11
comms/airspyhf/files/patch-libairspyhf_src_airspyhf.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- libairspyhf/src/airspyhf.c.orig 2022-06-23 21:14:46 UTC
|
||||
+++ libairspyhf/src/airspyhf.c
|
||||
@@ -1189,7 +1189,7 @@ int ADDCALL airspyhf_stop(airspyhf_device_t* device)
|
||||
int result1, result2;
|
||||
result1 = kill_io_threads(device);
|
||||
result2 = airspyhf_set_receiver_mode(device, RECEIVER_MODE_OFF);
|
||||
- libusb_interrupt_event_handler(device->usb_context);
|
||||
+ // libusb_interrupt_event_handler(device->usb_context);
|
||||
|
||||
if (result2 != AIRSPYHF_SUCCESS)
|
||||
{
|
4
comms/airspyhf/pkg-descr
Normal file
4
comms/airspyhf/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
User mode driver for Airspy HF+, a high performance software defined radio for
|
||||
the HF and VHF bands.
|
||||
|
||||
WWW: https://github.com/airspy/airspyhf
|
13
comms/airspyhf/pkg-plist
Normal file
13
comms/airspyhf/pkg-plist
Normal file
@ -0,0 +1,13 @@
|
||||
bin/airspyhf_calibrate
|
||||
bin/airspyhf_gpio
|
||||
bin/airspyhf_info
|
||||
bin/airspyhf_lib_version
|
||||
bin/airspyhf_rx
|
||||
include/libairspyhf/airspyhf.h
|
||||
include/libairspyhf/airspyhf_commands.h
|
||||
include/libairspyhf/iqbalancer.h
|
||||
lib/libairspyhf.a
|
||||
lib/libairspyhf.so
|
||||
lib/libairspyhf.so.0
|
||||
lib/libairspyhf.so.1.6.8
|
||||
libdata/pkgconfig/libairspyhf.pc
|
Loading…
Reference in New Issue
Block a user