Add dosbox 0.55, an emulator of a PC with DOS.

PR:		41082
Submitted by:	Tom Carrick <knyghtmare@knyghtmare.com>
This commit is contained in:
Munechika SUMIKAWA 2003-05-01 22:19:27 +00:00
parent 744d776bc9
commit dade58f65f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=79969
6 changed files with 81 additions and 0 deletions

View File

@ -15,6 +15,7 @@
SUBDIR += darcnes
SUBDIR += dgen-sdl
SUBDIR += dlx
SUBDIR += dosbox
SUBDIR += fmsx
SUBDIR += freesci
SUBDIR += frodo

48
emulators/dosbox/Makefile Normal file
View File

@ -0,0 +1,48 @@
# New ports collection makefile for: dosbox
# Date created: 28 July 2002
# Whom: Tom Carrick <knyghtmare@knyghtmare.com>
#
# $FreeBSD$
#
PORTNAME= dosbox
PORTVERSION= 0.55
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= knyghtmare@knyghtmare.com
COMMENT= An emulator of a PC with DOS
LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
USE_REINPLACE= yes
post-patch:
${REINPLACE_CMD} -e 's#<SDL/#<SDL11/#' ${WRKSRC}/include/timer.h \
${WRKSRC}/src/gui/sdlmain.cpp ${WRKSRC}/src/hardware/mixer.cpp
${REINPLACE_CMD} -e "s#@@PREFIX@@#${PREFIX}#" \
${WRKSRC}/src/misc/messages.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/dosbox ${PREFIX}/bin/dosbox
${MKDIR} ${PREFIX}/share/dosbox
${INSTALL_DATA} ${WRKSRC}/src/dosbox.lang ${PREFIX}/share/dosbox
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/dosbox
${INSTALL_DATA} ${WRKSRC}/NEWS ${PREFIX}/share/doc/dosbox
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dosbox
.endif
post-install:
@${ECHO_CMD} "================================================="
@${ECHO_CMD} "Be sure to read the README for usage instructions"
@${ECHO_CMD} "located in ${PREFIX}/share/doc/dosbox by default"
@${ECHO_CMD} "================================================="
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (dosbox-0.55.tar.gz) = b3daf143cb27f9d43b0683c39e26951a

View File

@ -0,0 +1,12 @@
--- src/misc/messages.cpp.orig Tue Jul 30 15:13:10 2002
+++ src/misc/messages.cpp Tue Sep 3 09:29:12 2002
@@ -101,7 +101,7 @@
/* Load the messages from "dosbox.lang file" */
first_message=0;
char filein[CROSS_LEN];
- strcpy(filein,dosbox_basedir);
- strcat(filein,"dosbox.lang");
+ strcpy(filein,"@@PREFIX@@/share/dosbox/dosbox.lang");
+/* strcat(filein,"dosbox.lang"); */
LoadMessageFile(filein);
}

View File

@ -0,0 +1,13 @@
DOSBox is an emulator of a PC with dos.
The main focus of this project is emulating old dos games using the
local file system for files.
Currently emulated is:
o CPU:286/386 realmode
o GFX:VGA/EGS/CGA
o SND:PC-Speaker/Tandy 3-Voice/Adlib/SoundBlaster
o MSC:Keyboard/Mouse
o DOS:Director FileSystem/XMS/EMS
WWW: http://dosbox.zophar.net/

View File

@ -0,0 +1,6 @@
bin/dosbox
share/dosbox/dosbox.lang
@dirrm share/dosbox
%%PORTDOCS%%share/doc/dosbox/NEWS
%%PORTDOCS%%share/doc/dosbox/README
%%PORTDOCS%%@dirrm share/doc/dosbox