www/py-django-dpaste: Pastebin application that powers dpaste.de [NEW PORT]

dpaste is a Django based pastebin. It's intended to run separately but its
also possible to be installed into an existing Django project like a regular
app. You can find a live example on dpaste.de

WWW: https://github.com/bartTC/dpaste/
This commit is contained in:
Kubilay Kocak 2013-12-08 13:17:41 +00:00
parent 2e6161aa6f
commit dadb749d43
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=335885
7 changed files with 53 additions and 0 deletions

View File

@ -1495,6 +1495,7 @@
SUBDIR += py-django-classy-tags
SUBDIR += py-django-cms
SUBDIR += py-django-devel
SUBDIR += py-django-dpaste
SUBDIR += py-django-evolution
SUBDIR += py-django-extensions
SUBDIR += py-django-filer

View File

@ -0,0 +1,30 @@
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
# $FreeBSD$
PORTNAME= dpaste
PORTVERSION= 2.0
CATEGORIES= www python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}django-
MAINTAINER= koobs@FreeBSD.org
COMMENT= Pastebin Django application that powers dpaste.de
LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=1.4:${PORTSDIR}/www/py-django \
${PYTHON_PKGNAMEPREFIX}django-mptt>=0.6.0:${PORTSDIR}/www/py-django-mptt \
${PYTHON_PKGNAMEPREFIX}pygments>=1.6:${PORTSDIR}/textproc/py-pygments \
${PYTHON_PKGNAMEPREFIX}requests>=1.0.0:${PORTSDIR}/www/py-requests
USE_GITHUB= yes
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYDISTUTILS_AUTOPLIST= yes
GH_ACCOUNT= bartTC
GH_COMMIT= 129be43
post-patch:
@${CP} ${FILESDIR}/MANIFEST.in ${WRKSRC}
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
SHA256 (dpaste-2.0.tar.gz) = d6704e01765a9e83d85729708be6464271c4e8a6fd65552f9c24d03d169dcc5f
SIZE (dpaste-2.0.tar.gz) = 113097

View File

@ -0,0 +1,3 @@
include *.rst LICENSE
recursive-include dpaste/templates *
recursive-include dpaste/static *

View File

@ -0,0 +1,11 @@
--- ./setup.py.orig 2013-12-07 23:20:33.881977668 +1100
+++ ./setup.py 2013-12-07 23:20:46.477070760 +1100
@@ -24,7 +24,7 @@
packages=find_packages(),
package_data={'dpaste': ['static/*.*', 'templates/*.*']},
- scripts=('manage.py',),
+ include_package_data=True,
install_requires=(
'django>=1.4',
'django-mptt>=0.6.0',

View File

@ -0,0 +1,5 @@
dpaste is a Django based pastebin. It's intended to run separately but its
also possible to be installed into an existing Django project like a regular
app. You can find a live example on dpaste.de
WWW: https://github.com/bartTC/dpaste/

View File

@ -0,0 +1 @@
@comment $FreeBSD$