Add evolution-devel after a repo copy from evolution. Evolution-devel is

the unstable GNOME 2 version of the Ximian Evolution groupware client.
Once 1.4 is released, this will become mail/evolution.
This commit is contained in:
Joe Marcus Clarke 2003-05-07 06:07:55 +00:00
parent be7ece819a
commit dabf2b8bf6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=80345
13 changed files with 1404 additions and 1658 deletions

View File

@ -6,38 +6,36 @@
#
PORTNAME= evolution
PORTVERSION= 1.2.4
PORTVERSION= 1.3.3
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://people.FreeBSD.org/~sobomax/:local
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.2 \
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.3 \
sobomax/:local
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
db-3.1.17${EXTRACT_SUFX}:local
DIST_SUBDIR= gnome
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= An integrated mail, calendar and address book distributed suite
LIB_DEPENDS= bonobo_conf.0:${PORTSDIR}/devel/bonobo-conf \
nss3.1:${PORTSDIR}/security/nss \
soup.6:${PORTSDIR}/devel/soup
LIB_DEPENDS= nss3.1:${PORTSDIR}/security/nss \
soup-2.0.0:${PORTSDIR}/devel/libsoup \
gtkhtml-3.0.1:${PORTSDIR}/www/gtkhtml3
.if defined(WITH_LDAP)
LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20
.endif
RUN_DEPENDS= gnome-spell-component-0.5:${PORTSDIR}/textproc/gnomespell \
gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
RUN_DEPENDS= ${X11BASE}/lib/gnome-spell/libgnome-spell-component-0.3.so:${PORTSDIR}/textproc/gnomespell-devel
.if !defined(WITHOUT_PILOT)
BUILD_DEPENDS+= ${X11BASE}/lib/gnome-pilot/conduits/libemail_conduit.so:${PORTSDIR}/palm/gnomepilot-conduits
RUN_DEPENDS+= ${X11BASE}/lib/gnome-pilot/conduits/libemail_conduit.so:${PORTSDIR}/palm/gnomepilot-conduits
LIB_DEPENDS+= gpilotdconduit.2:${PORTSDIR}/palm/gnomepilot2
.endif
USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs gal gtkhtml
USE_GNOME= gnomeprefix gnomehack gnometarget
USE_REINPLACE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
@ -62,9 +60,9 @@ PLIST_SUB= PILOT:="@comment "
CONFIGURE_ENV= CPPFLAGS="-I${DB3_WRKSRC} -I${LOCALBASE}/include" \
LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
PLIST_SUB+= VERSION=${PORTVERSION}
PLIST_SUB+= VERSION="1.3"
MAN1= evolution.1
#MAN1= evolution.1
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
@ -81,7 +79,7 @@ DB3_CONFIGURE_ARGS= --enable-compat185 \
--disable-dynamic \
--prefix=${PREFIX} \
--includedir=${PREFIX}/include/db3 \
--build=${ARCH}-unknown-freebsd${OSREL}
--target=${ARCH}-unknown-freebsd${OSREL}
pre-configure:
@(cd ${DB3_WRKSRC} && \

View File

@ -1,2 +1,2 @@
MD5 (gnome/evolution-1.2.4.tar.bz2) = 5f8f862b366c38d8b8c13adca89375c8
MD5 (gnome/db-3.1.17.tar.bz2) = b237f4e38a650d096389ff54d564928d
MD5 (gnome2/evolution-1.3.3.tar.bz2) = d9a6f15317e5f208af6e64f7894dbabb
MD5 (gnome2/db-3.1.17.tar.bz2) = b237f4e38a650d096389ff54d564928d

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig Mon Nov 11 17:44:58 2002
+++ Makefile.in Mon Nov 11 17:45:22 2002
@@ -223,7 +223,7 @@
changelogs = ChangeLog
-confexecdir = $(libdir)
+confexecdir = $(prefix)/etc
confexec_DATA = camelConf.sh evolution_shellConf.sh evolution_addressbookConf.sh evolution_calendarConf.sh

View File

@ -1,57 +1,46 @@
--- configure.orig Wed Nov 6 16:01:40 2002
+++ configure Tue Nov 12 00:12:54 2002
@@ -7260,7 +7260,7 @@
fi
rm -f conftest*
-ALL_LINGUAS="az bg ca cs da de el en_AU en_GB es et eu fi fr ga gl hu it ja ko lt lv nl nn no pl pt pt_BR ro ru sk sl sv tr uk vi zh_CN zh_TW"
+ALL_LINGUAS="az bg ca cs da de el en_AU en_GB es et eu fi fr ga gl hu it ja ko lt lv nl nn no pl pt pt_BR ro ru sk sl sv tr uk vi zh_CN"
# Extract the first word of "ranlib", so it can be a program name with args.
set dummy ranlib; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
@@ -9636,7 +9636,7 @@
CPPFLAGS_save="$CPPFLAGS"
--- configure.orig Mon Mar 10 12:01:16 2003
+++ configure Thu Mar 13 01:31:35 2003
@@ -11148,7 +11148,7 @@
CPPFLAGS="$DB3_CFLAGS $CPPFLAGS"
-for ac_hdr in db.h db3/db.h
+for ac_hdr in db3/db.h
-for ac_header in db.h db3/db.h
+for ac_header in db3/db.h
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
@@ -9710,7 +9710,7 @@
echo "configure: failed program was:" >&5
cat conftest.$ac_ext >&5
rm -rf conftest*
- { echo "configure: error: Found db.h is not version $evolution_db_version" 1>&2; exit 1; }
+# { echo "configure: error: Found db.h is not version $evolution_db_version" 1>&2; exit 1; }
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
if eval "test \"\${$as_ac_Header+set}\" = set"; then
@@ -11341,9 +11341,9 @@
echo "$as_me: failed program was:" >&5
sed 's/^/| /' conftest.$ac_ext >&5
-{ { echo "$as_me:$LINENO: error: Found db.h is not version $evolution_db_version" >&5
-echo "$as_me: error: Found db.h is not version $evolution_db_version" >&2;}
- { (exit 1); exit 1; }; }
+#{ { echo "$as_me:$LINENO: error: Found db.h is not version $evolution_db_version" >&5
+#echo "$as_me: error: Found db.h is not version $evolution_db_version" >&2;}
+# { (exit 1); exit 1; }; }
fi
rm -f conftest*
rm -f conftest.$ac_objext conftest.$ac_ext
@@ -12054,10 +12054,10 @@
Please specify the path to libnspr4.a
Example: --with-nspr-libs=/usr/lib" 1>&2; exit 1; }
else
- nsprlibs="-ldl $with_nspr_libs/libplc4.a $with_nspr_libs/libplds4.a $with_nspr_libs/libnspr4.a $PTHREAD_LIB"
+ nsprlibs="$with_nspr_libs/libplc4.a $with_nspr_libs/libplds4.a $with_nspr_libs/libnspr4.a $PTHREAD_LIB"
fi
else
- nsprlibs="-ldl -lplc4 -lplds4 -lnspr4 $PTHREAD_LIB"
+ nsprlibs="-lplc4 -lplds4 -lnspr4 $PTHREAD_LIB"
fi
@@ -13495,10 +13495,10 @@
Example: --with-nspr-libs=/usr/lib" >&2;}
{ (exit 1); exit 1; }; }
else
- nsprlibs="-ldl $with_nspr_libs/libplc4.a $with_nspr_libs/libplds4.a $with_nspr_libs/libnspr4.a $PTHREAD_LIB"
+ nsprlibs="$with_nspr_libs/libplc4.a $with_nspr_libs/libplds4.a $with_nspr_libs/libnspr4.a $PTHREAD_LIB"
fi
else
- nsprlibs="-ldl -lplc4 -lplds4 -lnspr4 $PTHREAD_LIB"
+ nsprlibs="-lplc4 -lplds4 -lnspr4 $PTHREAD_LIB"
fi
echo $ac_n "checking for Mozilla nspr libraries""... $ac_c" 1>&6
@@ -13857,10 +13857,10 @@
*) # Relative path.
ac_sub_cache_file="$ac_dots$cache_file" ;;
esac
- case "$ac_given_INSTALL" in
- [/$]*) INSTALL="$ac_given_INSTALL" ;;
- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
- esac
+# case "$ac_given_INSTALL" in
+# [/$]*) INSTALL="$ac_given_INSTALL" ;;
+# *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
+# esac
echo "$as_me:$LINENO: checking for Mozilla nspr libraries" >&5
@@ -16710,7 +16710,7 @@
idldir="$datadir/idl/evolution-$BASE_VERSION"
echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
# The eval makes quoting arguments work.
-serverdir="$libdir/bonobo/servers"
+serverdir="$prefix/libdata/bonobo/servers"
evolutionuidir="$privdatadir/ui"

View File

@ -1,7 +0,0 @@
--- calendar/gui/Makefile.in.orig Mon Jul 10 21:34:31 2000
+++ calendar/gui/Makefile.in Tue Jul 11 22:41:10 2000
@@ -593,3 +593,3 @@
install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(help_base)/C
+# $(mkinstalldirs) $(DESTDIR)$(help_base)/C
$(mkinstalldirs) $(Conduitsdir)

View File

@ -1,11 +0,0 @@
--- calendar/conduits/calendar/Makefile.in.orig Mon Dec 9 15:55:17 2002
+++ calendar/conduits/calendar/Makefile.in Mon Dec 9 15:56:02 2002
@@ -231,7 +231,7 @@
libecalendar_conduit_la_LDFLAGS = -module -avoid-version
-libecalendar_conduit_la_LIBADD = $(top_builddir)/e-util/libeutil.la $(top_builddir)/calendar/cal-client/libcal-client-static.la $(top_builddir)/calendar/cal-util/libcal-util-static.la $(top_builddir)/libversit/libversit.a $(top_builddir)/libical/src/libical/libical-static.la $(top_builddir)/libwombat/libwombat-static.la $(top_builddir)/e-util/libeconduit-static.la $(EVOLUTION_CALENDAR_CONDUIT_LIBS)
+libecalendar_conduit_la_LIBADD = $(top_builddir)/e-util/libeutil.la $(top_builddir)/calendar/cal-client/libcal-client.la $(top_builddir)/calendar/cal-util/libcal-util.la $(top_builddir)/libversit/libversit.a $(top_builddir)/libical/src/libical/libical-static.la $(top_builddir)/libwombat/libwombat.la $(top_builddir)/e-util/libeconduit.la $(EVOLUTION_CALENDAR_CONDUIT_LIBS)
Conduitdir = $(datadir)/gnome-pilot/conduits/

View File

@ -1,11 +0,0 @@
--- calendar/conduits/todo/Makefile.in.orig Mon Dec 9 16:01:21 2002
+++ calendar/conduits/todo/Makefile.in Mon Dec 9 16:01:48 2002
@@ -231,7 +231,7 @@
libetodo_conduit_la_LDFLAGS = -module -avoid-version
-libetodo_conduit_la_LIBADD = $(top_builddir)/e-util/libeutil.la $(top_builddir)/calendar/cal-client/libcal-client-static.la $(top_builddir)/calendar/cal-util/libcal-util-static.la $(top_builddir)/libversit/libversit.a $(top_builddir)/libical/src/libical/libical-static.la $(top_builddir)/libwombat/libwombat-static.la $(top_builddir)/e-util/libeconduit-static.la $(EVOLUTION_CALENDAR_CONDUIT_LIBS)
+libetodo_conduit_la_LIBADD = $(top_builddir)/e-util/libeutil.la $(top_builddir)/calendar/cal-client/libcal-client.la $(top_builddir)/calendar/cal-util/libcal-util.la $(top_builddir)/libversit/libversit.a $(top_builddir)/libical/src/libical/libical-static.la $(top_builddir)/libwombat/libwombat.la $(top_builddir)/e-util/libeconduit.la $(EVOLUTION_CALENDAR_CONDUIT_LIBS)
Conduitdir = $(datadir)/gnome-pilot/conduits/

View File

@ -1,11 +0,0 @@
--- camel/Makefile.in.orig Thu Sep 19 15:23:54 2002
+++ camel/Makefile.in Thu Sep 19 15:24:30 2002
@@ -265,7 +265,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I..
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
-LIBS = @LIBS@
+LIBS = @LIBS@ -lintl
libcamel_la_DEPENDENCIES = $(top_builddir)/e-util/libeutil.la
libcamel_la_OBJECTS = broken-date-parser.lo camel-address.lo \
camel-arg.lo camel-block-file.lo camel-certdb.lo camel-charset-map.lo \

View File

@ -1,29 +1,11 @@
--- camel/camel-mime-utils.c.orig Mon Oct 7 22:44:40 2002
+++ camel/camel-mime-utils.c Mon Dec 2 02:34:31 2002
@@ -3387,6 +3387,8 @@
return 0;
--- camel/camel-mime-utils.c.orig Fri May 3 15:47:41 2002
+++ camel/camel-mime-utils.c Sun May 5 18:09:24 2002
@@ -3388,6 +3388,8 @@
}
d(printf("named offset = %d\n", offset));
}
+ tm.tm_isdst = -1;
+
d(printf ("\ndecoding date '%s'\n", inptr));
+ tm.tm_isdst = -1;
memset (&tm, 0, sizeof(tm));
@@ -3739,8 +3741,6 @@
/* X-Mailing-List: gnome-hackers */
/* X-Mailing-List: <gnome-hackers> */
{ "X-Mailing-List", "[ \t]*<?([^@>]+)@?([^ \n\t\r>]*)" },
- /* X-Loop: gnome-hackers@gnome.org */
- { "X-Loop", "[ \t]*([^@]+)@?([^ \n\t\r>]*)" },
/* List-Id: GNOME stuff <gnome-hackers.gnome.org> */
/* List-Id: <gnome-hackers.gnome.org> */
/* List-Id: <gnome-hackers> */
@@ -3756,6 +3756,8 @@
/* X-List: gnome-hackers */
/* X-List: gnome-hackers@gnome.org */
{ "X-List", "[ \t]*([^@]+)@?([^ \n\t\r>]*)" },
+ /* X-Loop: gnome-hackers@gnome.org */
+ { "X-Loop", "[ \t]*([^@]+)@?([^ \n\t\r>]*)" },
/* Sender: owner-gnome-hackers@gnome.org */
/* Sender: owner-gnome-hacekrs */
{ "Sender", "[ \t]*owner-([^@]+)@?([^ @\n\t\r>]*)" },
t = mktime(&tm);
#if defined(HAVE_TIMEZONE)

View File

@ -1,35 +0,0 @@
--- importers/Makefile.in.orig Thu Sep 19 00:27:31 2002
+++ importers/Makefile.in Thu Sep 19 00:30:02 2002
@@ -277,12 +277,12 @@
$(top_builddir)/shell/importer/libevolution-importer.la \
$(top_builddir)/camel/libcamel.la $(top_builddir)/e-util/libeutil.la \
$(top_builddir)/filter/libfilter.la $(top_builddir)/shell/libeshell.la
-evolution_netscape_importer_LDFLAGS =
+evolution_netscape_importer_LDFLAGS = -module -avoid-version
evolution_elm_importer_OBJECTS = elm-importer.$(OBJEXT)
evolution_elm_importer_DEPENDENCIES = \
$(top_builddir)/shell/importer/libevolution-importer.la \
$(top_builddir)/e-util/libeutil.la
-evolution_elm_importer_LDFLAGS =
+evolution_elm_importer_LDFLAGS = -module -avoid-version
evolution_pine_importer_OBJECTS = pine-importer.$(OBJEXT)
evolution_pine_importer_DEPENDENCIES = \
$(top_builddir)/shell/importer/libevolution-importer.la \
@@ -290,7 +290,7 @@
$(top_builddir)/camel/libcamel.la $(top_builddir)/e-util/libeutil.la \
$(top_builddir)/e-util/ename/libename.la \
$(top_builddir)/libversit/libversit.a
-evolution_pine_importer_LDFLAGS =
+evolution_pine_importer_LDFLAGS = -module -avoid-version
evolution_gnomecard_importer_OBJECTS = \
evolution-gnomecard-importer.$(OBJEXT)
evolution_gnomecard_importer_DEPENDENCIES = \
@@ -299,7 +299,7 @@
$(top_builddir)/camel/libcamel.la $(top_builddir)/e-util/libeutil.la \
$(top_builddir)/e-util/ename/libename.la \
$(top_builddir)/libversit/libversit.a
-evolution_gnomecard_importer_LDFLAGS =
+evolution_gnomecard_importer_LDFLAGS = -module -avoid-version
CFLAGS = @CFLAGS@
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View File

@ -1,14 +0,0 @@
$FreeBSD$
--- po/Makefile.in.in.orig Thu Feb 7 14:34:39 2002
+++ po/Makefile.in.in Thu Feb 7 14:36:07 2002
@@ -106,7 +106,7 @@
@catalogs='$(CATALOGS)'; \
for cat in $$catalogs; do \
cat=`basename $$cat`; \
- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
+ lang=`echo $$cat | sed 's/\.mo$$//'`; \
dir=$(localedir)/$$lang/LC_MESSAGES; \
$(mkinstalldirs) $(DESTDIR)$$dir; \
if test -r $$cat; then \

View File

@ -1,11 +0,0 @@
--- shell/Makefile.in.orig Thu Sep 19 13:31:46 2002
+++ shell/Makefile.in Thu Sep 19 13:38:39 2002
@@ -217,7 +217,7 @@
SUBDIRS = glade importer
-INCLUDES = -O -I$(top_srcdir)/widgets -I$(top_srcdir)/widgets/misc -I$(top_srcdir)/libical/src/libical -I$(top_builddir)/libical/src/libical -I$(top_srcdir) -DEVOLUTION_IMAGES=\""$(datadir)/images/evolution"\" -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" -DEVOLUTION_DATADIR=\""$(datadir)"\" -DEVOLUTION_GLADEDIR=\"$(datadir)/evolution/glade\" -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" -DPREFIX=\"$(prefix)\" -DG_LOG_DOMAIN=\"evolution-shell\" $(SHELL_CFLAGS)
+INCLUDES = -I$(top_srcdir)/widgets -I$(top_srcdir)/widgets/misc -I$(top_srcdir)/libical/src/libical -I$(top_builddir)/libical/src/libical -I$(top_srcdir) -DEVOLUTION_IMAGES=\""$(datadir)/images/evolution"\" -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" -DEVOLUTION_DATADIR=\""$(datadir)"\" -DEVOLUTION_GLADEDIR=\"$(datadir)/evolution/glade\" -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" -DPREFIX=\"$(prefix)\" -DG_LOG_DOMAIN=\"evolution-shell\" $(SHELL_CFLAGS)
# Shell CORBA stuff

File diff suppressed because it is too large Load Diff