Add linc 0.1.16, a library for writing networked servers & clients.

This commit is contained in:
Maxim Sobolev 2002-02-12 13:12:30 +00:00
parent bf1ea36835
commit da9abcb0d6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=54607
8 changed files with 110 additions and 0 deletions

View File

@ -221,6 +221,7 @@
SUBDIR += licq-console
SUBDIR += licq-devel
SUBDIR += licq-qt-gui
SUBDIR += linc
SUBDIR += linpopup
SUBDIR += lla
SUBDIR += macipgw

34
net/linc/Makefile Normal file
View File

@ -0,0 +1,34 @@
# New ports collection makefile for: linc
# Date Created: 12 February 2002
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= linc
PORTVERSION= 0.1.16
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= glib-1.3.13:${PORTSDIR}/devel/glib13
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
.include <bsd.port.mk>

1
net/linc/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (gnome2/linc-0.1.16.tar.bz2) = bb2aa352564eb4f6011b684b75877ba8

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- Makefile.in 2002/02/12 12:58:07 1.1
+++ Makefile.in 2002/02/12 13:09:12
@@ -89,7 +89,7 @@
VERSION = @VERSION@
WARN_CFLAGS = @WARN_CFLAGS@
-SUBDIRS = include src test docs
+SUBDIRS = include src docs
m4datadir = $(datadir)/aclocal
m4data_DATA = linc.m4

View File

@ -0,0 +1,28 @@
$FreeBSD$
--- ltmain.sh 2001/08/27 09:51:26 1.1
+++ ltmain.sh 2001/08/27 09:51:42
@@ -2408,6 +2408,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
@@ -4175,10 +4178,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

1
net/linc/pkg-comment Normal file
View File

@ -0,0 +1 @@
A library for writing networked servers & clients

8
net/linc/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
linc is a library that eases the task of writing networked servers & clients.
It takes care of connection initiation and maintainance, and the details of
various transports. It is used by the ORBit2 to handle message
transmission/receipt.
The connections can optionally be encrypted using OpenSSL.
WWW: http://developer.gnome.org/projects/gap/

23
net/linc/pkg-plist Normal file
View File

@ -0,0 +1,23 @@
bin/linc-config
include/linc-1.0/linc/linc-config.h
include/linc-1.0/linc/linc-connection.h
include/linc-1.0/linc/linc-protocol.h
include/linc-1.0/linc/linc-server.h
include/linc-1.0/linc/linc-types.h
include/linc-1.0/linc/linc.h
lib/liblinc.a
lib/liblinc.so
lib/liblinc.so.1
libdata/pkgconfig/linc.pc
share/aclocal/linc.m4
share/doc/linc/c4.html
share/doc/linc/index.html
share/doc/linc/index.sgml
share/doc/linc/linc-linc-protocol.html
share/doc/linc/linc-linc-types.html
share/doc/linc/linc-linc.html
share/doc/linc/linc-lincconnection.html
share/doc/linc/linc-lincserver.html
@dirrm share/doc/linc
@dirrm include/linc-1.0/linc
@dirrm include/linc-1.0