- Update `net-p2p/torrent-file-editor' to version 0.3.9, which fixes

creating torrents which contain files larger than 2 GB in size
- TIMESTAMP (torrent-file-editor-0.3.9.tar.gz) = 1512986548

Reported by:	portscout
This commit is contained in:
Alexey Dokuchaev 2017-12-11 11:32:01 +00:00
parent e7d1a7f6d7
commit da91be60f3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=456022
3 changed files with 5 additions and 14 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= torrent-file-editor
PORTVERSION= 0.3.8
PORTVERSION= 0.3.9
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/v${PORTVERSION}

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1512039438
SHA256 (torrent-file-editor-0.3.8.tar.gz) = 4545a6c2e2cf1eb8924319a86fd4d6cc7aa319c26b31c263de9709c48102762e
SIZE (torrent-file-editor-0.3.8.tar.gz) = 336154
TIMESTAMP = 1512986548
SHA256 (torrent-file-editor-0.3.9.tar.gz) = 8821a57fca153bdf0de16f79386e8725092e8377c8defdaeb8e0882122cf8aec
SIZE (torrent-file-editor-0.3.9.tar.gz) = 343340

View File

@ -1,14 +1,5 @@
--- CMakeLists.txt.orig 2017-09-26 09:30:09 UTC
--- CMakeLists.txt.orig 2017-12-11 09:39:35 UTC
+++ CMakeLists.txt
@@ -46,7 +46,7 @@ if(CMAKE_BUILD_TYPE STREQUAL Release OR CMAKE_BUILD_TY
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
# #warning is not an error
- if(NOT APPLE)
+ if(NOT APPLE AND NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=cpp")
else()
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-#warnings")
@@ -108,6 +108,7 @@ if(QT5_BUILD)
else()
find_package(Qt4 REQUIRED)