patch-04 and patch-05 are merged into KAME IPv6 patch.

Approved by:	billf
This commit is contained in:
Munechika SUMIKAWA 2001-05-09 08:31:32 +00:00
parent 792310cae0
commit da07978652
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42443
4 changed files with 3 additions and 37 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= mtr
PORTVERSION= 0.42
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.bitwizard.nl/mtr/ \
http://www.giovannelli.it/~gmarco/files/
@ -23,7 +23,7 @@ MAN8= mtr.8
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 400014
PATCHFILES= mtr-042-v6-20000719.diff.gz
PATCHFILES= mtr-042-v6-20010508.diff.gz
PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/
PATCH_DIST_STRIP= -p1

View File

@ -1,2 +1,2 @@
MD5 (mtr-0.42.tar.gz) = cb4da4e6dbc0b527b7fc2a7199c51c3b
MD5 (mtr-042-v6-20000719.diff.gz) = 56e386f272016654b3d117d6606e5ca1
MD5 (mtr-042-v6-20010508.diff.gz) = cad20b4dcbe4f7eaad46936fa341b486

View File

@ -1,24 +0,0 @@
--- curses.c~ Sat Mar 10 17:04:01 2001
+++ curses.c Sat Mar 10 17:04:39 2001
@@ -22,6 +22,7 @@
#ifndef NO_CURSES
#include <ctype.h>
#include <stdlib.h>
+#include <sys/types.h>
#include <netdb.h>
#include <sys/socket.h>
@@ -35,13 +36,6 @@
# include <cursesX.h>
#else
# error No curses header file available
-#endif
-
-#if defined(HAVE_SYS_TYPES_H)
-#include <sys/types.h>
-#else
-/* If a system doesn't have sys/types.h, lets hope that time_t is an int */
-#define time_t int
#endif
#ifndef HAVE_ATTRON

View File

@ -1,10 +0,0 @@
--- split.c~ Sat Mar 10 17:04:01 2001
+++ split.c Sat Mar 10 17:04:11 2001
@@ -24,6 +24,7 @@
#include <ctype.h>
#include <stdlib.h>
#include <stdio.h>
+#include <sys/types.h>
#include <netdb.h>
#include <sys/socket.h>
#include <netinet/in.h>