This library is minimum, easy-to-use, C implementation for xml file parsing.

Because XML parsing is always hard to reinvent.
Because very often, xml libraries are too big to fit with little application.

WWW: http://code.google.com/p/libroxml/

PR:		ports/145755
Submitted by:	Hung-Yi Chen <gaod at hychen.org>
This commit is contained in:
Martin Wilke 2010-04-17 05:27:34 +00:00
parent 0652f54e53
commit d9e08fa3c1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=252788
5 changed files with 75 additions and 0 deletions

View File

@ -307,6 +307,7 @@
SUBDIR += libnxml
SUBDIR += libparsifal
SUBDIR += libpathan
SUBDIR += libroxml
SUBDIR += libstree
SUBDIR += libtext-charwidth-perl
SUBDIR += libtext-wrapi18n-perl

View File

@ -0,0 +1,31 @@
# New ports collection makefile for: libroxml
# Date created: 2010-04-16
# Whom: Hung-Yi Chen <gaod@hychen.org>
#
# $FreeBSD$
#
PORTNAME= libroxml
PORTVERSION= 2.0.1
CATEGORIES= textproc
MASTER_SITES= GOOGLE_CODE
DISTNAME= libroxml-${PORTVERSION}
MAINTAINER= gaod@hychen.org
COMMENT= A minimum, easy-to-use, C implementation for xml file parsing
PROJECTHOST= libroxml
USE_GMAKE= yes
MAKE_ENV+= DESTDIR=${PREFIX}
USE_LDCONFIG= yes
MAN1= roxml.1
PLIST_FILES= bin/roxml \
lib/libroxml.so \
lib/libroxml.so.0 \
lib/libroxml.a \
include/roxml.h
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (libroxml-2.0.1.tar.gz) = a309bc508195a5e9ebf8224ff4ef998f
SHA256 (libroxml-2.0.1.tar.gz) = f544334cae3b7471bf0f8acd41e989c75f7544c09eaba7e1e26b9eab50d1509a
SIZE (libroxml-2.0.1.tar.gz) = 85427

View File

@ -0,0 +1,35 @@
--- Makefile.orig 2010-03-20 07:47:37.000000000 +0800
+++ Makefile 2010-04-16 18:56:26.000000000 +0800
@@ -111,25 +111,13 @@
$E - $(MAKE) -C $(abspath fuse.xml)
.PHONY: install
-install: $(TARGETS) doxy
- $P ' INSTALL DIRS'
- $E mkdir -p $(DESTDIR)/usr/bin
- $E mkdir -p $(DESTDIR)/usr/include
- $E mkdir -p $(DESTDIR)/usr/lib/pkgconfig
- $E mkdir -p $(DESTDIR)/usr/share/man/man3
- $E mkdir -p $(DESTDIR)/usr/share/man/man1
- $E mkdir -p $(DESTDIR)/usr/share/doc/libroxml/html
- $P ' INSTALL FILES'
- $E install -D $(TARGET_SLIB) $(DESTDIR)/usr/lib
- $E install -D $(TARGET_LIB) $(DESTDIR)/usr/lib
- $E install -D $(TARGET_BIN) $(DESTDIR)/usr/bin
- $E install -D $(INC) $(DESTDIR)/usr/include
- $E install -D LGPL.txt $(DESTDIR)/usr/share/doc/libroxml/
- $E install -D docs/roxml.1 $(DESTDIR)/usr/share/man/man1/
- $E install -D docs/man/man3/* $(DESTDIR)/usr/share/man/man3/
- $E install -D docs/html/* $(DESTDIR)/usr/share/doc/libroxml/html/
- $E install -m644 libroxml.pc $(DESTDIR)/usr/lib/pkgconfig
- $E cp -d $(TARGET_LN) $(DESTDIR)/usr/lib
+install:
+ $E install $(TARGET_SLIB) $(DESTDIR)/lib
+ $E install $(TARGET_LIB) $(DESTDIR)/lib
+ $E install $(TARGET_BIN) $(DESTDIR)/bin
+ $E install $(INC) $(DESTDIR)/include
+ $E install docs/roxml.1 $(DESTDIR)/man/man1/
+ $E install $(TARGET_LN) $(DESTDIR)/lib
.PHONY: uninstall
uninstall:

View File

@ -0,0 +1,5 @@
This library is minimum, easy-to-use, C implementation for xml file parsing.
Because XML parsing is always hard to reinvent.
Because very often, xml libraries are too big to fit with little application.
WWW: http://code.google.com/p/libroxml/