* Update to 0.7.3.3

* Update master sites.
* Fix build and unbreak port.
This commit is contained in:
Andrey Slusar 2006-02-10 15:07:06 +00:00
parent 5d63054c79
commit d9d0485e10
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=155658
8 changed files with 90 additions and 18 deletions

View File

@ -6,10 +6,9 @@
#
PORTNAME= rscheme
PORTVERSION= 0.7.3.2
PORTVERSION= 0.7.3.3
CATEGORIES= lang scheme
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MASTER_SITES= http://www.rscheme.org/rs/b/${PORTVERSION}/32/
DISTNAME= rs-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@ -28,12 +27,6 @@ MAKE_ENV= REAL_PREFIX=${PREFIX}
BOOTSTRAP_DIR= ${WRKDIR}/${DISTNAME}
BOOTSTRAP_TARGET= stage1
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
BROKEN= "Coredump during build"
.endif
post-extract:
@${MKDIR} ${WRKSRC} ${WRKDIR}/build
@ -50,4 +43,4 @@ do-install:
(cd ${WRKDIR}/build && ${TAR} -c -f - resource) \
| (cd ${DATADIR} && ${TAR} --unlink -x -f -)
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (rs-0.7.3.2.tar.gz) = 7b76fb21652a30e641db3994c06fda5e
SHA256 (rs-0.7.3.2.tar.gz) = 66fc81ef69e52e7f8d35225d6927e9015a9f2c2006bb8f2557f5c78bb204ccb3
SIZE (rs-0.7.3.2.tar.gz) = 1907741
MD5 (rs-0.7.3.3.tar.gz) = 30b3be7aa86bcb2be3361fda0eec3657
SHA256 (rs-0.7.3.3.tar.gz) = de2d5f7fc7103ef758f248f29979588f456b5f2ce43a05f6adfe35b0c7219ec0
SIZE (rs-0.7.3.3.tar.gz) = 2470576

View File

@ -0,0 +1,13 @@
$FreeBSD$
--- ../handc/runtime/basemath.c Fri Feb 10 14:51:07 2006
+++ ../handc/runtime/basemath.c Fri Feb 10 14:57:02 2006
@@ -1319,6 +1319,7 @@
} else {
scheme_error( "non-basic-integer value ~s is not a valid UINT_32", 1, a );
}
+ return 0;
}
/* extra 1 (36+1=37) is for NUL which isn't used... */

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- ../handc/runtime/smemory.c Sat May 21 05:10:48 2005
+++ ../handc/runtime/smemory.c Fri Feb 10 14:41:56 2006
@@ -481,7 +481,7 @@
e = b->elements;
for (i=0; i<n; i++, e++)
{
- fprintf( stderr, " [%u] from {%08lx} SLOT(%u) ; a %s\n",
+ fprintf( stderr, " [%u] from {%08lx} SLOT(%lu) ; a %s\n",
j,
e->item,
e->offset / SLOT(1),

View File

@ -1,14 +1,14 @@
$FreeBSD$
--- ../stage0/configure 2001/07/31 06:44:55 1.1
+++ ../stage0/configure 2001/07/31 06:45:13
@@ -2837,7 +2837,7 @@
--- ../stage0/configure.orig Mon Jun 13 17:00:47 2005
+++ ../stage0/configure Fri Feb 10 14:19:41 2006
@@ -6608,7 +6608,7 @@
#
if $OPTIMIZE
if test "$OPTIMIZE" = true -a "$GNU_C" = true
-then CFLAGS="$CFLAGS -O2"
+then CFLAGS="$CFLAGS"
fi
echo $ac_n "checking if we should use hardware registers""... $ac_c" 1>&6
# HWREGS is broken on the latest GCC (3.3) on both

View File

@ -0,0 +1,13 @@
$FreeBSD$
--- ../stage0/runtime/basemath.c Fri Feb 10 14:51:07 2006
+++ ../stage0/runtime/basemath.c Fri Feb 10 14:57:02 2006
@@ -1319,6 +1319,7 @@
} else {
scheme_error( "non-basic-integer value ~s is not a valid UINT_32", 1, a );
}
+ return 0;
}
/* extra 1 (36+1=37) is for NUL which isn't used... */

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- ../stage0/runtime/smemory.c Sat May 21 05:10:48 2005
+++ ../stage0/runtime/smemory.c Fri Feb 10 14:41:56 2006
@@ -481,7 +481,7 @@
e = b->elements;
for (i=0; i<n; i++, e++)
{
- fprintf( stderr, " [%u] from {%08lx} SLOT(%u) ; a %s\n",
+ fprintf( stderr, " [%u] from {%08lx} SLOT(%lu) ; a %s\n",
j,
e->item,
e->offset / SLOT(1),

View File

@ -0,0 +1,25 @@
$FreeBSD$
--- ../handc/runtime/vinsns.h Fri Feb 10 15:56:41 2006
+++ ../handc/runtime/vinsns.h Fri Feb 10 15:56:57 2006
@@ -58,7 +58,7 @@
arg_count_reg = num; \
return (jump_addr)label;)
#else
-#define JUMP(num,label) return (jump_addr)((jump_addr)label)()
+#define JUMP(num,label) return label()
#endif
#endif
--- ../stage0/runtime/vinsns.h Fri Feb 10 15:56:41 2006
+++ ../stage0/runtime/vinsns.h Fri Feb 10 15:56:57 2006
@@ -58,7 +58,7 @@
arg_count_reg = num; \
return (jump_addr)label;)
#else
-#define JUMP(num,label) return (jump_addr)((jump_addr)label)()
+#define JUMP(num,label) return label()
#endif
#endif