math/py-mathics: allow to run with sympy-1.11.1

This commit is contained in:
Thierry Thomas 2023-01-20 19:00:29 +01:00
parent 32e1b7c5c2
commit d9acc3ed30
3 changed files with 23 additions and 1 deletions

View File

@ -1,6 +1,6 @@
PORTNAME= Mathics3
PORTVERSION= 5.0.2
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= math python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View File

@ -0,0 +1,11 @@
--- Mathics3.egg-info/requires.txt.orig 2022-08-06 09:38:06 UTC
+++ Mathics3.egg-info/requires.txt
@@ -1,7 +1,7 @@
Mathics-Scanner<1.3.0,>=1.2.1
numpy
llvmlite
-sympy<1.11,>=1.8
+sympy<1.11.2,>=1.8
recordclass
Mathics_Scanner<1.3.0,>=1.2.1
mpmath>=1.2.0

View File

@ -0,0 +1,11 @@
--- setup.py.orig 2023-01-20 17:32:12 UTC
+++ setup.py
@@ -57,7 +57,7 @@ elif sys.version_info[:2] == (3, 6):
elif sys.version_info[:2] == (3, 7):
INSTALL_REQUIRES += ["numpy<1.22", "llvmlite", "sympy>=1.8, < 1.11"]
else:
- INSTALL_REQUIRES += ["numpy", "llvmlite", "sympy>=1.8, < 1.11"]
+ INSTALL_REQUIRES += ["numpy", "llvmlite", "sympy>=1.8, < 1.11.2"]
if not is_PyPy:
INSTALL_REQUIRES += ["recordclass"]