graphics/vulkan-loader: unbreak build on non-x86 archs after e99b707ea9
CMake Error at loader/CMakeLists.txt:311 (target_compile_definitions):
Cannot specify compile definitions for target "asm_offset" which is not
built by this project.
This reverts commit e99b707ea9
.
PR: 259718
Reported by: mikael (aarch64)
This commit is contained in:
parent
bb5cd9be0d
commit
d97553f6f7
@ -4,9 +4,6 @@ DISTVERSION= 1.2.197
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics devel
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
PATCHFILES+= b8ee23e4d5ac.patch:-p1 # https://github.com/KhronosGroup/Vulkan-Loader/pull/738
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
COMMENT= Driver loader for the Vulkan graphics API
|
||||
|
||||
|
@ -1,5 +1,3 @@
|
||||
TIMESTAMP = 1635956498
|
||||
SHA256 (KhronosGroup-Vulkan-Loader-v1.2.197_GH0.tar.gz) = fd1bf11dfa62ed118fc3537c849e6619e2c7b84598b60a2ad89f7af553eb29d6
|
||||
SIZE (KhronosGroup-Vulkan-Loader-v1.2.197_GH0.tar.gz) = 1436996
|
||||
SHA256 (b8ee23e4d5ac.patch) = a5bdac0080bcaf342d45b4b4d5ebbc6d68aef190b47dfb7bd5545a6f72aa3dd5
|
||||
SIZE (b8ee23e4d5ac.patch) = 1797
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- loader/vk_loader_platform.h.orig 2021-11-03 16:21:38 UTC
|
||||
+++ loader/vk_loader_platform.h
|
||||
@@ -156,7 +156,7 @@ static inline bool loader_platform_is_path_absolute(co
|
||||
|
||||
static inline char *loader_platform_dirname(char *path) { return dirname(path); }
|
||||
|
||||
-#if defined(__linux__) || defined(__FreeBSD__)
|
||||
+#if defined(__linux__)
|
||||
|
||||
// find application path + name. Path cannot be longer than 1024, returns NULL if it is greater than that.
|
||||
static inline char *loader_platform_executable_path(char *buffer, size_t size) {
|
Loading…
Reference in New Issue
Block a user