New port: textproc/py-duecredit: Embed scientific publication or other references in the original code

This commit is contained in:
Yuri Victorovich 2018-05-14 00:08:08 +00:00
parent 3de5cbcd36
commit d925b690cc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=469840
5 changed files with 49 additions and 0 deletions

View File

@ -1289,6 +1289,7 @@
SUBDIR += py-diff-match-patch
SUBDIR += py-docutils
SUBDIR += py-dsv
SUBDIR += py-duecredit
SUBDIR += py-elasticsearch
SUBDIR += py-elasticsearch-async
SUBDIR += py-elasticsearch5

View File

@ -0,0 +1,23 @@
# $FreeBSD$
PORTNAME= duecredit
DISTVERSION= 0.6.3
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Embed scientific publication or other references in the original code
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}citeproc-py>=0.4:textproc/py-citeproc-py@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
USES= python
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1526251833
SHA256 (duecredit-0.6.3.tar.gz) = 93b84a0333b9f6985f025f5f7daa049e0d4081ebde54905ef4d97a5f36b4df17
SIZE (duecredit-0.6.3.tar.gz) = 416360

View File

@ -0,0 +1,11 @@
--- setup.py.orig 2018-05-14 00:01:07 UTC
+++ setup.py
@@ -39,7 +39,7 @@ try:
list(filter(lambda x: x.startswith(' -- '), lines))[0].rstrip())
else:
print('Attempting to get version number from git...')
- git = Popen(['git', 'describe', '--abbrev=4', '--dirty'],
+ git = Popen(['false', 'describe', '--abbrev=4', '--dirty'],
stdout=PIPE, stderr=sys.stderr)
if git.wait() != 0:
raise OSError

View File

@ -0,0 +1,11 @@
duecredit is being conceived to address the problem of inadequate citation of
scientific software and methods, and limited visibility of donation requests
for open-source software.
It provides a simple framework (at the moment for Python only) to embed
publication or other references in the original code so they are automatically
collected and reported to the user at the necessary level of reference detail,
i.e. only references for actually used functionality will be presented back if
software provides multiple citeable implementations.
WWW: https://github.com/duecredit/duecredit