- Respect CC/CCFLAGS [1]
- use -pthread instead of -lpthread [2] - It was only ever accidental that -ldb showed up in apu-config --libs Subversion doesn't actually even use it (apr_dbm*). APR/Util is supposed to auto load the backed db library without the app ever know which one it was. Subversion uses db _directly_. Subversion 1.6.3 should account for this. [3] - Convert to bsd.options.mk - Bump PORTREVISION PR: ports/135396 [3], ports/134453 [2], ports/132432 [1] Submitted by: dev@apr.apache.org (wrowe, bojan) [3], b.f. [2], Anonymous <swell.k@gmail.com> [1]
This commit is contained in:
parent
0fb954b294
commit
d906134aee
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=235527
@ -6,6 +6,7 @@
|
||||
|
||||
PORTNAME= apr
|
||||
PORTVERSION= ${APR_VERSION}.${APU_VERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_APACHE}
|
||||
MASTER_SITE_SUBDIR= apr
|
||||
@ -37,6 +38,8 @@ USE_PYTHON_BUILD= yes
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}"
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
APR_WRKDIR= ${WRKDIR}/apr-${APR_VERSION}
|
||||
APU_WRKDIR= ${WRKDIR}/apr-util-${APU_VERSION}
|
||||
@ -49,7 +52,7 @@ APU_CONF_ARGS= --with-apr=${APR_WRKDIR} \
|
||||
--with-expat=${LOCALBASE} \
|
||||
--with-iconv=${LOCALBASE}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
########## APR Options
|
||||
.if defined(WITHOUT_THREADS)
|
||||
@ -177,8 +180,11 @@ PLIST_SUB+= APU_EXTRAS="@comment "
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's/OSVERSION/'${OSVERSION}'/g' \
|
||||
${APR_WRKDIR}/build/apr_hints.m4
|
||||
${FIND} ${WRKDIR} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
${FIND} ${APR_WRKDIR} ${APU_WRKDIR} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
|
||||
${REINPLACE_CMD} -e 's,-lpthreads,${PTHREAD_LIBS},g' \
|
||||
${APR_WRKDIR}/build/apr_threads.m4 ${APR_WRKDIR}/build/apr_hints.m4 \
|
||||
${APU_WRKDIR}/build/apu-conf.m4
|
||||
|
||||
run-autotools::
|
||||
cd ${APR_WRKDIR} ; \
|
||||
@ -220,4 +226,4 @@ debug_autoconf:
|
||||
@${ECHO} "${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS} ${APR_CONF_ARGS}"
|
||||
@${ECHO} "${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS} ${APR_UTIL_CONF_ARGS}"
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
39
devel/apr/files/patch-apr-util-1.3.7__apu-config.in
Normal file
39
devel/apr/files/patch-apr-util-1.3.7__apu-config.in
Normal file
@ -0,0 +1,39 @@
|
||||
--- ./apr-util-1.3.7/apu-config.in.orig 2008-05-23 17:27:59.000000000 -0400
|
||||
+++ ./apr-util-1.3.7/apu-config.in 2009-06-10 01:03:50.971447822 -0400
|
||||
@@ -31,6 +31,7 @@
|
||||
INCLUDES="@APRUTIL_INCLUDES@"
|
||||
LDFLAGS="@APRUTIL_LDFLAGS@"
|
||||
LDAP_LIBS="@LDADD_ldap@"
|
||||
+DBM_LIBS="@LDADD_dbm_db@ @LDADD_dbm_gdbm@ @LDADD_dbm_ndbm@"
|
||||
|
||||
APRUTIL_LIBNAME="@APRUTIL_LIBNAME@"
|
||||
|
||||
@@ -56,6 +57,8 @@
|
||||
--libs print library information
|
||||
--avoid-ldap do not include ldap library information with --libs
|
||||
--ldap-libs print additional library information to link with ldap
|
||||
+ --avoid-dbm do not include DBM library information with --libs
|
||||
+ --dbm-libs print additional library information to link with DBM
|
||||
--srcdir print APR-util source directory
|
||||
--link-ld print link switch(es) for linking to APR-util
|
||||
--link-libtool print the libtool inputs for linking to APR-util
|
||||
@@ -115,12 +118,18 @@
|
||||
--avoid-ldap)
|
||||
LDAP_LIBS=""
|
||||
;;
|
||||
+ --avoid-dbm)
|
||||
+ DBM_LIBS=""
|
||||
+ ;;
|
||||
--libs)
|
||||
- flags="$flags $LDAP_LIBS $LIBS"
|
||||
+ flags="$flags $LDAP_LIBS $DBM_LIBS $LIBS"
|
||||
;;
|
||||
--ldap-libs)
|
||||
flags="$flags $LDAP_LIBS"
|
||||
;;
|
||||
+ --dbm-libs)
|
||||
+ flags="$flags $DBM_LIBS"
|
||||
+ ;;
|
||||
--includedir)
|
||||
if test "$location" = "installed"; then
|
||||
flags="$includedir"
|
@ -6,6 +6,7 @@
|
||||
|
||||
PORTNAME= apr
|
||||
PORTVERSION= ${APR_VERSION}.${APU_VERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_APACHE}
|
||||
MASTER_SITE_SUBDIR= apr
|
||||
@ -37,6 +38,8 @@ USE_PYTHON_BUILD= yes
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}"
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
APR_WRKDIR= ${WRKDIR}/apr-${APR_VERSION}
|
||||
APU_WRKDIR= ${WRKDIR}/apr-util-${APU_VERSION}
|
||||
@ -49,7 +52,7 @@ APU_CONF_ARGS= --with-apr=${APR_WRKDIR} \
|
||||
--with-expat=${LOCALBASE} \
|
||||
--with-iconv=${LOCALBASE}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
########## APR Options
|
||||
.if defined(WITHOUT_THREADS)
|
||||
@ -177,8 +180,11 @@ PLIST_SUB+= APU_EXTRAS="@comment "
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's/OSVERSION/'${OSVERSION}'/g' \
|
||||
${APR_WRKDIR}/build/apr_hints.m4
|
||||
${FIND} ${WRKDIR} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
${FIND} ${APR_WRKDIR} ${APU_WRKDIR} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
|
||||
${REINPLACE_CMD} -e 's,-lpthreads,${PTHREAD_LIBS},g' \
|
||||
${APR_WRKDIR}/build/apr_threads.m4 ${APR_WRKDIR}/build/apr_hints.m4 \
|
||||
${APU_WRKDIR}/build/apu-conf.m4
|
||||
|
||||
run-autotools::
|
||||
cd ${APR_WRKDIR} ; \
|
||||
@ -220,4 +226,4 @@ debug_autoconf:
|
||||
@${ECHO} "${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS} ${APR_CONF_ARGS}"
|
||||
@${ECHO} "${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS} ${APR_UTIL_CONF_ARGS}"
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
39
devel/apr0/files/patch-apr-util-1.3.7__apu-config.in
Normal file
39
devel/apr0/files/patch-apr-util-1.3.7__apu-config.in
Normal file
@ -0,0 +1,39 @@
|
||||
--- ./apr-util-1.3.7/apu-config.in.orig 2008-05-23 17:27:59.000000000 -0400
|
||||
+++ ./apr-util-1.3.7/apu-config.in 2009-06-10 01:03:50.971447822 -0400
|
||||
@@ -31,6 +31,7 @@
|
||||
INCLUDES="@APRUTIL_INCLUDES@"
|
||||
LDFLAGS="@APRUTIL_LDFLAGS@"
|
||||
LDAP_LIBS="@LDADD_ldap@"
|
||||
+DBM_LIBS="@LDADD_dbm_db@ @LDADD_dbm_gdbm@ @LDADD_dbm_ndbm@"
|
||||
|
||||
APRUTIL_LIBNAME="@APRUTIL_LIBNAME@"
|
||||
|
||||
@@ -56,6 +57,8 @@
|
||||
--libs print library information
|
||||
--avoid-ldap do not include ldap library information with --libs
|
||||
--ldap-libs print additional library information to link with ldap
|
||||
+ --avoid-dbm do not include DBM library information with --libs
|
||||
+ --dbm-libs print additional library information to link with DBM
|
||||
--srcdir print APR-util source directory
|
||||
--link-ld print link switch(es) for linking to APR-util
|
||||
--link-libtool print the libtool inputs for linking to APR-util
|
||||
@@ -115,12 +118,18 @@
|
||||
--avoid-ldap)
|
||||
LDAP_LIBS=""
|
||||
;;
|
||||
+ --avoid-dbm)
|
||||
+ DBM_LIBS=""
|
||||
+ ;;
|
||||
--libs)
|
||||
- flags="$flags $LDAP_LIBS $LIBS"
|
||||
+ flags="$flags $LDAP_LIBS $DBM_LIBS $LIBS"
|
||||
;;
|
||||
--ldap-libs)
|
||||
flags="$flags $LDAP_LIBS"
|
||||
;;
|
||||
+ --dbm-libs)
|
||||
+ flags="$flags $DBM_LIBS"
|
||||
+ ;;
|
||||
--includedir)
|
||||
if test "$location" = "installed"; then
|
||||
flags="$includedir"
|
@ -6,6 +6,7 @@
|
||||
|
||||
PORTNAME= apr
|
||||
PORTVERSION= ${APR_VERSION}.${APU_VERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_APACHE}
|
||||
MASTER_SITE_SUBDIR= apr
|
||||
@ -37,6 +38,8 @@ USE_PYTHON_BUILD= yes
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}"
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
APR_WRKDIR= ${WRKDIR}/apr-${APR_VERSION}
|
||||
APU_WRKDIR= ${WRKDIR}/apr-util-${APU_VERSION}
|
||||
@ -49,7 +52,7 @@ APU_CONF_ARGS= --with-apr=${APR_WRKDIR} \
|
||||
--with-expat=${LOCALBASE} \
|
||||
--with-iconv=${LOCALBASE}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
########## APR Options
|
||||
.if defined(WITHOUT_THREADS)
|
||||
@ -177,8 +180,11 @@ PLIST_SUB+= APU_EXTRAS="@comment "
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's/OSVERSION/'${OSVERSION}'/g' \
|
||||
${APR_WRKDIR}/build/apr_hints.m4
|
||||
${FIND} ${WRKDIR} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
${FIND} ${APR_WRKDIR} ${APU_WRKDIR} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
|
||||
${REINPLACE_CMD} -e 's,-lpthreads,${PTHREAD_LIBS},g' \
|
||||
${APR_WRKDIR}/build/apr_threads.m4 ${APR_WRKDIR}/build/apr_hints.m4 \
|
||||
${APU_WRKDIR}/build/apu-conf.m4
|
||||
|
||||
run-autotools::
|
||||
cd ${APR_WRKDIR} ; \
|
||||
@ -220,4 +226,4 @@ debug_autoconf:
|
||||
@${ECHO} "${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS} ${APR_CONF_ARGS}"
|
||||
@${ECHO} "${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS} ${APR_UTIL_CONF_ARGS}"
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
39
devel/apr1/files/patch-apr-util-1.3.7__apu-config.in
Normal file
39
devel/apr1/files/patch-apr-util-1.3.7__apu-config.in
Normal file
@ -0,0 +1,39 @@
|
||||
--- ./apr-util-1.3.7/apu-config.in.orig 2008-05-23 17:27:59.000000000 -0400
|
||||
+++ ./apr-util-1.3.7/apu-config.in 2009-06-10 01:03:50.971447822 -0400
|
||||
@@ -31,6 +31,7 @@
|
||||
INCLUDES="@APRUTIL_INCLUDES@"
|
||||
LDFLAGS="@APRUTIL_LDFLAGS@"
|
||||
LDAP_LIBS="@LDADD_ldap@"
|
||||
+DBM_LIBS="@LDADD_dbm_db@ @LDADD_dbm_gdbm@ @LDADD_dbm_ndbm@"
|
||||
|
||||
APRUTIL_LIBNAME="@APRUTIL_LIBNAME@"
|
||||
|
||||
@@ -56,6 +57,8 @@
|
||||
--libs print library information
|
||||
--avoid-ldap do not include ldap library information with --libs
|
||||
--ldap-libs print additional library information to link with ldap
|
||||
+ --avoid-dbm do not include DBM library information with --libs
|
||||
+ --dbm-libs print additional library information to link with DBM
|
||||
--srcdir print APR-util source directory
|
||||
--link-ld print link switch(es) for linking to APR-util
|
||||
--link-libtool print the libtool inputs for linking to APR-util
|
||||
@@ -115,12 +118,18 @@
|
||||
--avoid-ldap)
|
||||
LDAP_LIBS=""
|
||||
;;
|
||||
+ --avoid-dbm)
|
||||
+ DBM_LIBS=""
|
||||
+ ;;
|
||||
--libs)
|
||||
- flags="$flags $LDAP_LIBS $LIBS"
|
||||
+ flags="$flags $LDAP_LIBS $DBM_LIBS $LIBS"
|
||||
;;
|
||||
--ldap-libs)
|
||||
flags="$flags $LDAP_LIBS"
|
||||
;;
|
||||
+ --dbm-libs)
|
||||
+ flags="$flags $DBM_LIBS"
|
||||
+ ;;
|
||||
--includedir)
|
||||
if test "$location" = "installed"; then
|
||||
flags="$includedir"
|
@ -6,6 +6,7 @@
|
||||
|
||||
PORTNAME= apr
|
||||
PORTVERSION= ${APR_VERSION}.${APU_VERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_APACHE}
|
||||
MASTER_SITE_SUBDIR= apr
|
||||
@ -37,6 +38,8 @@ USE_PYTHON_BUILD= yes
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}"
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
APR_WRKDIR= ${WRKDIR}/apr-${APR_VERSION}
|
||||
APU_WRKDIR= ${WRKDIR}/apr-util-${APU_VERSION}
|
||||
@ -49,7 +52,7 @@ APU_CONF_ARGS= --with-apr=${APR_WRKDIR} \
|
||||
--with-expat=${LOCALBASE} \
|
||||
--with-iconv=${LOCALBASE}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
########## APR Options
|
||||
.if defined(WITHOUT_THREADS)
|
||||
@ -177,8 +180,11 @@ PLIST_SUB+= APU_EXTRAS="@comment "
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's/OSVERSION/'${OSVERSION}'/g' \
|
||||
${APR_WRKDIR}/build/apr_hints.m4
|
||||
${FIND} ${WRKDIR} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
${FIND} ${APR_WRKDIR} ${APU_WRKDIR} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
|
||||
${REINPLACE_CMD} -e 's,-lpthreads,${PTHREAD_LIBS},g' \
|
||||
${APR_WRKDIR}/build/apr_threads.m4 ${APR_WRKDIR}/build/apr_hints.m4 \
|
||||
${APU_WRKDIR}/build/apu-conf.m4
|
||||
|
||||
run-autotools::
|
||||
cd ${APR_WRKDIR} ; \
|
||||
@ -220,4 +226,4 @@ debug_autoconf:
|
||||
@${ECHO} "${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS} ${APR_CONF_ARGS}"
|
||||
@${ECHO} "${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS} ${APR_UTIL_CONF_ARGS}"
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
39
devel/apr2/files/patch-apr-util-1.3.7__apu-config.in
Normal file
39
devel/apr2/files/patch-apr-util-1.3.7__apu-config.in
Normal file
@ -0,0 +1,39 @@
|
||||
--- ./apr-util-1.3.7/apu-config.in.orig 2008-05-23 17:27:59.000000000 -0400
|
||||
+++ ./apr-util-1.3.7/apu-config.in 2009-06-10 01:03:50.971447822 -0400
|
||||
@@ -31,6 +31,7 @@
|
||||
INCLUDES="@APRUTIL_INCLUDES@"
|
||||
LDFLAGS="@APRUTIL_LDFLAGS@"
|
||||
LDAP_LIBS="@LDADD_ldap@"
|
||||
+DBM_LIBS="@LDADD_dbm_db@ @LDADD_dbm_gdbm@ @LDADD_dbm_ndbm@"
|
||||
|
||||
APRUTIL_LIBNAME="@APRUTIL_LIBNAME@"
|
||||
|
||||
@@ -56,6 +57,8 @@
|
||||
--libs print library information
|
||||
--avoid-ldap do not include ldap library information with --libs
|
||||
--ldap-libs print additional library information to link with ldap
|
||||
+ --avoid-dbm do not include DBM library information with --libs
|
||||
+ --dbm-libs print additional library information to link with DBM
|
||||
--srcdir print APR-util source directory
|
||||
--link-ld print link switch(es) for linking to APR-util
|
||||
--link-libtool print the libtool inputs for linking to APR-util
|
||||
@@ -115,12 +118,18 @@
|
||||
--avoid-ldap)
|
||||
LDAP_LIBS=""
|
||||
;;
|
||||
+ --avoid-dbm)
|
||||
+ DBM_LIBS=""
|
||||
+ ;;
|
||||
--libs)
|
||||
- flags="$flags $LDAP_LIBS $LIBS"
|
||||
+ flags="$flags $LDAP_LIBS $DBM_LIBS $LIBS"
|
||||
;;
|
||||
--ldap-libs)
|
||||
flags="$flags $LDAP_LIBS"
|
||||
;;
|
||||
+ --dbm-libs)
|
||||
+ flags="$flags $DBM_LIBS"
|
||||
+ ;;
|
||||
--includedir)
|
||||
if test "$location" = "installed"; then
|
||||
flags="$includedir"
|
Loading…
Reference in New Issue
Block a user