biology/hisat2: Update to 2.2.1

Changes:        https://github.com/DaehwanKimLab/hisat2/tags
This commit is contained in:
Jason W. Bacon 2021-11-26 16:03:52 -06:00
parent 948157a880
commit d8bc1eb796
6 changed files with 99 additions and 480 deletions

View File

@ -1,6 +1,6 @@
PORTNAME= hisat2
DISTVERSION= 2.1.0-23
DISTVERSIONSUFFIX= -g20f333e
DISTVERSIONPREFIX= v
DISTVERSION= 2.2.1
CATEGORIES= biology perl5 python
MAINTAINER= jwb@FreeBSD.org
@ -9,20 +9,18 @@ COMMENT= Alignment program for mapping next-generation sequencing reads
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
# May work on other 64-bit archs, untested
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= 64-bit code, some assembly language
USES= gmake perl5 python shebangfix
USE_GITHUB= yes
SHEBANG_FILES= hisat2 hisat2-build hisat2-inspect *.py \
scripts/*.sh scripts/*.pl \
hisatgenotype_modules/*.py \
hisatgenotype_scripts/*.py \
hisatgenotype_scripts/*.sh
GH_ACCOUNT= infphilo
SHEBANG_FILES= hisat2 hisat2-build hisat2-inspect \
*.py */*.py */*/*.py */*/*/*.py \
scripts/*.sh evaluation/tests/HLA_novel/scripts/*.sh \
scripts/*.pl docs_jhu/*.pl
GH_ACCOUNT= DaehwanKimLab
MAKEFILE= ${FILESDIR}/Makefile.pkg
CFLAGS+= -Wno-deprecated-declarations -Wno-char-subscripts
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1547001889
SHA256 (infphilo-hisat2-2.1.0-23-g20f333e_GH0.tar.gz) = 7327fa50f51cd1a0fefe1a379cfeb2f06eefdbbe8f49b04b0d79332080f6be57
SIZE (infphilo-hisat2-2.1.0-23-g20f333e_GH0.tar.gz) = 3972398
TIMESTAMP = 1637941870
SHA256 (DaehwanKimLab-hisat2-v2.2.1_GH0.tar.gz) = f3f4f867d0a6b1f880d64efc19deaa5788c62050e0a4d614ce98b3492f702599
SIZE (DaehwanKimLab-hisat2-v2.2.1_GH0.tar.gz) = 6761242

View File

@ -1,446 +0,0 @@
#
# Generic Makefile for package managers
# J Bacon <bacon4000@gmail.com>
#
# This Makefile respects standard make variables provided by package
# managers, such as CXX, CXXFLAGS, etc. It is intended to work on
# any POSIX platform. Default behaviour should be similar to the
# original Makefile.
#
# This file is part of HISAT2.
#
# HISAT 2 is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
# (at your option) any later version.
#
# HISAT 2 is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with HISAT. If not, see <http://www.gnu.org/licenses/>.
#
INC =
GCC_PREFIX = $(shell dirname `which gcc`)
GCC_SUFFIX =
CC ?= $(GCC_PREFIX)/gcc$(GCC_SUFFIX)
CPP ?= $(GCC_PREFIX)/g++$(GCC_SUFFIX)
CXX ?= $(CPP)
CXXFLAGS ?= -O2 -Wall
INSTALL ?= install
HEADERS = $(wildcard *.h)
BOWTIE_MM = 1
BOWTIE_SHARED_MEM = 0
MACOS = 0
ifneq (,$(findstring Darwin,$(shell uname)))
MACOS = 1
endif
# EXTRA_FLAGS += -DPOPCNT_CAPABILITY
INC += -I third_party
MM_DEF =
ifeq (1,$(BOWTIE_MM))
MM_DEF = -DBOWTIE_MM
endif
SHMEM_DEF =
ifeq (1,$(BOWTIE_SHARED_MEM))
SHMEM_DEF = -DBOWTIE_SHARED_MEM
endif
PTHREAD_PKG =
PTHREAD_LIB = -lpthread
SEARCH_LIBS =
BUILD_LIBS =
INSPECT_LIBS =
USE_SRA = 0
SRA_DEF =
SRA_LIB =
SERACH_INC =
ifeq (1,$(USE_SRA))
SRA_DEF = -DUSE_SRA
SRA_LIB = -lncbi-ngs-c++-static -lngs-c++-static -lncbi-vdb-static -ldl
SEARCH_INC += -I$(NCBI_NGS_DIR)/include -I$(NCBI_VDB_DIR)/include
SEARCH_LIBS += -L$(NCBI_NGS_DIR)/lib64 -L$(NCBI_VDB_DIR)/lib64
endif
LIBS = $(PTHREAD_LIB)
SHARED_CPPS = ccnt_lut.cpp ref_read.cpp alphabet.cpp shmem.cpp \
edit.cpp gfm.cpp \
reference.cpp ds.cpp multikey_qsort.cpp limit.cpp \
random_source.cpp tinythread.cpp
SEARCH_CPPS = qual.cpp pat.cpp \
read_qseq.cpp aligner_seed_policy.cpp \
aligner_seed.cpp \
aligner_seed2.cpp \
aligner_sw.cpp \
aligner_sw_driver.cpp aligner_cache.cpp \
aligner_result.cpp ref_coord.cpp mask.cpp \
pe.cpp aln_sink.cpp dp_framer.cpp \
scoring.cpp presets.cpp unique.cpp \
simple_func.cpp \
random_util.cpp \
aligner_bt.cpp sse_util.cpp \
aligner_swsse.cpp outq.cpp \
aligner_swsse_loc_i16.cpp \
aligner_swsse_ee_i16.cpp \
aligner_swsse_loc_u8.cpp \
aligner_swsse_ee_u8.cpp \
aligner_driver.cpp \
splice_site.cpp
SEARCH_OBJS = qual.o pat.o \
read_qseq.o aligner_seed_policy.o \
aligner_seed.o \
aligner_seed2.o \
aligner_sw.o \
aligner_sw_driver.o aligner_cache.o \
aligner_result.o ref_coord.o mask.o \
pe.o aln_sink.o dp_framer.o \
scoring.o presets.o unique.o \
simple_func.o \
random_util.o \
aligner_bt.o sse_util.o \
aligner_swsse.o outq.o \
aligner_swsse_loc_i16.o \
aligner_swsse_ee_i16.o \
aligner_swsse_loc_u8.o \
aligner_swsse_ee_u8.o \
aligner_driver.o \
splice_site.o
BUILD_CPPS = diff_sample.cpp
HISAT2_CPPS_MAIN = $(SEARCH_CPPS) hisat2_main.cpp
HISAT2_BUILD_CPPS_MAIN = $(BUILD_CPPS) hisat2_build_main.cpp
SEARCH_FRAGMENTS = $(wildcard search_*_phase*.c)
VERSION = $(shell cat VERSION)
DEBUG_FLAGS = $(CXXFLAGS) -O0 -g3
DEBUG_DEFS = -DCOMPILER_OPTIONS="\"$(DEBUG_FLAGS) $(EXTRA_FLAGS)\""
RELEASE_FLAGS = $(CXXFLAGS)
RELEASE_DEFS = -DCOMPILER_OPTIONS="\"$(RELEASE_FLAGS) $(EXTRA_FLAGS)\""
NOASSERT_FLAGS = -DNDEBUG
FILE_FLAGS = -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
ifeq (1,$(USE_SRA))
ifeq (1, $(MACOS))
DEBUG_FLAGS += -mmacosx-version-min=10.6
RELEASE_FLAGS += -mmacosx-version-min=10.6
endif
endif
HISAT2_BIN_LIST = hisat2-build-s \
hisat2-build-l \
hisat2-align-s \
hisat2-align-l \
hisat2-inspect-s \
hisat2-inspect-l
HISAT2_BIN_LIST_AUX = hisat2-build-s-debug \
hisat2-build-l-debug \
hisat2-align-s-debug \
hisat2-align-l-debug \
hisat2-inspect-s-debug \
hisat2-inspect-l-debug
GENERAL_LIST = $(wildcard scripts/*.sh) \
$(wildcard scripts/*.pl) \
$(wildcard *.py) \
$(wildcard hisatgenotype_modules/*.py) \
$(wildcard hisatgenotype_scripts/*.py) \
doc/manual.inc.html \
doc/README \
doc/style.css \
$(wildcard example/index/*.ht2) \
$(wildcard example/reads/*.fa) \
example/reference/22_20-21M.fa \
example/reference/22_20-21M.snp \
$(PTHREAD_PKG) \
hisat2 \
hisat2-build \
hisat2-inspect \
AUTHORS \
LICENSE \
NEWS \
MANUAL \
MANUAL.markdown \
TUTORIAL \
VERSION
ifeq (1,$(WINDOWS))
HISAT2_BIN_LIST := $(HISAT2_BIN_LIST) hisat2.bat hisat2-build.bat hisat2-inspect.bat
endif
# This is helpful on Windows under MinGW/MSYS, where Make might go for
# the Windows FIND tool instead.
FIND=$(shell which find)
SRC_PKG_LIST = $(wildcard *.h) \
$(wildcard *.hh) \
$(wildcard *.c) \
$(wildcard *.cpp) \
doc/strip_markdown.pl \
Makefile \
$(GENERAL_LIST)
BIN_PKG_LIST = $(GENERAL_LIST)
.PHONY: all allall both both-debug install
all: $(HISAT2_BIN_LIST)
allall: $(HISAT2_BIN_LIST) $(HISAT2_BIN_LIST_AUX)
both: hisat2-align-s hisat2-align-l hisat2-build-s hisat2-build-l
both-debug: hisat2-align-s-debug hisat2-align-l-debug hisat2-build-s-debug hisat2-build-l-debug
DEFS=-fno-strict-aliasing \
-DHISAT2_VERSION="\"`cat VERSION`\"" \
-DBUILD_HOST="\"`hostname`\"" \
-DBUILD_TIME="\"`date`\"" \
-DCOMPILER_VERSION="\"`$(CXX) -v 2>&1 | tail -1`\"" \
$(FILE_FLAGS) \
$(PREF_DEF) \
$(MM_DEF) \
$(SHMEM_DEF)
#
# hisat-bp targets
#
hisat-bp-bin: hisat_bp.cpp $(SEARCH_CPPS) $(SHARED_CPPS) $(HEADERS) $(SEARCH_FRAGMENTS)
$(CXX) $(RELEASE_FLAGS) $(RELEASE_DEFS) $(EXTRA_FLAGS) \
$(DEFS) -DBOWTIE2 $(NOASSERT_FLAGS) \
$(INC) \
-o $@ $< \
$(SHARED_CPPS) $(HISAT_CPPS_MAIN) \
$(LIBS) $(SEARCH_LIBS)
hisat-bp-bin-debug: hisat_bp.cpp $(SEARCH_CPPS) $(SHARED_CPPS) $(HEADERS) $(SEARCH_FRAGMENTS)
$(CXX) $(DEBUG_FLAGS) \
$(DEBUG_DEFS) $(EXTRA_FLAGS) \
$(DEFS) -DBOWTIE2 \
$(INC) \
-o $@ $< \
$(SHARED_CPPS) $(HISAT_CPPS_MAIN) \
$(LIBS) $(SEARCH_LIBS)
#
# hisat2-build targets
#
hisat2-build-s: hisat2_build.cpp $(SHARED_CPPS) $(HEADERS)
$(CXX) $(RELEASE_FLAGS) $(RELEASE_DEFS) $(EXTRA_FLAGS) \
$(DEFS) -DBOWTIE2 $(NOASSERT_FLAGS) -DMASSIVE_DATA_RLCSA \
$(INC) \
-o $@ $< \
$(SHARED_CPPS) $(HISAT2_BUILD_CPPS_MAIN) \
$(LIBS) $(BUILD_LIBS)
hisat2-build-l: hisat2_build.cpp $(SHARED_CPPS) $(HEADERS)
$(CXX) $(RELEASE_FLAGS) $(RELEASE_DEFS) $(EXTRA_FLAGS) \
$(DEFS) -DBOWTIE2 -DBOWTIE_64BIT_INDEX $(NOASSERT_FLAGS) \
$(INC) \
-o $@ $< \
$(SHARED_CPPS) $(HISAT2_BUILD_CPPS_MAIN) \
$(LIBS) $(BUILD_LIBS)
hisat2-build-s-debug: hisat2_build.cpp $(SHARED_CPPS) $(HEADERS)
$(CXX) $(DEBUG_FLAGS) $(DEBUG_DEFS) $(EXTRA_FLAGS) \
$(DEFS) -DBOWTIE2 -DMASSIVE_DATA_RLCSA \
$(INC) \
-o $@ $< \
$(SHARED_CPPS) $(HISAT2_BUILD_CPPS_MAIN) \
$(LIBS) $(BUILD_LIBS)
hisat2-build-l-debug: hisat2_build.cpp $(SHARED_CPPS) $(HEADERS)
$(CXX) $(DEBUG_FLAGS) $(DEBUG_DEFS) $(EXTRA_FLAGS) \
$(DEFS) -DBOWTIE2 -DBOWTIE_64BIT_INDEX \
$(INC) \
-o $@ $< \
$(SHARED_CPPS) $(HISAT2_BUILD_CPPS_MAIN) \
$(LIBS) $(BUILD_LIBS)
#
# hisat2 targets
#
hisat2-align-s: hisat2.cpp $(SEARCH_CPPS) $(SHARED_CPPS) $(HEADERS) $(SEARCH_FRAGMENTS)
$(CXX) $(RELEASE_FLAGS) $(RELEASE_DEFS) $(EXTRA_FLAGS) \
$(DEFS) $(SRA_DEF) -DBOWTIE2 $(NOASSERT_FLAGS) \
$(INC) $(SEARCH_INC) \
-o $@ $< \
$(SHARED_CPPS) $(HISAT2_CPPS_MAIN) \
$(LIBS) $(SRA_LIB) $(SEARCH_LIBS)
hisat2-align-l: hisat2.cpp $(SEARCH_CPPS) $(SHARED_CPPS) $(HEADERS) $(SEARCH_FRAGMENTS)
$(CXX) $(RELEASE_FLAGS) $(RELEASE_DEFS) $(EXTRA_FLAGS) \
$(DEFS) $(SRA_DEF) -DBOWTIE2 -DBOWTIE_64BIT_INDEX $(NOASSERT_FLAGS) \
$(INC) $(SEARCH_INC) \
-o $@ $< \
$(SHARED_CPPS) $(HISAT2_CPPS_MAIN) \
$(LIBS) $(SRA_LIB) $(SEARCH_LIBS)
hisat2-align-s-debug: hisat2.cpp $(SEARCH_CPPS) $(SHARED_CPPS) $(HEADERS) $(SEARCH_FRAGMENTS)
$(CXX) $(DEBUG_FLAGS) \
$(DEBUG_DEFS) $(EXTRA_FLAGS) \
$(DEFS) $(SRA_DEF) -DBOWTIE2 \
$(INC) $(SEARCH_INC) \
-o $@ $< \
$(SHARED_CPPS) $(HISAT2_CPPS_MAIN) \
$(LIBS) $(SRA_LIB) $(SEARCH_LIBS)
hisat2-align-l-debug: hisat2.cpp $(SEARCH_CPPS) $(SHARED_CPPS) $(HEADERS) $(SEARCH_FRAGMENTS)
$(CXX) $(DEBUG_FLAGS) \
$(DEBUG_DEFS) $(EXTRA_FLAGS) \
$(DEFS) $(SRA_DEF) -DBOWTIE2 -DBOWTIE_64BIT_INDEX \
$(INC) $(SEARCH_INC) \
-o $@ $< \
$(SHARED_CPPS) $(HISAT2_CPPS_MAIN) \
$(LIBS) $(SRA_LIB) $(SEARCH_LIBS)
#
# hisat2-inspect targets
#
hisat2-inspect-s: hisat2_inspect.cpp $(HEADERS) $(SHARED_CPPS)
$(CXX) $(RELEASE_FLAGS) \
$(RELEASE_DEFS) $(EXTRA_FLAGS) \
$(DEFS) -DBOWTIE2 -DHISAT2_INSPECT_MAIN \
$(INC) -I . \
-o $@ $< \
$(SHARED_CPPS) \
$(LIBS) $(INSPECT_LIBS)
hisat2-inspect-l: hisat2_inspect.cpp $(HEADERS) $(SHARED_CPPS)
$(CXX) $(RELEASE_FLAGS) \
$(RELEASE_DEFS) $(EXTRA_FLAGS) \
$(DEFS) -DBOWTIE2 -DBOWTIE_64BIT_INDEX -DHISAT2_INSPECT_MAIN \
$(INC) -I . \
-o $@ $< \
$(SHARED_CPPS) \
$(LIBS) $(INSPECT_LIBS)
hisat2-inspect-s-debug: hisat2_inspect.cpp $(HEADERS) $(SHARED_CPPS)
$(CXX) $(DEBUG_FLAGS) \
$(DEBUG_DEFS) $(EXTRA_FLAGS) \
$(DEFS) -DBOWTIE2 -DHISAT2_INSPECT_MAIN \
$(INC) -I . \
-o $@ $< \
$(SHARED_CPPS) \
$(LIBS) $(INSPECT_LIBS)
hisat2-inspect-l-debug: hisat2_inspect.cpp $(HEADERS) $(SHARED_CPPS)
$(CXX) $(DEBUG_FLAGS) \
$(DEBUG_DEFS) $(EXTRA_FLAGS) \
$(DEFS) -DBOWTIE2 -DBOWTIE_64BIT_INDEX -DHISAT2_INSPECT_MAIN \
$(INC) -I . \
-o $@ $< \
$(SHARED_CPPS) \
$(LIBS) $(INSPECT_LIBS)
%.o: %.cpp
$(CXX) -c $(RELEASE_FLAGS) \
$(RELEASE_DEFS) $(EXTRA_FLAGS) \
$(DEFS) -DBOWTIE2 -DHISAT2_INSPECT_MAIN \
$(INC) -I . $< -o $@ $<
hisat2: ;
hisat2.bat:
echo "@echo off" > hisat2.bat
echo "perl %~dp0/hisat2 %*" >> hisat2.bat
hisat2-build.bat:
echo "@echo off" > hisat2-build.bat
echo "python %~dp0/hisat2-build %*" >> hisat2-build.bat
hisat2-inspect.bat:
echo "@echo off" > hisat2-inspect.bat
echo "python %~dp0/hisat2-inspect %*" >> hisat2-inspect.bat
.PHONY: hisat2-src
hisat2-src: $(SRC_PKG_LIST)
chmod a+x scripts/*.sh scripts/*.pl
mkdir .src.tmp
mkdir .src.tmp/hisat2-$(VERSION)
zip tmp.zip $(SRC_PKG_LIST)
mv tmp.zip .src.tmp/hisat2-$(VERSION)
cd .src.tmp/hisat2-$(VERSION) ; unzip tmp.zip ; rm -f tmp.zip
cd .src.tmp ; zip -r hisat2-$(VERSION)-source.zip hisat2-$(VERSION)
cp .src.tmp/hisat2-$(VERSION)-source.zip .
rm -rf .src.tmp
.PHONY: hisat2-bin
hisat2-bin: $(BIN_PKG_LIST) $(HISAT2_BIN_LIST) $(HISAT2_BIN_LIST_AUX)
chmod a+x scripts/*.sh scripts/*.pl
rm -rf .bin.tmp
mkdir .bin.tmp
mkdir .bin.tmp/hisat2-$(VERSION)
if [ -f hisat2.exe ] ; then \
zip tmp.zip $(BIN_PKG_LIST) $(addsuffix .exe,$(HISAT2_BIN_LIST) $(HISAT2_BIN_LIST_AUX)) ; \
else \
zip tmp.zip $(BIN_PKG_LIST) $(HISAT2_BIN_LIST) $(HISAT2_BIN_LIST_AUX) ; \
fi
mv tmp.zip .bin.tmp/hisat2-$(VERSION)
cd .bin.tmp/hisat2-$(VERSION) ; unzip tmp.zip ; rm -f tmp.zip
cd .bin.tmp ; zip -r hisat2-$(VERSION)-$(BITS).zip hisat2-$(VERSION)
cp .bin.tmp/hisat2-$(VERSION)-$(BITS).zip .
rm -rf .bin.tmp
.PHONY: doc
doc: doc/manual.inc.html MANUAL
doc/manual.inc.html: MANUAL.markdown
pandoc -T "HISAT2 Manual" -o $@ \
--from markdown --to HTML --toc $^
perl -i -ne \
'$$w=0 if m|^</body>|;print if $$w;$$w=1 if m|^<body>|;' $@
MANUAL: MANUAL.markdown
perl doc/strip_markdown.pl < $^ > $@
# Install per filesystem hierarchy standard:
# https://en.wikipedia.org/wiki/Filesystem_Hierarchy_Standard
.PHONY: install
install:
mkdir -p ${DESTDIR}${PREFIX}/bin
${INSTALL} -c -s ${HISAT2_BIN_LIST} ${DESTDIR}${PREFIX}/bin
${INSTALL} -c hisat2 hisat2-build hisat2-inspect \
${DESTDIR}${PREFIX}/bin
mkdir -p ${DESTDIR}${PREFIX}/libexec/hisat2
${INSTALL} -c scripts/*.sh scripts/*.pl *.py \
hisatgenotype_modules/hisat*.py \
hisatgenotype_scripts/*.py hisatgenotype_scripts/*.sh \
${DESTDIR}${PREFIX}/libexec/hisat2
.PHONY: clean
clean:
rm -f $(HISAT2_BIN_LIST) $(HISAT2_BIN_LIST_AUX) \
$(addsuffix .exe,$(HISAT2_BIN_LIST) $(HISAT2_BIN_LIST_AUX)) \
hisat2-src.zip hisat2-bin.zip
rm -f core.* .tmp.head
rm -rf *.dSYM
.PHONY: push-doc
push-doc: doc/manual.inc.html
scp doc/*.*html doc/indexes.txt salz-dmz:/ccb/salz7-data/www/ccb.jhu.edu/html/software/hisat2/

View File

@ -0,0 +1,71 @@
--- Makefile.orig 2020-07-24 20:07:54 UTC
+++ Makefile
@@ -23,9 +23,11 @@
INC =
GCC_PREFIX = $(shell dirname `which gcc`)
GCC_SUFFIX =
-CC = $(GCC_PREFIX)/gcc$(GCC_SUFFIX)
-CPP = $(GCC_PREFIX)/g++$(GCC_SUFFIX)
-CXX = $(CPP)
+CC ?= $(GCC_PREFIX)/gcc$(GCC_SUFFIX)
+CPP ?= $(GCC_PREFIX)/g++$(GCC_SUFFIX)
+CXX ?= $(CPP)
+INSTALL ?= install
+
HEADERS = $(wildcard *.h)
BOWTIE_MM = 1
BOWTIE_SHARED_MEM = 0
@@ -152,31 +154,9 @@ HISAT2_REPEAT_CPPS_MAIN = $(REPEAT_CPPS) $(BUILD_CPPS)
SEARCH_FRAGMENTS = $(wildcard search_*_phase*.c)
VERSION = $(shell cat VERSION)
-# Convert BITS=?? to a -m flag
-BITS=32
-ifeq (x86_64,$(shell uname -m))
-BITS=64
-endif
-# msys will always be 32 bit so look at the cpu arch instead.
-ifneq (,$(findstring AMD64,$(PROCESSOR_ARCHITEW6432)))
- ifeq (1,$(MINGW))
- BITS=64
- endif
-endif
-BITS_FLAG =
-
-ifeq (32,$(BITS))
- BITS_FLAG = -m32
-endif
-
-ifeq (64,$(BITS))
- BITS_FLAG = -m64
-endif
-SSE_FLAG=-msse2
-
DEBUG_FLAGS = -O0 -g3 $(BITS_FLAG) $(SSE_FLAG)
DEBUG_DEFS = -DCOMPILER_OPTIONS="\"$(DEBUG_FLAGS) $(EXTRA_FLAGS)\""
-RELEASE_FLAGS = -O3 $(BITS_FLAG) $(SSE_FLAG) -funroll-loops -g3
+RELEASE_FLAGS = $(CXXFLAGS)
RELEASE_DEFS = -DCOMPILER_OPTIONS="\"$(RELEASE_FLAGS) $(EXTRA_FLAGS)\""
NOASSERT_FLAGS = -DNDEBUG
FILE_FLAGS = -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
@@ -553,6 +533,20 @@ doc/manual.inc.html: MANUAL.markdown
MANUAL: MANUAL.markdown
perl doc/strip_markdown.pl < $^ > $@
+
+# Install per filesystem hierarchy standard:
+# https://en.wikipedia.org/wiki/Filesystem_Hierarchy_Standard
+
+.PHONY: install
+install:
+ mkdir -p ${DESTDIR}${PREFIX}/bin
+ ${INSTALL} -c -s ${HISAT2_BIN_LIST} ${DESTDIR}${PREFIX}/bin
+ ${INSTALL} -c hisat2 hisat2-build hisat2-inspect \
+ ${DESTDIR}${PREFIX}/bin
+
+ mkdir -p ${DESTDIR}${PREFIX}/libexec/hisat2
+ ${INSTALL} -c scripts/*.sh scripts/*.pl scripts/*.py *.py \
+ ${DESTDIR}${PREFIX}/libexec/hisat2
.PHONY: clean
clean:

View File

@ -0,0 +1,11 @@
--- util.h.orig 2021-11-26 15:40:17 UTC
+++ util.h
@@ -43,7 +43,7 @@ char* itoa10(const T& value, char* result) {
// Only apply negative sign for base 10
if(std::numeric_limits<T>::is_signed) {
// Avoid compiler warning in cases where T is unsigned
- if (value <= 0 && value != 0) *out++ = '-';
+ if (value <= 0) *out++ = '-';
}
reverse( result, out );
*out = 0; // terminator

View File

@ -7,9 +7,8 @@ bin/hisat2-build-s
bin/hisat2-inspect
bin/hisat2-inspect-l
bin/hisat2-inspect-s
libexec/hisat2/compare_HLA_Omixon.py
bin/hisat2-repeat
libexec/hisat2/convert_quals.pl
libexec/hisat2/extract_Omixon_HLA.py
libexec/hisat2/extract_exons.py
libexec/hisat2/extract_splice_sites.py
libexec/hisat2/gen_2b_occ_lookup.pl
@ -19,21 +18,8 @@ libexec/hisat2/hisat2_extract_exons.py
libexec/hisat2/hisat2_extract_snps_haplotypes_UCSC.py
libexec/hisat2/hisat2_extract_snps_haplotypes_VCF.py
libexec/hisat2/hisat2_extract_splice_sites.py
libexec/hisat2/hisat2_read_statistics.py
libexec/hisat2/hisat2_simulate_reads.py
libexec/hisat2/hisatgenotype.py
libexec/hisat2/hisatgenotype_HLA_genotyping_PGs.py
libexec/hisat2/hisatgenotype_assembly_graph.py
libexec/hisat2/hisatgenotype_build_genome.py
libexec/hisat2/hisatgenotype_convert_codis.py
libexec/hisat2/hisatgenotype_extract_codis_data.py
libexec/hisat2/hisatgenotype_extract_cyp_data.py
libexec/hisat2/hisatgenotype_extract_reads.py
libexec/hisat2/hisatgenotype_extract_vars.py
libexec/hisat2/hisatgenotype_gene_typing.py
libexec/hisat2/hisatgenotype_hla_cyp.py
libexec/hisat2/hisatgenotype_locus.py
libexec/hisat2/hisatgenotype_locus_samples.py
libexec/hisat2/hisatgenotype_typing_common.py
libexec/hisat2/infer_fraglen.pl
libexec/hisat2/make_a_thaliana_tair.sh
libexec/hisat2/make_b_taurus_UMD3.sh
@ -49,7 +35,9 @@ libexec/hisat2/make_grch37_snp_tran.sh
libexec/hisat2/make_grch37_snp_tran_ercc.sh
libexec/hisat2/make_grch37_tran.sh
libexec/hisat2/make_grch38.sh
libexec/hisat2/make_grch38_rep.sh
libexec/hisat2/make_grch38_snp.sh
libexec/hisat2/make_grch38_snp_rep.sh
libexec/hisat2/make_grch38_snp_tran.sh
libexec/hisat2/make_grch38_snp_tran_ercc.sh
libexec/hisat2/make_grch38_tran.sh
@ -74,8 +62,5 @@ libexec/hisat2/make_sc3.sh
libexec/hisat2/make_wbcel235.sh
libexec/hisat2/make_wbcel235_tran.sh
libexec/hisat2/make_zm3_snp_tran_ercc.sh
libexec/hisat2/run_extract_CP.sh
libexec/hisat2/run_extract_ILMN.sh
libexec/hisat2/run_genotype_build.sh
libexec/hisat2/run_hisat2_build.sh
libexec/hisat2/run_type_CP.sh
libexec/hisat2/sa.py
libexec/hisat2/validate_repeat.py